1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Unreal2 Awakening crash, XP x64 SP2, Quad Core

Discussion in 'Unreal 2' started by noabody, Aug 30, 2009.

  1. noabody

    noabody New Member

    Aug 30, 2009
    Likes Received:
    First off some of you may already know this and the fix is probably posted in the message board but I didn't find it within one Google search so I wanted the topic to be as detailed as possible.

    I'm running XP x64 Pro Sp2 with AMD Phenom 9950 quad core (2.6 Ghz) on Biostar TA790GX3 A2 board and Radeon HD 4800. Built in sound is ALC888. The game runs fine with full detail but was crashing to desktop upon loading a quicksave. Event log shows event 1000: Faulting application unreal2.exe, version, faulting module dmusic.dll, version 5.3.3790.3959, fault address 0x0001472a.

    I read that OpenAL is problematic and although I don't have EAX enabled, sound effects are handled by file DefOpenAL32.dll in the system folder. Properties for this file have this comment: Creative DS3D Wrapper Implementation. This file wraps OpenAL calls to DirectSound and looks like the culprit. I found this solution just after I figured it out on my own.


    The updated DefOpenAL.dll is here: http://connect.creativelabs.com/openal/Downloads/Forms/AllItems.aspx Install Oalinst, then go to your System32 or SysWOW64 folder and copy the wrap_oal.dll to your Unreal2 system directory. Then rename it to DefOpenAL.dll and there you go (the usual one is v0.9.9, the new one is v2.2.0.5).

    If you're running x64 then you want the file from C:\Windows\SysWOW64\wrap_oal.dll. For XP 32 you want C:\Windows\System32\wrap_oal.dll. The crashing stopped after I updated the OpenAl wrapper. Hopefully this solution will show up in the top Google list when someone searches for Unreal2, OpenAl, and crash. I love it when somebody else solves my problems with a quick search on the internet.
    Last edited: Aug 30, 2009
  2. Manticore

    Manticore Official BUF Birthday Spammer

    Nov 5, 2003
    Likes Received:
    This is still relevant.

Share This Page