1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Skinart Animating

Discussion in 'General and Off Topic' started by Warslut, Nov 25, 2004.

  1. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    You're talking about masking off areas of the texture so that only small bits are animated, like having animated veins on an otherwise static texture, right?

    I'll get back to you on this real soon. I'm not 100% sure of the steps, so I'm gonna play with some stuff then come back with the answer for ya.
     
  2. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    Yes thats what I meant, Take your time, thank you very much :)
     
  3. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    Warslut, I've updated my tutorial a little. No new steps or anything, but there's a new texture pack at the bottom that you can download that should make some things clearer.

    Note that the textures "skinplate" and "veinmask" in there have alpha channels. "veinmask" was imported with the Alpha checkbox on, "skinplate" was imported with the Alpha checkbox off. All that really does is tell UnrealEd whether or not to apply the embedded Alpha channel to the texture's opacity or not. You can see that "veinmask" has transparent areas in the Texture Browser, but "skinplate" does not, even though they both have alpha channels.

    Sorry I couldn't do another tutorial or section just for that. Maybe later when I have time, but for now I hope that helps out some. :) Just remember to pick apart everything, even if it means you have to export the texture files. ;)
     
  4. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    Ok, I think I know where I'm going here but I cant get the texture to animate anymore... and I don't fully under stand what to do...
     
  5. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    Aw crap... I've discovered a bug in that last texture pack.... I'm going to have to rework it at home. For some reason it works under win2000, on a GeForceFX5700, but it doesn't work on a GeForce2 Go... I'll give it another look. Could be part of the problem you're having... I'll get back to you soon.
     
  6. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    Think it would work fine if the modifier, animation thingy would actually go into the shader... just refuses to when i click use.

    Think I could get it to work find if the damn thing would import with tranparent bg like it suppost to be in photoshop! >_<

    BTW I use Targa format...
     
    Last edited: Dec 5, 2004
  7. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    It just goes either all white (on the 3D views) or blank (flat view) when you put the Modifier into the Shader, right? I seem to get that problem as well, especially when doing certain combinations. I rechecked the tjtutorialtexturepack_ii.zip texture at home and it works fine, so I'm stumped.

    It's too bad UDN's documents don't go into more detail about this kind of problem.

    Also, if you don't already have it, download the Photoshop plugin on this page:
    http://developer.nvidia.com/object/nv_texture_tools.html

    It will allow you to import and export .dds files (DXT1, DXT3, DXT5, etc...).

    If you want the background to be transparent, make sure you're saving your .tga as 32-bit, not 24-bit. 24-bit .tga files do not contain any alpha information. Then make sure you're checking the Alpha check box when importing into UnrealEd.

    If you use the Photoshop plugin mentioned above, make sure you're saving it as a DXT3 or DXT5 file, and check to make sure the Alpha setting is on.

    That should cover almost any problem you may be having... the only other thing I can think of is maybe the .tga format isn't working well with UnrealEd. If that's the case, I'd try one of the DirectX formats. They're also smaller in size than .tga formats and should reduce your texture package size.

    EDIT: Damn! I figured out why the texture package wasn't working. In the main UnrealEd viewport, under View>Rendering Emulation, there's options for None, GeForce 1, GeForce 2, and Xbox. I opened my Texture browser, enabled GeForce 2, then watched as some of my textures went white. Apparently GeForce 2 GPUs and below won't render the material properly. If you have any of those, then that would lead me to believe that's where your problem lies. Ah well... off to update the tutorial to include that info. ;)

    -Tj-
     
    Last edited: Dec 5, 2004
  8. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    I knew it would be something stupid like that >_< It works now great thanks a lot. Only now I forgot how to make that texture in use... :S

    Got everything how I want it now, just need to know how to use it... also if possible how to make team colors enables :(
     
    Last edited: Dec 5, 2004
  9. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    Ah yeah, that was one thing that went over my head... I completely forgot that whatever material you want to use on a character won't be used in-game until you define the texture set in a .upl file.

    Easiest way to do this is to open up the .upl of the character you're skinning, edit the BodySkin and FaceSkin values so that they use your skin, give the character a name, then save that file to a NEW file (don't overwrite the .upl of the file you're editing!).

    The format to use is PackageName.MaterialName

    For example, if my texture package name is GoatTexturePackage, and the body texture I want to use in that package is Goat_Final_Material, I would type in that section this info:

    BodySkin=GoatTexturePackage.Goat_Body

    This ignores material grouping in the texture browser (it's just an organizational thing anyway). Then all you need to do is save the .upl as a new file with a logical name. In my case I'd probably save it as "Goat2k4.upl". The addition of "2k4" or "2004" at the end makes it easier to see at a glance if the file is meant for UT2k3 or UT2k4, or whatever version of UT comes next.

    As for team colors, I think there's a tutorial on this forum already that can help with that:
    http://forums.beyondunreal.com/showthread.php?t=141262

    Your .upl should look like mine does below:

    [Public]
    Player=(DefaultName="Goat",Race="ThunderCrash",Mesh=HumanMaleA.MercMaleD,species=xGame.SPECIES_Merc,BodySkin=GoatTexturePackage.Goat_Body,FaceSkin=GoatTexturePackage.Goat_Head,Portrait=GoatTexturePackage.Goat_Portrait,Text=XGoat.Goat,Sex=Male,Menu="SP",Tactics=1.0,StrafingAbility=1.0,Accuracy=0.5,BotUse=1)

    That should help, lemme know if that works. :)
     
  10. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    Everything works perfect accept... when the team colors go, it only works on body, and not head :S I can't find out why.
     
  11. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    I think you forgot to put the TeamFace=1 setting in your .upl file. You can put it right at the end of the string of settings, so in the example above, it would be:

    [Public]
    Player=(DefaultName="Goat",Race="ThunderCrash",Mesh=HumanMaleA.MercMaleD,species=xGame.SPECIES_Merc,BodySkin=GoatTexturePackage.Goat_Body,FaceSkin =GoatTexturePackage.Goat_Head,Portrait=GoatTexturePackage.Goat_Portrait,Text=XGoat.Goat,Sex=Male,Men u="SP",Tactics=1.0,StrafingAbility=1.0,Accuracy=0.5,BotUse=1,TeamFace=1)

    I just tested it out here and saw the problem you had. No team skin switch for the head. It works after you put the TeamFace option in there, though. I'm pretty sure that'll do it. :)

    -Tj-
     
    Last edited: Dec 5, 2004
  12. Warslut

    Warslut The Slut!

    Joined:
    Nov 8, 2004
    Messages:
    78
    Likes Received:
    0
    It works... thats every... thanks a million man =) I'm going to submit skin now called 'Warslut' look out for it soon ^_^
     
  13. -Tj-

    -Tj- New Member

    Joined:
    Nov 30, 2004
    Messages:
    268
    Likes Received:
    0
    Happy to help :)

    Glad you got through everything. I'll keep an eye out for the skin download. ;)

    -Tj-
     

Share This Page