1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Precaching taking excessive time and...

Discussion in 'Original Unreal Tournament' started by tyaalii, Dec 2, 1999.

Thread Status:
Not open for further replies.
  1. tyaalii

    tyaalii New Member

    Joined:
    Dec 2, 1999
    Messages:
    7
    Likes Received:
    0
    I've been combing the last few days of posts and haven't seen this problem resolved.

    I have a p3 450 wtih 128megs of ram, with a v770 ultra tnt2... plenty meat for UT. The game runs fine---kind of. The only problem is precaching takes more than two full mintes, I timed it, and then once the match starts, there is an approximately 1 second pause whenever I see something new, like a person, a weapon or a texture. That makes the first few minutes of DM excruciating.

    Other people had this problem? Help an Id Fanboy become an ex-Id Fanboy! Thanks all.
     
  2. tyaalii

    tyaalii New Member

    Joined:
    Dec 2, 1999
    Messages:
    7
    Likes Received:
    0
    A continuation of my story:

    I downloaded the latest SB Live drivers, the latest Diamond drivers, the latest detonator drivers. I tried turning off precache.

    Even more extreme jerkiness initially w/o precache, w/precache same deal. Long wait, LONG wait, then long wait nbetween frames if you know what I mean.

    I tried lowering the textures and detail to the max. That makes the choppiness less when it happens, but it still rudely intrudes on a normally perfectly smooth gameplay.

    Very frustration! Suggestions would be appreciated.

    I'm having tons of hard drive reading during play--is my 128 mg of ram bloated by windows or something? This sucks buttx0r.
     
  3. RW

    RW New Member

    Joined:
    Nov 24, 1999
    Messages:
    234
    Likes Received:
    0
    I will try and help but I don't have a TNT card and any pre-cache problems. In UT advanced options/advanced/game engine settings, change the "game engine cache from the default of 4MB up to at least 20MB. In advanced options/audio, disable the "use 3d hardware" since EAX support is borked anyway. In advanced options/rendering/d3d see if you can increase the "refresh rate" from the default of 60 Hz up to at least 100Hz.

    Now here is a post or part of a post that I did a few days ago and I got this from another site but it should help your reduce your hard drive hitching a bit.

    "Step 1. CLOSE YOUR DAMN PROGRAMS!

    The biggest waste of RAM can be misc. programs that aren't essential
    for Windows to run. This includes any StartUp group programs,
    services, etc. that you don't need, and that aren't required for
    Windows to run. To get rid of this crap, delete the item from the
    StartUp group, or use MSConfig to disable services that you don't
    need. The only things that should be in your systray are the clock,
    and the UT server icon. Try to avoid running any FTP/Web servers as
    they can hog a lot of RAM, and may affect your speed. One other
    thing to do is get rid of any backround picture you may have on your
    desktop. An 800x600 16-bit background consumes around 1 meg or so of
    memory, so git rid of it! If you are running active desktop, turn
    that mofo off as well. You need all the RAM you can get! Also, you
    may want to try turning your color depth down to 16 bit colors. It may
    help, or it may not. Be sure to close all virus and ICQ programs,
    this is a must. My system at boot only has the windows exployer and
    systry running and starts off with a cpu that is 97% free.

    Step 2. Tame that swapfile!

    If your swapfile isn't already setup as a permanent swapfile, doing
    this is a MUST! The reason being is that Windows will dynamically
    change the swapfile to meet its needs, thereby wasting precious CPU
    cycles and causing unnecessary disk access. This will cause your
    system to not perform at 100%. By setting up a permanent swapfile,
    you free up your CPU to concentrate on the game, not on resizing that
    damn swapfile. If you are using NT, your swapfile is already
    permament, you can skip this entire section.

    To setup a permanent swapfile for Windows 9x, right click on My
    Computer and select the Properties. You can also get here through the
    control panel by double clicking the System icon. Head over to the
    Performance tab, and select Virtual Memory. Since we are going for
    Maximum Tweakage, we are going to have to defrag your hard drive in
    order to create a defragged swapfile. Here's how to do it:

    1.) Disable your Virtual Memory. Windows will cry a few times, just
    ignore its error messages.

    2.) Reboot your computer and defrag your C: drive. If your swapfile
    is on a different drive/partition, defrag that drive instead.

    3.) After the defrag is complete, go back to the Virtual memory
    settings and select 'Let me specify my own virtual memory settings'.
    Make both the Minimum and Maximum values the same. This prevents
    Windows from wasting time resizing the swapfile. If disk space is
    low, you can go with a 200 MB swapfile, otherwise go for 300 MB. This
    will ensure you will never run out of virtual RAM.

    4.) Reboot and enjoy your optimized swapfile!

    Step 2a. DMA!

    Please make sure that if your hard drive supports UDMA, that the DMA
    button is checked under the Device Manager. Also check your CD drive
    and confirm that "DMA" is enabled."
     
  4. tyaalii

    tyaalii New Member

    Joined:
    Dec 2, 1999
    Messages:
    7
    Likes Received:
    0
    This is super information. Thanks a lot -- if only it could be more accessible! I got RamBooster and that made my free mem from 5/128mg to 30/128mg. Is this normal!?

    For the sake of future problem diagnosis, my hardware is in MSDOS compatibility mode; I did have all progs closed, had 30meg free. Cache at 4 mg. I will DEFINITELY up that and fix the virtual mem thing...

    Thanks!
     
  5. RW

    RW New Member

    Joined:
    Nov 24, 1999
    Messages:
    234
    Likes Received:
    0
    128MB is enough memory to run this game but as always the more you have the better off you are. /~unreal/ubb/html/smile.gif UT/Unreal is for sure a memory hog, however if you for example do the following it will speed things up a bit.

    1: In UT options/preferences/video, change the "world detail" to medium, also change the "player detail" to medium.
    2: In UT options/preferences/HUD, move the "HUD" size slider all the way to the left and this will buy you a good 5FPS and maybe more.
    3: Use low quility sounds for even more speed and you could also in "advanced options/audio turn off the "use CD music" to disable the UT music, thus more CPU power for other important stuff.

    Why do you have your hardware in MSDOS mode? That will really slow down your hard drive.
     
Thread Status:
Not open for further replies.

Share This Page