1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE3 - UT3 Add custom NormalMap to Material

Discussion in 'Mapping' started by Xumari, Oct 2, 2009.

  1. Xumari

    Xumari New Member

    Joined:
    Jun 22, 2009
    Messages:
    102
    Likes Received:
    0
    Hi all

    I have a problem when I try to add a normalmap: if I add a custom normalmap (made with Crazybump, see screenshot1) to my package, it cannot be cooked (editor crash) :confused:

    With Crazybump, I open my image, convert to normalmap, export to BMP and TGA, import to UPK package and put into the material (see screenshot3). When importing (I've tryed both BMP and TGA) I've tryed with the predeterminated options and with this (see screenshot2):
    - CompressionNoAlpha
    - TC_NormalMap
    - DeferCompression (the editor deactivates this option when I save the package)

    At this point, the editor works and the in-game test works well. The problem comes here, when I try to cook the map: UT3 crash (see screenshot4)

    What I'm doing bad?? :(
    Why UT3 doesn't want to cook my NormalMaps?? :mad:

    Please help :rolleyes:
     

    Attached Files:

    Last edited: Oct 3, 2009
  2. aipash

    aipash New Member

    Joined:
    Jul 16, 2009
    Messages:
    9
    Likes Received:
    0
    have you tried building on any other computer? could just be your computer not handling this well. Question tho, could you not just use a bump map for this? The normal just seems like extra work.
     
  3. Bi()ha2arD

    Bi()ha2arD Toxic!

    Joined:
    Jun 29, 2009
    Messages:
    2,810
    Likes Received:
    0
    try cooking with the log window open. maybe it says something there.
     
  4. Xumari

    Xumari New Member

    Joined:
    Jun 22, 2009
    Messages:
    102
    Likes Received:
    0
    The log files and log window don't reveal nothing special. The cooking utility simply crash :confused:

    ----------------------------------

    OK, I'm trying a new thing.
    I've noticed that the problem is on the editor's cache and this file:
    My Games\Unreal Tournament 3\UTGame\Published\CookedPC\GlobalPersistentCookerData.upk

    If I delete all this files, the editor still crashing with all the normalmaps added to the package, BUT if I add only one normalmap (the same as the first post) with this files deleted now it works!

    Now I'm going to add one by one all the normalmaps, by cooking every time.
    I will tell you how it works :D
     
  5. Cr4zyB4st4rd

    Cr4zyB4st4rd I make awesome ©

    Joined:
    Aug 8, 2008
    Messages:
    1,244
    Likes Received:
    0
    Wrong file to delete.

    Go to
    Code:
    My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC
    And delete the 4 LocalShaderCache upk files 3 being -PC and one possibly being -PS3 in the file name. If you haven't cooked for PS3 there may only be three files.

    Remove those and re-cook.
     
  6. Xumari

    Xumari New Member

    Joined:
    Jun 22, 2009
    Messages:
    102
    Likes Received:
    0
    No, i have already try it. That files aren't the problem.

    --------------------------

    Now is fixed
    As I supposed, the problem was on the file:
    My Games\Unreal Tournament 3\UTGame\Published\CookedPC\GlobalPersistentCookerData.upk

    I've deleted that file and added one by one with recooking every time all the mapfiles. At 3th of 4th the editor crash again, then I delete again that file and I contiune adding. Now all the Normalmaps are on package and the Editor cooks the map without any problem.
    Why this? Don't know, but it's solved by this way :D

    Thanks for your help :rolleyes:
     
  7. Bazzwano

    Bazzwano Hi, I'm Bryan

    Joined:
    Jan 20, 2008
    Messages:
    604
    Likes Received:
    0
    yeah I had this problem too, sometimes it work and sometimes it didn't, so my solution was to embed to my map file.
     

Share This Page