1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE3 - General Wrong specular with symmetry ? (looks like hard edge)

Discussion in 'Modeling & Skinning' started by ng.aniki, Feb 1, 2009.

  1. ng.aniki

    ng.aniki New Member

    Joined:
    Apr 25, 2008
    Messages:
    11
    Likes Received:
    0
    Hi !
    I'm having some problems with one of my mesh, here is a screenshot to understand:

    [​IMG]

    As you can see, everything looks fine in the Static Mesh Editor; Same in Maya.

    *There isn't any normal map yet.
    *Vertex are correctly welded.
    *UVs correctly welded.
    *Edges hardness correctly set.
    *Faces normals look right.

    [​IMG]

    I don't know if there is a way to solve this problem... Anyone can help ?

    Thanks !
     
  2. Anuxinamoon

    Anuxinamoon New Member

    Joined:
    Feb 4, 2009
    Messages:
    18
    Likes Received:
    0
    Hi there,

    I'm not quite sure if this will help, but if you are using mirrored/overlaying UVW's, it can have an effect like this, especially with the baking of lights in unreal. I see you have 2 UVW channels so I'm assuming the second one is specifically for the light map and that those UVW's have been Auto unwrapped/unwrapped with no overlaps or mirroring.

    It might help to see your Material Editor as well to see how its setup :)
     
  3. ng.aniki

    ng.aniki New Member

    Joined:
    Apr 25, 2008
    Messages:
    11
    Likes Received:
    0
    Thanks for the reply ! :rolleyes:

    Yes, the second uv channel is for the light map, but there isn't any overlaps on it (The porblem is only with the specular, the baked shadows are ok).


    For the material, I tried with a new material with only a constant3vector(color) as diffuse and constant in spec and specpower, and nothing else. And the result is the same, the spec looks like those edges are hard.

    Here a picture, it shows the glitch with the basic material and explain how are my uvs.
    [​IMG]
     
  4. |*BILLY$CLINT*|

    |*BILLY$CLINT*| I make things happen!

    Joined:
    Jan 25, 2008
    Messages:
    532
    Likes Received:
    0
    Correct me if I am wrong but you are only seeing specular work correctly in the X axis and not the Y axis and it only happens after you bake your light correct?

    If this is in fact correct then there is not much you can do about it as this is something that Epic has done to their code to make it more optimized. I remember one of the engineers at work telling me that the code to do the spec on stacked UV's in the Y axis is there but it was commented out as it was too costly on the GPU. It has something to do with the sin/cosine tangent used to calculate the reflection at least that is what I remember the engineer tell me the problem came from. I am not 100% sure if this is still correct as this was over a year ago we worked on this and there could have been changes made since then to support this.

    I do know that the reason that it looks correct in the static mesh browser and not in the game is that the static mesh browser uses a dynamic light to light objects. Your scene uses baked light which is different so that is why in one its right and the other one its not.

    One last thing I think if you go to http://polycount.com/ there is a work around for this or some more advice on how to avoid/deal with this. My best advice is don't stack your UVW's or find ways where you can stack some but not others.

    Hope this helps!!!
     
  5. Anuxinamoon

    Anuxinamoon New Member

    Joined:
    Feb 4, 2009
    Messages:
    18
    Likes Received:
    0
    There is one way to fix it but its a bit expensive if your object has a lot of vertices.

    Select your object, press f4. In the properties window, scroll down to StaticMeshActor roll-out, Open StaticMeshComponent at the bottom, and where is says OverriddenLightMapR; Set it to 0.

    This will turn off using light maps and use vertex lighting. But its very expensive if you have a lot of vertexes.
     

Share This Page