1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UTInput

Discussion in 'Unreal Tournament 3' started by Slaughterer, Feb 2, 2012.

  1. Slaughterer

    Slaughterer New Member

    Joined:
    Feb 2, 2012
    Messages:
    1
    Likes Received:
    0
    Hello, maybe someone familliar with ut engine and configs could help me sort this out.
    In config file UTInput.ini there are lines:
    Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=100")
    Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=100")
    Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-200.0 AbsoluteAxis=100")
    Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+200.0 AbsoluteAxis=100")
    Im just curious what does parametre in bold does. Is it somekind of an acceleration or turn speed limit ?
    In tips about how to disable 'laggy' mouse feeling and to make ut3 sense ut2004 like it says to change those settings to:

    Bindings=(Name=«LookUp»,Command=«Axis aLookUp Speed=+25.0 AbsoluteAxis=0»,Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name=«LookDown»,Command=«Axis aLookUp Speed=-25.0 AbsoluteAxis=0»,Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name=«GBA_TurnLeft»,Command=«Axis aBaseX Speed=-40.0 AbsoluteAxis=0»,Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name=«GBA_TurnRight»,Command=«Axis aBaseX Speed=+40.0 AbsoluteAxis=0»,Control=False,Shift=False,Alt=Fals e

    As we can see it changes axis X speed from 200 to 40,which is also kinda confusing, because according to this in ut3 default speed on axisX is 8 times faster then AxisY(200/25=8) and also 5 times faster then ut2004 default axisX speed(200/40=5)..really frustrating
    Also absoluteAxis value is put from 100 to 0. Does it has to deal with disabling acceleration or just somekind of speed value which is made ut2004like?
    Would be really appreciated for any kind of feedback. I just blew my mind trying to understand this aspect of settings, cause i want my mouse act technically absolutely pure,but with this sort of weird parametres its really a big deal.
    Thx in advance
     
    Last edited: Feb 3, 2012

Share This Page