1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

ut2004 server crash

Discussion in 'General Discussion' started by willem, Feb 12, 2006.

  1. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    Hello,

    I have problems with my ut2004 DM server.
    It shut down automatic when changing maps.
    This will not always occur, but sometimes.
    I have all new patches/updates, even installed it complete new, but that only helps for about a week.
    Also my computer is clean !
    No virus or spyware.

    Here is my server log:

    ScriptLog: START MATCH
    UT2Vote: 23:41:20 - Player login request: ?Name=SloppySlut?Class=Engine.Pawn?Character=Ophelia?team=255
    ScriptLog: New Player SloppySlut id=568de194421527a414fbfd9f58054c27
    NetComeGo: Open myLevel 02/10/06 23:42:25 82.135.67.80:1665
    Log: Client netspeed is 7400
    UT2Vote: 23:42:45 - Player login request: ?Name=F.E.A.R.M.E?Class=Engine.Pawn?Character=Ophelia?team=255
    ScriptLog: New Player F.E.A.R.M.E id=be0fa5fadffd3857f6bf5560730c0be7
    UT2Vote: 23:59:25 - VoteTime = 53 - MaxVoters = 4 - VotesIn = 1 - Vote Submitted: DM-1on1-Zorgon2K4 - by SloppySlut
    UT2Vote: 23:59:28 - VoteTime = 49 - MaxVoters = 4 - VotesIn = 2 - Vote Submitted: DM-1on1-Contact2K3 - by F.E.A.R.M.E
    UT2Vote: 23:59:39 - VoteTime = 37 - MaxVoters = 4 - VotesIn = 3 - Vote Submitted: DM-1on1-Zorgon2K4 - by *wimpy*
    UT2Vote: 23:59:48 - VoteTime = 27 - MaxVoters = 4 - VotesIn = 4 - Vote Submitted: DM-1on1-Contact2K3 - by M.Crocs_Fr
    UT2Vote: 23:59:50 - MajorityVote = DM-1on1-Contact2K3 scored 2 votes.
    UT2Vote: 2006/02/10 - 23:59:50 - The Map DM-1on1-Contact2K3 won the vote.
    UT2Vote: 23:59:55 - ServerSwitchLevel - ClientMap = DM-1on1-Contact2K3 | CommandLine = DM-1on1-Contact2K3?Game=XGame.xDeathMatch?Mutator=UT2Vote51.UT2VoteX,AntiTCC118c.MutAntiTCCFinal,SA2K4_102.M utSniperArena,Zound52.Zound?GamePassword=?Translocator=True?AdminName=*BB*~2004?AdminPassword=xxxx
    ScriptLog: PreClientTravel
    Log: Server switch level: DM-1on1-Contact2K3?Game=XGame.xDeathMatch?Mutator=UT2Vote51.UT2VoteX,AntiTCC118c.MutAntiTCCFinal,SA2K4_102.M utSniperArena,Zound52.Zound?GamePassword=?Translocator=True?AdminName=*BB*~2004?AdminPassword=xxxx
    Log: Browse: DM-1on1-Contact2K3?Name=WimpY?Class=Engine.Pawn?Character=Torch?team=255?Sex=M?SpectatorOnly=0?Game=XGame.xD eathMatch?Mutator=UT2Vote51.UT2VoteX,AntiTCC118c.MutAntiTCCFinal,SA2K4_102.MutSniperArena,Zound52.Zo und?DMTeam=xgame.DMRosterConfigured?MaxLives=0?GoalScore=28?TimeLimit=20?MinPlayers=4?MaxPlayers=8?M axSpectators=1?Translocator=True?WeaponStay=True?BalanceTeams=False?ForceRespawn=False?PlayersMustBe Ready=False?Tournament=0?GamePassword=?GameStats=False?GameSpeed=1.05?FF=0.00?NoOverTime=False?VsBot s=False?NumBots=1?Difficulty=2?bCustomGame=True?AdminName=*BB*~2004?ADMINPASSWORD=XXXXX
    NetComeGo: Close TcpipConnection 80.170.38.229:3487 02/10/06 23:59:59
    AntiTCC: [2006-02-10 23:59:59] - [Disconnect] M.Crocs_Fr [ 3fbc2db8d5875212d1f2c977e7f647df ] IP: 80.170.38.229 Security ID: 1 using v3369
    NetComeGo: Close TcpipConnection 82.169.230.89:20761 02/10/06 23:59:59
    AntiTCC: [2006-02-10 23:59:59] - [Disconnect] *wimpy* [ e023d9ff901dc868c2ad1431e7e2e93c ] IP: 82.169.230.89 Security ID: 0 using v3369
    NetComeGo: Close TcpipConnection 84.179.237.180:1389 02/10/06 23:59:59
    AntiTCC: [2006-02-10 23:59:59] - [Disconnect] SloppySlut [ 568de194421527a414fbfd9f58054c27 ] IP: 84.179.237.180 Security ID: 2 using v3369
    NetComeGo: Close TcpipConnection 82.135.67.80:1665 02/10/06 23:59:59
    AntiTCC: [2006-02-10 23:59:59] - [Disconnect] F.E.A.R.M.E [ be0fa5fadffd3857f6bf5560730c0be7 ] IP: 82.135.67.80 Security ID: 3 using v3369
    Exit: Socket shut down
    Log: Collecting garbage
    Log: Purging garbage
    Critical: UObject::GetPathName
    Critical: UObject::GetPathName
    Critical: UObject::GetPathName
    Critical: UObject::GetFullName
    Critical: DispatchDestroy
    Critical: UObject::GetPathName
    Critical: UObject::GetPathName
    Critical: UObject::GetPathName
    Critical: UObject::GetFullName
    Critical: DispatchDestroys
    Critical: UObject::purgeGarbage
    Critical: UObject::CollectGarbage
    Critical: Cleanup
    Critical: UGameEngine::LoadMap
    Critical: LocalMapURL
    Critical: UGameEngine:rowse
    Critical: ServerTravel
    Critical: UGameEngine::Tick
    Critical: Level DM-1on1-Contact2K3
    Critical: UpdateWorld
    Critical: MainLoop
    Critical: FMallocWindows::Free
    Critical: FMallocWindows::Realloc
    Critical: 10910191 0 FArray
    Critical: FArray::Realloc
    Critical: 0*2
    Critical: FMallocWindows::Free
    Exit: Executing UObject::StaticShutdownAfterError
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 846 MByte 110 KByte 21 Bytes from HD took 28.191049 seconds (26.584030 reading, 1.607019 seeking).
    Log: FileManager: 5.947930 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Log file closed, 02/11/06 00:00:01

    And here the ut2004 log:

    Log: Log file open, 02/10/06 16:58:22
    Init: Name subsystem initialized
    Init: Detected: Microsoft Windows XP 5.1 (Build: 2600)
    Init: Version: 3369 (128.29)
    Init: Compiled: Nov 23 2005 16:23:34
    Init: Command line:
    Init: Character set: Unicode
    Init: Base directory: C:\UT2004\System\
    Init: Ini:UT2004.ini UserIni:User.ini
    Init: Build label: UT2004 Build UT2004_Build_[2005-11-23_16.22]
    Init: Object subsystem initialized
    Log: Splash screen filename is '..\Help\UT2004Logo.bmp'
    Log: nv4_disp.dll/NVIDIA GeForce FX 5900XT
    Log: Game class is 'GameInfo'
    Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 2.091000...
    ScriptLog: GameInfo::InitGame : bEnableStatLogging False
    Log: Browse: NvidiaLogo.ut2?Name=WimpY?Class=Engine.Pawn?Character=Torch?team=255?Sex=M?SpectatorOnly=0
    Log: Collecting garbage
    Log: Purging garbage
    Log: Garbage: objects: 27950->27950; refs: 284088
    Log: Game class is 'CinematicGame'
    Log: Bringing Level NvidiaLogo.myLevel up for play (0) appSeconds: 3.582000...
    Log: (Karma): Autodetecting CPU for SSE
    Log: (Karma): Using SSE Optimizations
    ScriptLog: GameInfo::InitGame : bEnableStatLogging False
    Log: ALAudio: Using DirectSound to record audio.
    ScriptLog: New Player WimpY id=e023d9ff901dc868c2ad1431e7e2e93c
    Log: Opened viewport
    Log: Enter SetRes: 1024x768 Fullscreen 1
    Log: Using back-buffer format 23(16-bit)
    Log: Using depth-buffer format 80(16-bit)
    Log: Creating device
    Log: xD3DHelper::Init (QuadEmulation)
    Log: Startup time: 4.701000 seconds
    Log: Precaching: NvidiaLogo.LevelInfo0
    Log: Static mesh batches: 508608 vertex bytes, 110460 index bytes
    Log: Allocating 16384 byte dynamic index buffer.
    Log: Finished precaching geometry in 0.150 seconds
    Log: Finished precaching textures in 0.076 seconds
    Debug: UT2k4MainMenu.Opened() Sender:package.UT2k4MainMenu
    Log: URL: Adding default option Name=WimpY
    Log: URL: Adding default option Class=Engine.Pawn
    Log: URL: Adding default option Character=Torch
    Log: URL: Adding default option team=255
    Log: Browse: Index.ut2?disconnect?Name=WimpY?Class=Engine.Pawn?Character=Torch?team=255
    Log: Failed; returning to Entry
    ScriptLog: UT2k4MainMenu NotifyLevelChange PendingConnection:False
    Log: GP=FALSE
    Log: Spawning new actor for Viewport WindowsViewport
    ScriptLog: New Player WimpY id=e023d9ff901dc868c2ad1431e7e2e93c
    Log: Static mesh batches: 0 vertex bytes, 0 index bytes
    Log: FIREWALL: Freed XP.SP2 Firewall Object
    Log: Relaunch: DM-ED-Laundry-vh?BonusVehicles=false?Game=XGame.xDeathMatch?Mutator=AntiTCC118c.MutAntiTCCFinal,UT2Vote51.UT2VoteX ?DMTeam=xgame.DMRosterConfigured -server -log=server.log
    Log: GetModuleFileName returned C:\UT2004\System\UT2004.exe
    Log: ShellExecute result: 42
    Log: appRequestExit(0)
    Debug: UT2k4MainMenu.Opened() Sender:None
    Exit: Preparing to exit.
    Log: Purging garbage
    Log: Unbound to Window.dll
    Log: Unbound to Core.dll
    Log: Unbound to Engine.dll
    Exit: Game engine shut down
    Log: Unbound to WinDrv.dll
    Exit: Windows client shut down
    Log: Unbound to D3DDrv.dll
    Log: Unbound to XGame.dll
    Log: Unbound to IpDrv.dll
    Log: Unbound to Editor.dll
    Log: Unbound to Fire.dll
    Log: Unbound to XInterface.dll
    Log: Unbound to UWeb.dll
    Log: Unbound to Onslaught.dll
    Log: (Karma): Level Karma Terminated.
    Log: Unbound to ALAudio.dll
    Log: Waiting for file streaming thread to finish...
    Exit: OpenAL Audio subsystem shut down.
    Log: Garbage: objects: 33209->0; refs: 284088
    Exit: Object subsystem successfully closed.
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 63 MByte 797 KByte 287 Bytes from HD took 0.595999 seconds (0.450999 reading, 0.145000 seeking).
    Log: FileManager: 0.297000 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Memory Allocation Status
    Uninitialized: Curr Memory 0.216M / 4.621M
    Uninitialized: Peak Memory 99.725M / 101.680M
    Uninitialized: Allocs 956 Current / 3898671 Total
    Uninitialized: Log file closed, 02/10/06 16:58:40

    It happends with all maps, in this case 1on1-contact.
    Maybe someone has the same problem,
    Sollution ?
    I also run a 2003 server on a other computer, also with ut2vote, here everything works fine.
    Maybe a wrong setting on the computer ?

    Computer: P4-2600 mhz-768 memory
    Dedicated server startup from within the game.

    I had post this by troubleshooting, but maybe it has to do with ut vote.

    Willem.
     
  2. Assraker

    Assraker New Member

    Joined:
    Oct 16, 2004
    Messages:
    75
    Likes Received:
    0
    Let us try some basic troubleshooting.
    Humor me & try this command line and let me know what happens:

    Code:
    ucc.exe server DM-RANKIN?BonusVehicles=false?Game=XGame.xDeathMatch?Mutator=UT2Vote51.UT2VoteX ?DMTeam=xgame.DMRosterConfigured ini=UT2004.ini log=server.log
    
    Also, in UT2Vote add AntiTCC under the heading shown below:
    Code:
    [UT2Vote51.UT2VoteConfigs]
    ServerMuts=AntiTCC118c.MutAntiTCCFinal
    
     
  3. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    I know i only have to select ut2vote as an mutator, because ut2vote handels the game.
    But also then the same problems.
    Antitcc is already put in the servermuts, together with other mutators.
    Here are lines from ut2vote ini:

    [UT2Vote51.UT2VoteConfigs]
    VoteAdminPass=xxxx
    ClanAdminPass=
    GamePassword=
    DefaultGame=XGame.xDeathMatch
    DefServerName=BLOODY~BEAUTY 2004* Standard & Custom Maps*
    ServerMuts=AntiTCC118C.MutAntiTCCFinal,SA2K4_102.MutSniperArena,Zound52.Zound
    ServerLine=?Translocator=True

    Sometimes the server runs a week without any problems, but sometimes it crashes everyday.
    Normally it crashes after i cleaned the computer programs.
    (disk cleanup-defragging)
    I never start the way you descripe it, using server bat.
    I startup thewhole ut2004 game and select dedicated'
    This i also do with my ut2003 server.
    That one runs without any problems.

    I shall tomorrow select dm rankin and only mutator ut2vote, but i almost know it will crash.
    Maybe not right away, but it will crash.

    Thanks for your reaction and help, willem.
     
  4. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    Your server is crashing not from any mutator or mod but seems to be loosing its Paths which are originally defined in the UT2004.ini file.
    I have seen this happen on servers and the only thing I can conclude is the map, as this crash also happens on servers that are not using any mut or mod of any discription.
    Make a note of what map the server is trying to switch to when a crash happens.
    ** Edit **
    Try downloading the free server and use a bat file to start it.
     
    Last edited: Feb 12, 2006
  5. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    I also have read different forums with same problems (Critical: UObject::GetPathName).
    Here is one : http://www.unrealadmin.org/forums/showthread.php?p=35237&mode=threaded

    Last reaction i gonna try:
    Theteck
    Forum Newcomer Join Date: May 2004
    Posts: 8

    i find a options

    --------------------------------------------------------------------------------

    in ut2004.ini in tcp section

    the servertravel=4 set to 0 or 2 and this bug will quit you

    3 day now and is working again whitout reboot

    dont try to put hight because ut2vote restart in a loop

    It happens with all kinds of maps, standard ones and custom ones.
    Also a complete new install of ut2004 helps only for a short time.

    Thanks for your fast reaction !
    Regards, willem.
     
  6. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    I have set the ServerTravelPause in the [IpDrv.TcpNetDriver] section from 4.0 to 2.0
    Till now server is running without problems.
    Also i got a mail about this problem.
    Here it is:

    Hi,
    Have you desactivated the ACPI option (the energy saving). Does your bios well configured (events like automatic disc stop...).
    As we can see, a stop request is sent to the program :

    Log: ShellExecute result: 42
    Log: appRequestExit(0)
    Debug: UT2k4MainMenu.Opened() Sender:None
    Exit: Preparing to exit.

    May be some control's characters could be sent during map initialisation. Dont you have tuned some messages ?
    Dont you have modified the console ?
    Did you tried to lunch the game in safe mode, without SSE optimizations, with basic video... ?
    Have you installed last patch (i'm sure yes, but O:) ???) ?
    Do you have installed last drivers for your PC (video, sound, motherboard) ?
    FrenchKiss :cool:

    No screensavers or energy saving is on.
    In savemode the game is running worse than in standard mode.
    Yes, i got all latest patches for ut2004.
    Also latest drivers for my CPU, including latest bios version.
    I have nothing modiefied.
    Only standard installation,s.

    Thanks for your information and help, regards willem.
     
  7. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    Very interesting.
    Thanks for the report on this.
     
  8. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    Crash again - nothing works

    hello, i,m back !

    Today server crashes 4 times:mad: .
    Even after complete new install with default settings of the game, same problems.
    Server runs now on my other computer at home with same configuration.
    And excakly same game/install cd,s.
    Let see what happens.

    If now things go right, the cause is then off course the computer/windows.

    i will keep you all informed !

    willem.
     
  9. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    I've started the server now with the serverbat for the first time.
    It is looking good, no problems so far.
    It is looking at this now,

    @echo off
    :10
    ucc server DM-Rankin.ut2?Game=XGame.xDeathMatch?Mutator=UT2Vote51.UT2VoteX?bAutoNumBots=False ini=UT2004.ini log=Bloodybeauty.log
    copy server.log servercrash.log
    goto 10

    Mutators are all in ut2vote.
    I hope i did it the right way.

    willem.
     
  10. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    Yes, except you can remove the ?bAutoNumBots=False as it will just get ignored.
    It should go in the:
    ServerLine=bAutoNumBots=False
     
  11. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    Thx !

    Willem.
     
  12. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    OK,

    Here is my ut2vote, is it ok the way i did ?

    [UT2Vote51.UT2VoteConfigs]
    VoteAdminPass=XXXXX
    ClanAdminPass=
    GamePassword=
    DefaultGame=XGame.xDeathMatch
    DefServerName=BLOODY~BEAUTY 2004* Standard & Custom Maps*
    ServerMuts=AntiTCC118i.MutAntiTCCFinal,SA2K4_102.MutSniperArena,Zound52.Zound,ServerBots2.ServerBots
    ServerLine=?bAutoNumBots=False?Translocator=True


    Thx for your help:) .
    willem
     
  13. tdw-socke

    tdw-socke New Member

    Joined:
    Nov 21, 2003
    Messages:
    990
    Likes Received:
    0
    log=Bloodybeauty.log
    copy server.log servercrash.log

    doesn't make sense, does it? ;)
     
  14. willem

    willem New Member

    Joined:
    Jan 8, 2006
    Messages:
    13
    Likes Received:
    0
    remove the line 'copy server.log servercrash.log' ?
    sorry, but i,m a newby serving this way.

    Thx for your help.
    willem.
     
  15. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    change the line to:
    copy Bloodybeauty.log Servercrash.log

    The rest is great ;)
     

Share This Page