1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UT:GOTY Crashes on Load, Black Screen

Discussion in 'Hardware, Software & Troubleshooting' started by Kyouryuu, Feb 20, 2005.

  1. Kyouryuu

    Kyouryuu *roar!*

    Joined:
    Dec 17, 2003
    Messages:
    244
    Likes Received:
    0
    Hey all,

    I've having problems getting UT:GOTY to load after weeks of it working perfectly fine. When I try to execute the game using the enhanced OpenGL renderer, the splash screen appears. After a few moments, the screen goes black as if preparing to load the game, but then crashes back to the desktop with an unrefreshed splash screen, background, and elements of the Windows taskbar. Ctrl-alt-del is the only way to properly kill UT:GOTY via UnrealTournament.exe. The task manager reports that UT:GOTY is taking about 70 MB of RAM, so it's clearly trying to load. Also, although UnrealEd2 works fine even with the real-time rendering on, executing the game from here also crashes. Additionally, trying to load the game in DirectX 9.0c crashes fatally to a black screen, and a manual reboot is needed to get back to Windows.

    This is the second time I've had this issue. The previous time, no amount of reinstalling UT:GOTY or updating drivers fixed it. I had to do a fresh reinstall of Windows XP to get it working once more. It has functioned happily since then, until I tried executing it this weekend and got the above results. Searching the forum, there are some posts about similar problems. I've updated my graphics drivers to the latest Catalyst ones from ATI and updated the enhanced OpenGL renderer to 2.8. No luck.

    I really don't want to embark on the insipid 3+ hour journey of releasing Windows XP again and I'm looking for any other solutions.

    The system is a Dell 3.06 GHz with 512 MHz of RAM. The graphics card is an ATI Radeon 9700 Pro running the latest Catalyst drivers from ATI (dated earlier this month) and the desktop is running at 1600x1200 with 32-bit color. The OS is Windows XP SP2 with the latest patches from Windows Update. UT is version 436 with version 2.8 of the enhanced OpenGL renderer. Short of the Windows updates, no drivers have been updated until now and the game had worked fine since the last reinstall. It might be worth noting that UT2004 does work.

    Things I've tried:
    - Updated ATI Catalyst drivers to latest (release Feb. 9th, 2005)
    - Updated enhanced OpenGL renderer to 2.8
    - Running in DirectX (fatal crash)
    - Running from UnrealEd2 (same crash)
    - Rebooting Windows, restarting PC
    - Manually editing UnrealTournament.ini so FullscreenViewportX=1600, FullscreenViewportY=1200, FullscreenColorBits=32
    - Updated sound card driver (ES1969 from ESS Technologies)
    - Running with various options in Safe Mode. Could in some cases get game to run without sound, but setting the same options again sometimes resulted in the same crash.
     
    Last edited: Feb 20, 2005
  2. SkaarjMaster

    SkaarjMaster enemy of time

    Joined:
    Sep 1, 2000
    Messages:
    4,835
    Likes Received:
    4
    I don't have SP2 or DX9c installed on my system:

    WinXP SP1a, P4 3.2GHz(Asus P4P800-Deluxe),Thermalright SLK-947U,2GB Corsair XMS PC3200 Pro RAM(4-512 sticks),Sapphire ATI Radeon 9800Pro 256MB-AGP8X(4.7 catalyst,VGA Silencer,DX9.0b),SB Audigy2,Klipsch 5.1 speakers,Enermax 550W PS

    Did you try rolling back to the 4.10s or the 4.7s yet? This seems to work for some people. I've also heard some people may have to go back to 4.1s or 3.9s to get rid of another bug you may have run into (the gamma bug). Try the 4.10s and 4.7s first, then maybe the 3.9s. If none of that works and if you think it's worth it, reinstall WinXP with only SP1a (if possible) and only install DX9b. Also, you may want to post your OpenGL section of the UnrealTournment.ini file here and maybe one or more of those settings need changing. That's all I can suggest right now and sorry it's a month late.
     
  3. Kyouryuu

    Kyouryuu *roar!*

    Joined:
    Dec 17, 2003
    Messages:
    244
    Likes Received:
    0
    Your timing rocks, Skaarj. ;) I re-installed Windows after posting this thread and UT worked for a while. Then, once more, it stopped working. I'll try changing the ATI drivers and tell you what I find.
     
  4. Kyouryuu

    Kyouryuu *roar!*

    Joined:
    Dec 17, 2003
    Messages:
    244
    Likes Received:
    0
    Okay, here's what I found. First, I tried rolling back the ATI drivers by uninstalling the existing drivers, rebooting, then trying to install again. I tried two Catalyst versions, 4.12 and 3.9. Neither resolved the problem.

    I then managed to remove SP2 and surprised myself as Windows booted up as SP1. But, once again, UT wouldn't work.

    What I've done now is reinstall Windows (because a "former SP2" system is not exactly the pinnacle of stability) and deliberately left it at SP1 with all patches associated with it. So far, UT has worked just fine. I'll keep an eye on it and see what happens over time. I just remember that, under SP1, I never had this problem. And seeing that by Microsoft's own admission that SP2 "affects" UT, it's worth a shot cause I like making UT maps more than any other game. :D
     
  5. rattyocaster

    rattyocaster Up close and personal Sniper

    Joined:
    Jul 26, 2002
    Messages:
    267
    Likes Received:
    0
    I've been having Similar problems. I'm running an Athlon 2800+ with 1024MB of ram, GeForce FX 5700 and Windows XP SP2 with the latest drivers(DX9.0C as well). UT99 was running fine until I uninstalled some mods and then it wouldn't load, so I've Uninstalled it and reinstalled the full game again. But now if I try to run the game in Direct 3D it takes up to a minutes to precache and then the intro plays about 2 seconds per frame (yes, I mean 0.5fps) which obviously isn't right. I also have a Windows 98 SE machine of much lower spec, (Athlon 800 with 256MB of ram, GeForce MX400 and latest nVidia Drivers and dx9.0c) and that has the exact same issues...however, I've found it's possible to run it in open GL, but it looks far nicer in Direct 3D. If someone could help I'd be most grateful :)
     
  6. rattyocaster

    rattyocaster Up close and personal Sniper

    Joined:
    Jul 26, 2002
    Messages:
    267
    Likes Received:
    0
    What's appeared to help on my PC (Windows XP Machine) was if you run the game in software mode, then open the console and type "preferences" then open Rendering and then open Direct 3D and then in that list set "Use Precache" to False, then close the preferences window, the game will go to full screen, then quit the game. Press the "Run game in safe mode" button and then change the 3D rendering device to Direct 3D and with a bit of luck it'll work, and as a result of Disabling precache, it loads much quicker
     
  7. Kyouryuu

    Kyouryuu *roar!*

    Joined:
    Dec 17, 2003
    Messages:
    244
    Likes Received:
    0
    Okay, here's what worked for me!

    - Open up UnrealTournament.ini, usually located in C:\UnrealTournament\System.
    - Search for the string "UseDirectSound"
    - You should find the string in the [Galaxy.GalaxyAudioSubsystem] section.
    - Change UseDirectSound=True to UseDirectSound=False
    - Start Unreal Tournament

    I don't remember where I stumbled on this suggestion. It looks like it was last brought up way back in 2001 on the forums here. Either way, it definitely seems to solve the problem I have.
     
    Last edited: Jul 9, 2005

Share This Page