1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Unreal 2 Doesn't Load Full Screen on Windows 10

Discussion in 'Unreal 2' started by Freddie, Aug 5, 2015.

  1. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    123456.png

    Hi,

    I recently installed Win10 upgrade on my computer. The installation went well, but Unreal 2 doesn't launch full screen, though it runs nicely otherwise with a narrow band at the top and at the bottom. The bands are about the size of a normal task bar. See the picture.

    The Unreal 2.ini and the options in the game are both set to run full screen. I see no other setting options for this situation. It ran full screen in my former Windows 8.1 system before the upgrade.

    I'm running an intel i7 3.1 Gig processor with 8GB ram, and a Radeon 7750 video card with the latest drivers. The game is installed on C:\Program Files (x86)\Unreal2.

    Any idea of how I can get the game into full screen mode?

    Freddie

    Edit: I'm running the game in WinXP, SP3 compatibility mode. I've tried other modes. This mode seems to be best.

    Screen resolution is set to 1920 X 1080, both in-game and in the Unreal2.ini, and in Windows. That's the native resolution of my monitor.
     
    Last edited: Aug 6, 2015
  2. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    It looks as if I'll get no responses to my dilemma. I'll likely reinstall the game to see whether that move corrects the problem. I'll post back with the results. I was hoping for an easier fix, but what the heck, can't win'em all. Nothing like a little extra work.

    Freddie
     
  3. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    I have a question. Can I just move the Unreal2 folder containing all the files related to Unreal2 without reinstalling the game? It's now installed in C:\Program Files (x86)\Unreal2. I'd prefer to move it to C:\Unreal2 to save me the trouble of installing not only the game itself, but also other Unreal2 games. I have Red Planet, Damage, Unseen Consequences 1 & 2 installed.

    If I could do that, it would save me a lot of trouble. I know one can simply move the original Unreal from one location to another and still have it function properly. Original Unreal doesn't have all those extra system entries, like in registry. I've done that with the original Unreal. Worked good.

    Freddie
     
  4. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    Guys & Gals,

    I fixed it! I removed Unreal2 from C:\Program Files (x86), and reinstalled it in C:\Unreal2, as stated earlier. That move didn't solve the problem of the game not running in full screen mode. The problem remained the same, (see picture on my first post, above). Actually, after the reinstall, the game crashed when launched. It at least ran before, but just not in full screen mode. Bummer.

    I then did an Internet search on the error message I was getting when the game wouldn't launch when set to full screen mode in the Unreal2.ini file. I found a post where someone with the same problem fixed it by changing the Unreal2.ini option Startup Full Screen=True to False (counter intuitive) . Now the game launched, but not in full screen mode. What I got looked the same as the picture in my first post, above.

    I then continued my search on the Internet. I found a post where someone had the same issue running Unreal2 in Windows 10. That is, the game ran but not in full screen mode. He made the following adjustment which fixed the problem. Here is the fix, it works for me, too:

    Open Unreal2.ini and in the section:

    RenderDevice=D3DDrv.D3DRenderDevice, change:
    Reduce Mouse Lag=False (it was set to True by default)

    What that setting has to do with full screen mode beats me. Like I said before, I don't understand any of this. Anyway, now, the game launched but not in full screen mode. With the game running, In the Options section, Full Screen was not checked. I checked it and the screen immediately changed to full screen. Go figure. Check the picture.

    I may need to check that option every time I run the game, but I don't mind doing that. Simple.

    122.png

    I'm happy.

    Freddie
     
    Sir_Brizz likes this.
  5. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    In my previous post, above, I forgot to add that the game works properly for me in Windows 10 without selecting any Compatibility Mode in the game's Properties options. It also runs properly if you do select a compatibility mode. It doesn't seem to matter. Select one, or not.

    Freddie
     
  6. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    187
    Likes Received:
    2
    This post is an update to my previous post, where I stated that the game works properly without selecting a compatibility mode. After playing the game, I now amend that statement. The game works best, at least for me, when I set the compatibility mode to Windows 8. That mode seems odd, given that the game was designed and released long before Windows 8 came out. Even so, that's my experience.

    Freddie
     
  7. Leo(T.C.K.)

    Leo(T.C.K.) Well-Known Member

    Joined:
    May 14, 2006
    Messages:
    4,689
    Likes Received:
    29
    Sorry that you got no responses before buddy. I wasn't exactly around at the time though.
     

Share This Page