1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UCC can't find my staticmesh

Discussion in 'Programming' started by Amin0, Jul 10, 2004.

  1. Amin0

    Amin0 New Member

    Joined:
    Apr 20, 2004
    Messages:
    13
    Likes Received:
    0
    Hi all,

    I'm new on making a TC for UT... So i ran into a problem...
    I'm making a vehicle... the death-model is a staticmesh...
    i've created the staticmesh... imported it into unrealed...
    i did the coding... just said witch one he should grap...
    but when i compile it says:

    ObjectProperty Onslaught.ONSVehicle.DestroyedVehicleMesh: unresolved reference to 'StaticMesh'MyTCSM.Car.deadCar''

    this is when the staticmesh is in the folder : C:\UT2004\MyTC\StaticMeshes
    when i put it in: C:\UT2004\StaticMeshes
    it compiles with out that error...

    default.ini of MyTC :
    [Core.System]
    +Paths=../MyTC/StaticMeshes/*.usx
    +Paths=../MyTC/System/*.u
    +Paths=../MyTC/Textures/*.utx
    +Paths=../MyTC/Maps/*.ut2
    +Paths=../MyTC/Animations/*.ukx

    [Editor.EditorEngine]
    +EditPackages=MyTC

    [Engine.GameEngine]
    MainMenuClass=MyTC.SubSpaceMainMenu

    can anyone tell me what i'm doing wrong???
     
  2. punk129

    punk129 !!!!!!!!!!!11111111111

    Joined:
    Jan 18, 2003
    Messages:
    172
    Likes Received:
    0
    you did #exec OBJ LOAD FILE="yourfile"?
     
  3. Amin0

    Amin0 New Member

    Joined:
    Apr 20, 2004
    Messages:
    13
    Likes Received:
    0
    No... I took the code from the raptor (ONSAttackCraft)
    And in that file there wasn't a load of a staticmesh
    ...

    but can that be the problem?
    cause when i put the staticmesh in: C:\UT2004\StaticMeshes
    it compiles with out that error...

    anyway i will try it
     
  4. Amin0

    Amin0 New Member

    Joined:
    Apr 20, 2004
    Messages:
    13
    Likes Received:
    0
    nope... that didn't work either
     
  5. Amin0

    Amin0 New Member

    Joined:
    Apr 20, 2004
    Messages:
    13
    Likes Received:
    0
    omg... I feel like such a noob :S
    i found the problem... i edited the default.ini when MyTC.ini already existed...
    so it did not update MyTC.ini, in which ucc looks ...
    But tnx anyway for the suggestion punk129
     

Share This Page