1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Something new and strange in logfile...

Discussion in 'General Discussion' started by Skipx2, Oct 25, 2004.

  1. Skipx2

    Skipx2 New Member

    Joined:
    Aug 19, 2004
    Messages:
    19
    Likes Received:
    0
    Hi all,
    I have just noticed over the last week or so the following message appearing in my server log files. Anyone know what it means, or if its not important how to get rid of it? Sometimes it composes 1/4 of the log.

    Thanks,
    Skip

    Pasted text follows:

    NetComeGo: Close TcpipConnection 172.xxx.xx.xxx:2836 10/25/04 03:09:26
    Error: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (67/13)
    Warning: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None 'DefaultMap'
    Warning: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None
    Error: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (67/13)
    Warning: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None 'DefaultMap'
    Warning: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None
    Error: UT2VoteMulti DM-[SvL]-PhobosClassic.UT2VoteMulti (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (67/13)
     
  2. Skipx2

    Skipx2 New Member

    Joined:
    Aug 19, 2004
    Messages:
    19
    Likes Received:
    0
    Here's an interesting twist. I just received an email from one of my admins, he said he noticed some wierd stuff on the server.

    A few other players were running around with no upper body, and his (the admin's) health was a negative number. I have a screen shot, I'll try and attach it.

    This is NUTS!
     

    Attached Files:

  3. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    The negative health normally happens when you have a Game Mod on your server that uses the -mod= option in your commandline.
    Basically these mods have their own folders and their own ini files and this is where the screw comes in.
    As I said many times, its not UT2Vote thats not compatible with these mods, its these mods that are not comaptible with UT2Vote.
    Btw... these mods dont have to be running or currently in play, they just need to be on your server doing nothing for these problems to appear.
     
  4. Skipx2

    Skipx2 New Member

    Joined:
    Aug 19, 2004
    Messages:
    19
    Likes Received:
    0
    Interesting, I did put a Team LMS mod on a little while ago. In fact last night, I was editing the UT2Vote portion of each .ini (for each server) to have the mod show up (using the =true). If I understand you correctly, by enabling this new mod and putting it in the ini file it could be causing these problems? So, I should remove the line from the file to get things to return to normal, probably. Is this also why the warning keeps showing up in the logfile?

    My command line is very 'naked'. The only thing I have in there is mutator=UT2Vote, the name of each servers .ini file and gamestats=true.

    Am I on the right track here?

    Thanks very much.

    As a side note, I was trying to use UAdmin a while back, and it seemed to be incompatable when I loaded it with UT2Vote. Would this be a similar type of problem?
     
  5. sh0V3l

    sh0V3l New Member

    Joined:
    Oct 23, 2003
    Messages:
    246
    Likes Received:
    0
    mods vary quite a bit it depends on the packages associated with the mod how the guy coded the mod usually we use a dummymut do you have a limk to the mod ill check it out and tell u the proper ini configs
     
  6. HornDog

    HornDog Propeller head

    Joined:
    Sep 27, 2003
    Messages:
    39
    Likes Received:
    0
    Buy any chance are you using ZenCoder weapons? If so update to version203 this is a known issue.
     
  7. Negative9

    Negative9 New Member

    Joined:
    Feb 22, 2003
    Messages:
    5
    Likes Received:
    0
  8. Skipx2

    Skipx2 New Member

    Joined:
    Aug 19, 2004
    Messages:
    19
    Likes Received:
    0
    I have removed the Team LMS mod line in the UT2Vote_Gametypes section of the .ini file to see if this corrects it (I actually commented it out with a semicolon). I haven't heard of any of the strange player stuff showing up again, so maybe that was the problem.

    If I remove references to mods/mutes in the _Gametypes and _Mutators section, that should correct the half body problem and/or the recurring error message...if that was the root cause, correct?
     
  9. tdw-socke

    tdw-socke New Member

    Joined:
    Nov 21, 2003
    Messages:
    990
    Likes Received:
    0
    regarding the half-bodies, we're on it... Would be interesting, if that was clanmatch or standard.
     
  10. Skipx2

    Skipx2 New Member

    Joined:
    Aug 19, 2004
    Messages:
    19
    Likes Received:
    0
    It was standard. I've just started tinkering with clanmatch.

    If I can give you any more data that'd be helpful, let me know.
     
  11. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    If its the 'Out of Bound' error you are referring to then its because you have probably deleted some of the default GameTypes in the UT2Vote.UT2VoteGameTypes section.
    Deleting any of the default games supplied with UT2Vote may result in a severe Server Crash and these games MUST be left intact.
     

Share This Page