1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

runtime error

Discussion in 'Hardware, Software & Troubleshooting' started by access, May 8, 2006.

  1. access

    access New Member

    Joined:
    May 8, 2006
    Messages:
    1
    Likes Received:
    0
    I keep getting the following runtime error whenever I try to launch ut2004: Microsoft Visual C++ Runtime Library
    ____________________________

    Runtime Error!

    Program: C:\UT2004\System\UT2004.exe

    This application has required the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

    _____________________________________

    I've only just started getting this error and everything worked fine yesterday. I havesn't installed new software or altered the ut2004 folders/files recently either. Basically the only difference between yesterdays working ut2004 and todays broken one is the error message above and thus the programs inability to launch. :(

    BTW, I have the latest patch (3369) installed and the ut2004.log is empty.
    Aslo, i've tried deleting my ut2004 and user.ini files but now I get a "Your CD key appears to be invalid. You will need to reinstall the game and enter your CD key to fix the problem" instead of the runtime error.

    The only other thing i can think of is the non-standard resolution I was last playing the game at. I.e. I resized the window in windowed mode and thus it was nolonger 800x600 etc. But i've done that before and had no problems.

    I reeeeeally don't wanna have to reinstall :(

    Any suggestions?
     
    Last edited: May 8, 2006
  2. H34DHUNT3R

    H34DHUNT3R New Member

    Joined:
    Dec 20, 2005
    Messages:
    16
    Likes Received:
    0
    sounds like a corrupt registry/dll issue :rolleyes: ,

    try RE-installing the patch first, deleting your ini's afterwards,

    if you still get the invalid cdkey error open start->run and type regedit

    search for : HKEY_LOCAL_MACHINE\SOFTWARE\Unreal Technology\Installed Apps\UT2004

    and look for the value of the "CDKey" string, to see if your cdkey needs to be corrected.(assuming you're on a windows platform)

    a better idea is to go to http://spaz.s5.com/ and download and execute the ut2004 registry fixer 1.3


    Version 1.3 will re-establish:
    - The main registry settings.
    - UMOD, MAP and UT2004:// Extensions.
    - The CD-Key
    - Uninstall Information
    - Will now fix ECE 1.1 bad Setup.exe file.

    *note that you have to install the Microsoft.NET framework first, see the site itself for download locations (1.1 is sufficient).

    if this doesn't help backup your ut2004\system folder (just rename), find the retail system folder on your first ut2004 cd or dvd and put that in your ut2004 folder to see if that makes the game start.

    if it does you can just start (if necessary) overwriting the files in the backup folder with the retail ones and rename it back to system, hopefully saving you a complete reinstallation :Poop: .
     
  3. dizzm

    dizzm New Member

    Joined:
    Oct 21, 2008
    Messages:
    53
    Likes Received:
    0
    Just a little update from trying this. That spaz site above no longer has a working download for the fix. Well the file downloads but the zip is empty so it's worthless.

    Just download it from here if you're having issues:
    http://files.filefront.com/UT2004RegFix+13zip/;4088524;/fileinfo.html

    And don't forget .NET framework is required to run the fix! The attatched README should ensure you do it right.

    -Cheers
     

Share This Page