1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Running a dedicated server from home

Discussion in 'Unreal Tournament 3' started by IronMan(Erie), Nov 26, 2008.

  1. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    I have had an issue with running a UT3 server from my home. When I host an Internet game I cannot join the game from within my LAN but the game does show up in the Browser as an internet game. When I set it up as a LAN server I can join and play just fine. My issue is that I also run UT99 and UT2004 servers as internet servers on the same machine and I can join and play on them from the LAN while others can also join from the internet. UT3 seems to not allow this. I may be missing something but cannot seem to find out what it is. Is this game set up this way that online hosting is online hosting only and LAN is LAN only? I hope I am making myself clear on this.

    To sum up:
    Game set to host Internet = OK and others can see it in the browser and join it from online. Cannot join from LAN but can see server in browser. (Could join from LAN with UT99 & UT2004 with same setup)

    Game set to host LAN = OK and I and others can see it in the browser and join it locally.

    I also host other internet games like Quake 3 and COD and have no issue hosting internet games while playing locally at the same time. So this issue with UT3 is causing me to scratch my head. I searched around the internet a bit and didn't find info about this so far. Any hints or web links would be appreciated.
     
  2. Alhanalem

    Alhanalem Teammember on UT3JB Bangaa Bishop

    Joined:
    Feb 21, 2002
    Messages:
    2,237
    Likes Received:
    0
    Since both the server and the other computer on the lan have the same IP on the internet, when you send out your request (which seems to be going out to the internet and back) your request could be going back to the same computer instead of the server and thus you don't get a connection. NAT allows different PCs on the same network to use the same outside address without problems in most cases, but in this case it seems to be causing a problem because UT3 isn't using the LAN IP of the server, it's using the internet IP. When you have it set to LAN mode, it's not an issue because the IP used to connect to the server is the local network IP.

    thus it seems like some kind of NAT problem. I think the connection request is getting sent back to your client PC with the port number of the server but since there's no server there you're not connecting. But I can't say for sure. NAT should be doing something like this- when you send out your request, your router tacks a port number onto it with NAT (network address translation) and this port number is used to distinguish packets destined for one PC on your internal network from another. (x.y.z.w port 10000 goes to PC A, x.y.z.w port 20000 goes to PC B on the same network).

    But since other games work fine, it may just be an issue with how UT3 differentiates lan and normal servers. I'm willing to bet if you open the console and type "connect <LAN IP address of the server>" it will work.
     
    Last edited: Nov 27, 2008
  3. oldkawman

    oldkawman Master of Your Disaster

    Joined:
    Sep 18, 2008
    Messages:
    391
    Likes Received:
    0
    Are you talking dedicated server or what? Running a dedicated server works very well. Setting up a listen server, well that's something else.

    I have a linux dedicated server behind the same router as my game box and work station. Linux is easy, windoze I cannot say.

    Did you forward the correct ports on your router to the server? This uses the internal IP address of your box. You also need to turn off all firewalls on the server as your already behind the router firewall.

    Go to the server forums at epic and take a look at the how to threads.

    http://forums.epicgames.com/forumdisplay.php?f=343
     
  4. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    Yes this server is a separate physical box running in dedicated mode using the UT3 dedicated server program I downloaded and is patched to 1.3. The server is also a Windows XP OS. The reason I asked if I may have missed something is because of all the games I have hosted (Battlefield 1942, UT99, UT2004, Quake 3, COD, COD:UO, COD2, MOH:AA, and many more) I have always been able to host the server in internet mode and still able to join locally. UT3 has stumped me. I understand how NAT works and I will try the console command and see what happens since the browser doesn't connect me. I am presently still a student at Erie Institute of Technology taking Network Administration so I understand what is being discussed ok.
    Thanks for the ideas so far...
     
  5. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    Ok, I re-checked firewall and config settings and everything is as it should be. I used the console command to manually select the local IP address and it worked! Thanks SirTahngarth!
    The issue must be how UT3 handles the NAT issue thru the browser on the same network. Is Epic even aware of this I wonder? So if anyone else ever has this problem remember this solution.
    In case you don't know the console command:
    Open IP#

    Once again thanks for the help guys!!!
     
  6. Alhanalem

    Alhanalem Teammember on UT3JB Bangaa Bishop

    Joined:
    Feb 21, 2002
    Messages:
    2,237
    Likes Received:
    0
    Using DMZ on your router to fully expose the PC running the server to the internet may allow you to connect through the server browser properly.
     
  7. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    My last router had a DMZ function but this new one I have does not unfortunately. The routing device I use is the Westell Bridged-Router that Verizon issued to me with my DSL service. The Westell has somewhat limited options to set up and I just make due with it. My older D-Link I used to use that had much more options died years ago. But at least I can play locally and that was the biggest issue. I just upgraded my LAN to Gigabit speed and one day in the future I plan to get a better DSL Modem/Router. But what I really want is FIOS instead which is a few years away from being available in this area. ;) Thanks again!
     
  8. oldkawman

    oldkawman Master of Your Disaster

    Joined:
    Sep 18, 2008
    Messages:
    391
    Likes Received:
    0
    Can you setup your router to not be a router or firewall? Then just use your router behind the modem? Check this thread out, maybe it will fix you up.

    http://gearsforums.epicgames.com/showthread.php?t=613069

    Verizon FIOS is great. The actiontech modem/router was tricky to setup, but works flawlessly with my server.
     
  9. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    My Bridged-Router "IS" the DSL modem. It's an all in one device (it's a router, Switch, DSL modem, DNS, DHCP, firewall) so I cannot set up any router behind it until I purchase a new router. :(
     
  10. Nemezis

    Nemezis Marcio Nemezis Silva

    Joined:
    Mar 18, 2004
    Messages:
    69
    Likes Received:
    0
    Don't know if this is the right place, but its the exact problem I'm having in UT 99. My UT2004 dedicated server works fine, behind a router with port forwarding and so. I did the same for UT99 (the ports are the same, I never use both servers at the same time...).

    Thing is, I make an UT99 dedicated server, it minimizes, I run a 2nd copy of UT99, try to join the server in the LAN, but It gives me a 9999 ping... Other players from internet can join with no ping problems. But not me. I use the exact method in UT2004, and it works very well.

    Do I miss some patch or something? The UT99 has the 436 patch.

    note: I tried the solution of go to the console and type "open 192.168.1.2" and it worked perfectly; but I wanted the server to show up information on the LAN Browser, as UT2004 does (and I have done once in UT99 too, some time ago).
     
    Last edited: Dec 5, 2008
  11. oldkawman

    oldkawman Master of Your Disaster

    Joined:
    Sep 18, 2008
    Messages:
    391
    Likes Received:
    0
    Did you use the -multihome and -unattended on the command line or in your config? Also, you do need to use a seperate and distinct user name for the server.

    Also did you look here at the FAQ?
    http://forums.epicgames.com/showthread.php?t=586810
     
  12. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    I don't use the -multihome because I only have a single external IP address and I do have the -unattended at the end of my config. Also the server is named distinctly. Everything is working fine and I get traffic from the internet as I should. Using the "open" command to join from the LAN isn't a hardship but I'll live with it. So joining locally while running an internet server does work. Just cannot join locally using the browser unless the server is hosting a LAN game.
    Thanks for all the links you provided oldkawman! I didn't have some of those pages and the info will be valuable none the less!
     
  13. oldkawman

    oldkawman Master of Your Disaster

    Joined:
    Sep 18, 2008
    Messages:
    391
    Likes Received:
    0
    -multihome=xxx.xxx.x.xxx referes to the internal IP address of your server, your external address is always a single IP. The internal IP is the IP number assigned to the individual boxes by the router. It usually something like 192.168.1.101 for the PC, 192.168.1.102 for the server, and 192.168.1.103 for the game box. Then multihome=192.168.1.102 specifies which internal address is the server. This is also the IP that you forward the ports to.
     
  14. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    My NAT settings point to my server PC when I run them which has been successful for all the various servers I've run including TeamSpeak. What you are saying is that using -multihome it should be an additional pointer to my server PC where the game is hosted? And this may then allow me to use the browser from my game PC to find and join the server instead of using the open command?
     
  15. oldkawman

    oldkawman Master of Your Disaster

    Joined:
    Sep 18, 2008
    Messages:
    391
    Likes Received:
    0
    It's worth a try. I have used that on the command line since my first try and it works. But again, I run a linux dedicated server.

    There are routers that just will not work with UT3 according to some threads in the server admin section. But. yours does seem to work except for the joining via the server browser. Forwarding the specific ports to the server IP should have worked in itself, but maybe this fixes certain minor issues in some routers.
     
  16. IronMan(Erie)

    IronMan(Erie) Member

    Joined:
    May 31, 2005
    Messages:
    105
    Likes Received:
    0
    I used the -multihome and I still couldn't join from the browser. My server is a Windows box so maybe this is just related to that. Throughout all of this it is possible to see my server in the browser locally but it just will not join it unless it's strictly a LAN game. I appreciate all the assistance. I'm just glad to be able to join locally and if I have to keep using the console to do it then I'm fine with that. The whole point is I can play! ;)
     

Share This Page