1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Problems with Bonus and Community Weapons on Mac

Discussion in 'Troubleshooting' started by outrembill, Jul 11, 2005.

  1. outrembill

    outrembill New Member

    Joined:
    Jul 11, 2005
    Messages:
    2
    Likes Received:
    0
    Hey all. First time posting, so a little shy.

    Uhm, I wanted to address the problems some people have mentioned in previous threads as to getting bonus and community weapons to work on a Mac.

    In particular, I've tried installing both the Bonus pack and the INF ModTeam WeaponsPack mutators. With each I've placed all the files in all the correct locations. I've gone through all the .ini and .int files to ensure all pathnames are OS appropriate. And, for the bonus pack, I edited the .ini files to match their respective ADD-*.ini counterparts. In addition, I've ensured that the correct mutators are active.

    Now, as to what happens:

    The BONUS_* loadouts appear in the loadout menu, but none of the weapons (from either mutator) appear in either the loadouts themselves or in the interface used to customize the loadouts.

    Checking the log file, I get a similar error for each of the two weapon mutators -- but not, as you'll see, from other mutators:

    The ellipses (...), by the way, are supposed to indicate line continuity. This was meant to avoid leaving to chance where line breaks occur. Sorry if the above doesn't turn out to be very legible.

    So, although I realize folks are busy working on code for the HL2 implementation, I just wanted to bring to your attention that there may be a bug in the INF_Core.INFc_Weapon.CheckIcon function that only manifests itself on Macs.

    And then here's where the begging comes in: would it be possible for someone to peruse the code in the INF_Core.u file with an eye toward possible cross-platform conflicts in an attempt to verify whether this is in fact the case? Pretty please?

    I know all us (all 2 or 3 of us) Mac users would be deeply greatful.

    Thanks.
     
  2. cracwhore

    cracwhore I'm a video game review site...

    Joined:
    Oct 3, 2003
    Messages:
    1,326
    Likes Received:
    0
    I'm a little confused as to what you're saying...

    Are you saying that the mutator is loaded, and it shows up in the mutator list? But it does not show up when you try to customize loadouts?
     
  3. outrembill

    outrembill New Member

    Joined:
    Jul 11, 2005
    Messages:
    2
    Likes Received:
    0
    Essentially, yes. The mutator shows up. The actual weapons do not.

    As far as the loadouts go:
    The BONUS_* loadouts appear in the loadout menu. But when you examine them, they only contain non-bonus equipment: knife, any body armor, etc.

    Moreover, if you then try to customize those, or any, loadouts, all the normal weapons are available as usual, but none of the mutator weapons--from either mutator--are listed anywhere.
     

Share This Page