1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE3 - General Normal Mapping and Tangent Space

Discussion in 'Modeling & Skinning' started by MotherSuperior, Mar 27, 2009.

  1. MotherSuperior

    MotherSuperior New Member

    Joined:
    Mar 27, 2009
    Messages:
    1
    Likes Received:
    0
    We're having problems using normal projection maps from 3DSMAX and having them display properly in UE3. They look correct using the rendering in Max, but when it is brought into editor there are seams at the UV edges, which suggests to me, a problem with the tangent space.

    Is there a tool or a plugin available to Unreal, or a setting to use to allow accurate rendering of normal map tangent space on a UV edge?

    Please let me know if any of that is unclear so I can try and take a better screen shot or clarify what I'm trying to say.
     

    Attached Files:

  2. |*BILLY$CLINT*|

    |*BILLY$CLINT*| I make things happen!

    Joined:
    Jan 25, 2008
    Messages:
    532
    Likes Received:
    0
    Check the following options.

    1: Make sure that your smoothing groups are applied in 3Ds Max as it does not look like you have them on in Unreal.

    2: When importing a normal map there are specif setting you need to use like SRGB needs to be turned off and the first 3 zeros in the UnpackMin need to be set to -1.

    All of this is done for you if you select the option to import a normal map when you are importing your textures. Oh and can you also show me the shader network you are using so I can see if you have it all hooked up correctly.
     
  3. nELsOn

    nELsOn bSnakeCastShadow = True

    Joined:
    Aug 18, 2005
    Messages:
    1,307
    Likes Received:
    0
    smoothing groups seems to be a good point. i've had similar issues with meshes that did not use smoothing groups properly.
     
  4. raziel31

    raziel31 Active Member

    Joined:
    Nov 25, 2003
    Messages:
    1,054
    Likes Received:
    0
    First: if you render the normal map from max....enable in the Projection Options the Global Supersampler ( setup key then 'Enable Global Supersampler' then choose Max 2.5 Star.) The normal map will be smoother.

    Second: Just hide as much as you can the seams...it means the less seams you have the better will be your normal...theres no secret ;) It's why it takes time and effort to have a good model, your unwrap for the map channel 2 must be very clean.

    Also: Your example isnt a good one....you wont see in the game a simple sphere like this....try some more complex shapes where you will be able to hide your seams. Then your model will be better.
    Btw the unwrap of your sphere isnt optimal, you have too many seams !

    Yo !
     
    Last edited: Apr 1, 2009
  5. INhuman

    INhuman New Member

    Joined:
    May 26, 2009
    Messages:
    1
    Likes Received:
    0
    Only thing you need is just use proper (TC_normalmap) texture compression for normal maps. That's all.
     
  6. [SAS]Solid Snake

    [SAS]Solid Snake New Member

    Joined:
    Jun 7, 2002
    Messages:
    2,633
    Likes Received:
    0

Share This Page