1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

No Controller - an Nvidia Bug?

Discussion in 'Level Design, Skinning and Modelling' started by david.gerding, Feb 16, 2006.

  1. david.gerding

    david.gerding New Member

    Joined:
    Feb 16, 2006
    Messages:
    11
    Likes Received:
    0
    Hi,
    We've got an Unreal RT2 project that has been working fine. The build is shared via subversion.

    The new weird bug is that on two machines when you launch the level, the mouse control (view) functions but not the movement control. The only thing common between those two machines (one's a toshiba laptop the other is a dell workstation) is that they have nvidia graphics - keyboard and mouse hardware are different on both.

    On another machine with pathetic Intel integrated graphics, the same project loads with full, normal control functionality.

    Any help/ideas appreciated.

    Dave Gerding
     
  2. Angel_Mapper

    Angel_Mapper Goooooooats

    Joined:
    Jun 17, 2001
    Messages:
    3,532
    Likes Received:
    3
    Strange. Are there any errors in the log file, or any differences between the UE2Runtime.ini of the machines, or the User.ini?
     
  3. brunomartelli

    brunomartelli New Member

    Joined:
    Oct 1, 2004
    Messages:
    175
    Likes Received:
    0
    is numlock on or something
     
  4. david.gerding

    david.gerding New Member

    Joined:
    Feb 16, 2006
    Messages:
    11
    Likes Received:
    0
    Figured It Out - It was DirectX Version!

    Weird solution. The only thing I could figure out that was different on those machines was the DirectX build. The one that worked was the very latest December build. When we updated the directx to the December build on the non-functional machines, the controls worked again!

    Weird - given that the ur2 was built on a MUCH older version of directx.

    Anyhow, if you ever have your controls suddenly fail to work, try the latest build of directx.

    Thanks for the suggestions.

    Dave
     

Share This Page