1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE2 - UT2kX Map bug (everything goes black/transparent)

Discussion in 'Mapping' started by Addicted, Nov 29, 2010.

  1. Addicted

    Addicted New Member

    Joined:
    Oct 17, 2008
    Messages:
    20
    Likes Received:
    0
    Hey,
    I'm just developing a level for a university model (physics stuff), and i've ran into a bug. It's happened before but i can't remember how i fixed it last time!
    Basically somewhere i've changed part of the level and now when in the editor and testing the level, parts of the brushes i've played will go black/transparent and you can see the empty void of the rest of the level!
    I've also noticed that somehow this is linked to my skybox now breaking! :( The skybox works if i look in a certain direction, but as soon as i turn around in either direction it breaks again with the "lagged view of the frames"

    Here's a couple of screenshots to show what i mean!
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    hope you can help or suggest what i can do to fix it, reverting to an older version IS possible, but i _really_ do not want to if there is a fix, after doing alot of work since the earlier versions!

    Cheers,
    Matt
     
  2. Addicted

    Addicted New Member

    Joined:
    Oct 17, 2008
    Messages:
    20
    Likes Received:
    0
    fixed, it was the rollercoaster supports, i guess it doesn't like add brushes going through subtract! particularly circles!
     
  3. (ODC)Dragon88

    (ODC)Dragon88 New Member

    Joined:
    Feb 20, 2010
    Messages:
    6
    Likes Received:
    0
    Yes that is BSP and it can drive a person INSANE!!!! Happens more with tube, tessellated and revolved brushes. Also keep in mind antiportal brushes will generate BSP also if not used properly. Static mesh won't cause BSP errors so I try to keep most items in my maps as Static.
     

Share This Page