1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE3 - UT3 Lightmap Issues...

Discussion in 'Mapping' started by r2tincan, Sep 22, 2008.

  1. r2tincan

    r2tincan New Member

    Joined:
    Sep 17, 2008
    Messages:
    6
    Likes Received:
    0
    I am working on a "candyland" themed level, [thread], and I'm having some trouble lighting one of my meshes.

    This mesh is meant to look like ice cream, and it's proving more tough than I thought it would.

    I modeled this in max, and when I did so I UV'ed it as best I thought I could in order to avoid stretching. I also created a separate channel for a light map knowing this would probably need one. For the light map channel, I simply flatten mapped the mesh, (as this usually works well...).

    For the normal map, I projected a high-poly version onto the low-poly UV's, and presumably this will get rid of normal seams, correct? To add texture, I then created another normal from my diffuse in crazy bump and blended the two normals together.

    Here are my maps:
    [​IMG]

    My current result is this:
    [​IMG]

    Clearly something is wrong. This is without my custom light map enabled. So, I attempted to enable the custom light map UV's and it came out horrible. I then went back into max and created a seamless light map for the trouble areas, the current UV's are overlayed on this view from the mesh browser...

    [​IMG]

    The UV's look fine to me, does someone know what could be going wrong?

    Here are the mesh's settings and how the lights look when I render with the custom map. The result is actually WORSE than the engine's default lighting!

    [​IMG]


    At this point I have no idea what I'm doing wrong. Any ideas?
     
  2. ZixXer

    ZixXer New Member

    Joined:
    Jun 10, 2008
    Messages:
    21
    Likes Received:
    0
    Here are my maps:
    [​IMG]

    if you look at the 2e from above at the left you can see that the zides that are cut do not have the exact same coller. so if you put the sides together like in the staticmess the light maps are diferent.

    on side is more pink and the other more purple of the cut. that is the reason i beleave.
     
  3. Horror

    Horror New Member

    Joined:
    Jan 27, 2008
    Messages:
    86
    Likes Received:
    0
    Do these seams appear on the same section of the model in every circumstance? If you rotate it does the seam move to a different part of the model? I've had a few instances where (due to a lack of segments) a model was being rendered with what looked like seams, but this was based off the direction that the light was hitting it on.

    Also how much bleeding have you allowed along the border of your UVs?
     
  4. skyhave

    skyhave New Member

    Joined:
    Jul 24, 2008
    Messages:
    8
    Likes Received:
    0
    Your problem is probably the same as mine

    I've been modelling floating sky islands using Zbrush. I wanted to test my model with normal map to make sure it all worked before spent any more time working on it.
    Here is how it was suppose to look
    [​IMG]

    Here is how it actually looks with baked lightmaps
    [​IMG]

    When I plug the normal map into the diffuse you can clearly see seems where the UV's don't match up
    [​IMG]

    my point is the problem is the normal map and or the UV map no amount of setting changes in the editor will fix this.

    What I hope will fix this is changing the settings/configuration when generating the normal map in Zbrush. I'll let you know if have any luck.
     
  5. skyhave

    skyhave New Member

    Joined:
    Jul 24, 2008
    Messages:
    8
    Likes Received:
    0
    So far...

    I found that by using different configuration settings in the Zbrush Zmapper I could create an almost completely seemless normal map. However I was mistaken in thinking this would solve my lightmap issue.

    In my material I set the lighting model from MLM_Phong to MLM_NonDirectional. \o/

    I had tried this before and assumed that it hadn’t fixed my lightmap issue as it made my model completely white without any shadows. However I tried it again just now and found that if I multiplied my diffuse texture with a dark grey then I finally saw that my lightmap was all better.

    ...not really

    this only lit my model without taking the normal map into account. I noticed my model seemed to have lost some detail. So when I tried increasing the strength of my normal map it had no effect. :doh:
     
    Last edited: Oct 27, 2008

Share This Page