1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

installing ut4mod files in windows 7?

Discussion in 'Unreal Tournament 2003/2004' started by ravenus, Dec 24, 2010.

  1. ravenus

    ravenus The Heretic

    Joined:
    Oct 7, 2000
    Messages:
    352
    Likes Received:
    0
    I have Windows 7 64-bit and I recently installed my old fav UT2k4 in it. The game plays fine but I am unable to install any .ut4mod files even after associating them with the UT2004 setup.exe I remember that in XP you had to add a new file type and specify as ../setup.exe install "%1". But I don't know how to do that in Windows 7. Going to file types does not seem to offer adding of new parameters.
    I would appreciate any useful suggestions in this regard.
     
  2. Thanatosaurus

    Thanatosaurus Member

    Joined:
    Feb 21, 2009
    Messages:
    88
    Likes Received:
    1
  3. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    That site looks highly suspicious.

    There's always UT2Kx Regcheck, which should work for all Windows versions, though you will likely have to run it as administrator under Vista/Win7.
     
  4. Arnox

    Arnox UT99/2004 Mod Crazy

    Joined:
    Mar 26, 2009
    Messages:
    1,598
    Likes Received:
    5
    Try patching it again. Most of the time, if you install any mods, it will screw up the setup file and it won't launch at all. Repatching the game will fix this.
     
  5. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    Not for the UT4MOD file association. Oh, and there's another related bug: The Megapack installer garbles the [UT2004] Version= entry in Manifest.ini - change it to 3369 or install the standalone patch to fix that. (I suppose that's what you meant, Arnox.)
     
  6. Arnox

    Arnox UT99/2004 Mod Crazy

    Joined:
    Mar 26, 2009
    Messages:
    1,598
    Likes Received:
    5
    I think so. I was also talking about other mods that can garble up the version number when installed as well but whatever. :\
     
  7. ravenus

    ravenus The Heretic

    Joined:
    Oct 7, 2000
    Messages:
    352
    Likes Received:
    0
    UT2kx Regcheck didn't work for me in the sense that the clicking on the "insert" button only gives an error message.
    [​IMG]

    What worked was a roundabout technique of copying the mod file into the ut2k4 system folder, then going into command prompt and asking to "setup install [modname]"
     
  8. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    Remember to run it as administrator.
     
  9. ravenus

    ravenus The Heretic

    Joined:
    Oct 7, 2000
    Messages:
    352
    Likes Received:
    0
    D-oh. That worked. Thanks :)
     
  10. VendorX

    VendorX Member

    Joined:
    Aug 2, 2010
    Messages:
    224
    Likes Received:
    5
    All you need is:
    Code:
    REGEDIT4
    
    [HKEY_CLASSES_ROOT\.ut4mod]
    @="UT2004.Module"
    
    [HKEY_CLASSES_ROOT\UT2004.Module]
    @="UT2004 Module"
    
    [HKEY_CLASSES_ROOT\UT2004.Module\DefaultIcon]
    @="G:\\UT2004\\Help\\Unreal.ico"
    
    [HKEY_CLASSES_ROOT\UT2004.Module\Shell]
    @="open"
    
    [HKEY_CLASSES_ROOT\UT2004.Module\Shell\open]
    @="&Install this UT2004 module"
    
    [HKEY_CLASSES_ROOT\UT2004.Module\Shell\open\command]
    @="G:\\UT2004\\System\\Setup.exe install \"%1\""
    
    Make .reg file, put this in to, duble click and done...

    Somtimes (read - everytime) Win7 needs compatybility, try with Vista or XP or/and 'Run this program as an administrator' in properties 'Setup.exe '.
    Wait... No needed, it work.
     
  11. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    Registry stuff is the UT2Kx Regcheck's responsibility, the UT4MOD installer should just work if the Registry stuff is set up.
     
  12. VendorX

    VendorX Member

    Joined:
    Aug 2, 2010
    Messages:
    224
    Likes Received:
    5
    I don't trust a program with '...Check's' in the name. When he ask me my CDkey, network conection or my email adress...
     
  13. GreatEmerald

    GreatEmerald Khnumhotep

    Joined:
    Jan 20, 2008
    Messages:
    4,042
    Likes Received:
    1
    They ask them because that's what they use to reregister the game so you could play it without installing it, not because they are going to steal it. If you're paranoid, you can simply stop the connection to the internet while you enter it.
     
  14. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    Yes, please disconnect from the internet, that's the safest way for us all. :rolleyes:

    No really, what can you trust if not an officially endorsed utility.
     
    Last edited: Feb 7, 2011
  15. VendorX

    VendorX Member

    Joined:
    Aug 2, 2010
    Messages:
    224
    Likes Received:
    5
    1. Quesiton is not about trust, but what can you do yourself...
    2. Maby youre right... When i see discutions like that... On this forum you can find few people who locking for help and few who can give this help - all others is 'Off Topick'.
     
    Last edited: Feb 7, 2011
  16. jimdav

    jimdav flak cannon + minigun = FRAGS!!!

    Joined:
    Mar 18, 2011
    Messages:
    50
    Likes Received:
    0
    (Yes I know I'm a bit late) I have a problem with the .ut4mod extension as well. it's not that it doesn't know what to open it with, it just doesn't do anything when I try to open it. I'm using Windows 7 now, and its the first time I tried to open a .ut4mod on it. If I look at task manager when I open it, the proccess setup.exe comes up for about half a second, then crashes. I don't know what to do because every tool fixes the registry and not enything else. It could be compatibility, or I may have to run as admin, but because it is not a .exe I can't do either of those.
     

Share This Page