1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Infiltration 2.9 Common Problems

Discussion in 'Troubleshooting' started by Crowze, Dec 1, 2003.

Thread Status:
Not open for further replies.
  1. Crowze

    Crowze Bird Brain

    Joined:
    Feb 6, 2002
    Messages:
    3,554
    Likes Received:
    0
    Infiltration 2.9 Common Problems *please read before posting*

    This thread is the SECOND place you should look if you're having problems with Infiltration 2.9, the first being the manual. If you want something added to this, feel free to PM me.

    If what you're looking for isn't here, then [​IMG]. If there's no similar problems to what you're having, then post a new thread. Be sure to include your Infiltration.log, a screenshot if applicable, and a description of when the problem occurs.

    General - Entry point not found
    If you get the following error message when you try and start Infiltration:
    Make sure you are using UT (original, not UT2003/4) version 436 or greater. You can get the latest patch from www.unrealtournament.com.

    General - Strange animation issues
    You may find that the Inf soldier's waling animation is very odd, their actual position doesn't reflect the speed at which they are moving i.e. they can slide along the ground prone at high speed ;) (this doesn't affect the hitboxes though). I'm told it also has an affect on reload animations, and the hand animation in the dukeNades mutator.

    The problem is a very strange incompatibility between Infiltration and UT's high-resolution textures, found on the 2nd UT CD (if you have one). The solution is to copy the original textures from UT CD1 into UT/Textures. If you want to keep the hi-res ones for use with UT and other mods, you can put them into a separate directory e.g. UT/HiResTextures, and add 'Paths=../HiResTextures/*.utx' to your UnrealTournament.ini before the other paths.

    General - Game speed is too fast / game speed keeps changing
    This happens with modern processors such at the Pentium 4 6XX series, Pentium M and Athlon 64, which all vary their clock speed depending on load. The problem is, UT bases it's game speed off this, so when the clock speed varies, so does the game speed. The solution is to disable all power saving options while running UT - Blitzschlag has written a nice guide on writing a Windows batch file to do this.

    General - Network Speed Setting
    Before hopping on to a server, be sure to set your net speed as some people have had problems with the default speeds. Here's how to calculate and set it:
    Take your connection speed e.g. 64000Kb/s (ISDN) - for modems, use the actual connection speed you get, rather than the maximum (56k).
    Divide by 2 to simulate up/downstream (if your connection has different up and downstream speeds, take the slowest and skip this step) e.g. 32000Kb/s.
    Divide by 8 to get KBps, e.g. 4000KB/s.
    Take away about 10% to cover the overhead needed e.g. 3600KB/s.
    Now go to the console and type 'netspeed 3600', and you're done.

    General - in-game IRC client not working
    (Thanks to Almost)
    Gamesnet recently became Gamesurge and this has caused some problems with the ingame IRC client and the applet on the main site. Go to your Unreal Tournament\System-folder. Locate the file called Infiltration.ini and open it in Wordpad or similar. Somewhere between the middle and the bottom of that huge text document you'll find a few lines that looks like this :

    [INF_Menu.INF_MenuIRCSystemWin]
    NickName=Almost.
    FullName=INFPlayer
    OldPlayerName=Almost
    IRCServerHistory[0]=irc.gamesnet.net
    IRCServerHistory[1]=
    IRCServerHistory[2]=
    ...
    IRCChannelHistory[0]=#Infiltration
    IRCChannelHistory[1]=
    IRCChannelHistory[2]=
    ...and so on.

    What you need to do is add the new IRC server, irc.gamesurge.net. It should look like this :

    [INF_Menu.INF_MenuIRCSystemWin]
    NickName=Almost.
    FullName=INFPlayer
    OldPlayerName=Almost
    IRCServerHistory[0]=irc.gamesnet.net
    IRCServerHistory[1]=irc.gamesurge.net
    IRCServerHistory[2]=
    ...
    IRCChannelHistory[0]=#Infiltration
    IRCChannelHistory[1]=
    IRCChannelHistory[2]=

    ...but with your nicks, of course ;). For the record, the official IRC channel is still #infiltration. See you there.

    Windows XP
    (Thanks to ErehwoN)
    If any of you are experiencing issues running Infiltration on Windows XP (mainly lockups or strange sounds), install and use Analog X's MaxMem. That should help cure those problems.

    Windows - Unable to connect to v451 servers
    You won't be able to connect to servers using the 451 patch if you have the Creative EAX patch installed. Uninstall it as described here, and try again.

    Windows - Increasing OpenGL peformance
    (Thanks to FieldMedic)

    As you figured out when playing, INF 2.9 is a bit more intensive on your system than INF 2.86 was, due to everything has been improved in every way ;). So after trying several settings, tests, etc, i finally succeeded in improving the performance -on my system- , but if you have trouble in your case give a try folks.

    You will have to install the Chris Dohnal OpenGL that is normally installed with INF2.9 , but in some cases (it happened for me), due to your Antivirus function it is possible that only Epic OpenGL is installed instead. And honestly Epic OpenGL is less performing and less customisable than Chris OGL (but unfortunately it shouldnt work for linux, as chris introduced some window code in it) and has some graphic bugs (fixed by Chris OpenGL). So go download the version 2.4 in his website http://cwdohnal.home.mindspring.com/utglr/ and replace the OpenGLdrv.dll that is in your UnrealTournament\System folder with the OpenGLdrv.dll found in the downloaded .zip.

    Open the file Infiltration.ini (with notepad/wordpad) in your UnrealTournament\System. Search in that file the line [OpenGLDrv.OpenGLRenderDevice] and replace it and all that is under this category (stop at the line [D3DDrv.D3DRenderDevice] do not erase these and what follow these) with the following:

    [OpenGLDrv.OpenGLRenderDevice]
    RefreshRate=0
    DetailTextures=True
    UseTrilinear=False
    UseS3TC=False
    UseTNT=False
    LODBias=0.000000
    UseMultiTexture=True
    UsePalette=True
    UseAlphaPalette=True
    Translucency=1
    VolumetricLighting=False
    ShinySurfaces=True
    Coronas=False
    HighDetailActors=True
    MaxAnisotropy=1
    AlwaysMipmap=False
    UsePrecache=True
    SupportsLazyTextures=0
    UseBGRATextures=True
    UseAA=False
    NumAASamples=0
    AAFilterHint=0
    UseTexIdPool=True
    DynamicTexIdRecycleLevel=100
    UseTexPool=True
    TexDXT1ToDXT3=True
    SinglePassDetail=False
    UseDetailAlpha=False
    ColorizeDetailTextures=False
    UseCVA=False
    UseVertexProgram=False
    MaskedTextureHack=True
    OneXBlending=True
    TruFormMinVertices=0
    TruFormTessellation=3
    UseTruForm=False
    RequestHighResolutionZ=True
    SwapInterval=1
    UseMultiDrawArrays=False
    UseSSE=2
    BufferClippedActorTris=False
    DetailClipping=False
    MaxTMUnits=0
    NoFiltering=False
    UseFilterSGIS=False
    Use4444Textures=False
    AutoGenerateMipmaps=False
    ShareLists=False
    UseZTrick=False
    MaxLogTextureSize=8
    MinLogTextureSize=0
    MaxLogVOverU=8
    MaxLogUOverV=8
    GammaCorrectScreenshots=False
    GammaOffset=0.000000
    DescFlags=0
    Description=
    GammaOffsetBlue=0.000000
    GammaOffsetGreen=0.000000
    GammaOffsetRed=0.000000

    If you have a TNT2-class video card or older, be sure to set UseTNT to True.
    Eventually, to improve performance more, you can change the line up there
    LODBias=0.000000 to something higher (not too much as it get really ugly quickly) like LODBias=0.500000. Also, set ShinySurfaces=True to ShinySurfaces=False (but it will suppress those nice mirror effects that can be found on some floors). As a note, if you have problem, you should change
    RequestHighResolutionZ=True to RequestHighResolutionZ=False
    as some cards (dont know which) doesnt support the feature involved. And about the line RefreshRate=0 - it is used to have UT autodetect your monitor refresh rate, but if for unknown reason UT has a problem autodetecting it, put your monitor actual refresh rate e.g. RefreshRate=85 if your monitor is set to 85Hz. For more info in what those settings mean, you can read Chris explanations here: http://cwdohnal.home.mindspring.com/utglr/settings.html.

    If you use the OpenGL to play UT , be sure that in the Inflitration.ini file, you have this line exactly (it is near the beginning of the file, under [Engine.Engine] ):
    GameRenderDevice=OpenGLDrv.OpenGLRenderDevice

    Be sure to set the in-game colour depth to the same as your desktop colour depth - this can fix some graphical errors in UT (not certain if Chris worked around this, but it's best to be sure).

    Finally, you can always lower the resolution, that helps too ;). And if you are playing in 32 bits color depth , go play in 16 bits color (but it will not look as good of course).

    With this advice, you should have better performance. There are certainly other things to do, but that is all i can think of, so if someone has any other idea on tweaking for INF2.9 , PM me :).

    Windows - Increasing Direct3D peformance
    If you have a TNT2-class video card or older, then you're probably better off using the D3D driver that comes with UT v436. The following settings should be used in your Infiltration.ini:

    [D3DDrv.D3DRenderDevice]
    Translucency=True
    VolumetricLighting=False
    ShinySurfaces=True
    Coronas=True
    HighDetailActors=True
    UseMipmapping=True
    UseTrilinear=False
    UseMultitexture=True
    UsePageFlipping=True
    UsePalettes=True
    UseFullscreen=True
    UseGammaCorrection=True
    DetailTextures=False
    Use3dfx=False
    UseTripleBuffering=False
    UsePrecache=True
    Use32BitTextures=False
    Use32BitZBuffer=False
    UseVertexFog=False
    UseAGPTextures=True
    UseVideoMemoryVB=False
    UseVSync=True
    RefreshRate=75Hz
    DescFlags=1

    Windows - General peformance tweaks
    Search the category[WinDrv.WindowsClient] in your Infiltration.ini file then the following lines under this category and modify them
    ScreenFlashes=True and change it to ScreenFlashes=False (better for the eyes)
    Decals=True and change it to Decals=False (decals are realistic and usefull, so do this only in last ressort)
    NoFractalAnim=False change it to NoFractalAnim=True (it will stop the animation of the fire and the water , it will just be textures now but you should gain framerates there) - this helps a lot more in OpenGL than in D3D.

    In the Video options in-game, disable "Use Dynamic Light" if it is enabled, you will gain more framerate.

    In the Sound in-game option, set the quality to Low instead of the default High. this can be usefull when you have a bad soundcard or onboard soundchip. But even if you have a good card, give a try too, as there are a lot of different sound in the firefights, and lowering the quality can give performance.

    Hardware 3D sound adds a LOT of overhead to the sound occlusion calculations. For the fastest framerates, you should turn off 3D sound because of this.

    If you have to use Software Rendering, set the colour depth to 32bit - this peforms faster than in 16bit colour mode.

    Mac - Dual Boot OSX/OS9 problems
    (Thanks to bAd_ChIcKeN)
    Ok I have found a few hitches in the get-along if you are running OS 9 and OS X on your Mac. This mainly if you decide to run INF in OS 9 (in spite of the bugs with sound and graphic glitches). Seems the OS 9 Launcher script is pointed to the wrong UT app. Here is how to fix that:
    Open Script Editor located in Applications/Apple Script.
    Open the INF_Launcher_OS9
    Edit the line: tell application "Unreal Tournament OS X" to tell application "Unreal Tournament"
    Save
    And use this Launcher to Launch in OS 9

    The Launcher is assigned to the UT OS X app by default, so make sure you use the INF_Launcher_OS9 when and if you want to run in OS 9. I have noticed that the game gets a bit better FPS in OS 9 as opposed to OS X. But the sound and graphic issues are present, so its up to you if thats what you prefer.

    Also I noticed that if you are running in OS 9 and have the color depth set to 16bit and not 32bit the Menus are way off color wise, no biggie as they all function. but I just like the color scheme being correct so I use 32bit.

    Linux - Quick Action Menu problem workaround
    (Thanks to Rasalom)
    The only thing I have found as solution is to hold the QA Menu key followed by the number of the menu you want to access and then use mouse. For example, if you want to "vote reset" you press and hold QA Menu then press 3 then use mouse. It works fine, but soon I'll check another kind of solution, this one is not that good.
    Hope it helps.
     
    Last edited: Mar 8, 2006
Thread Status:
Not open for further replies.

Share This Page