1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Incompatible Game Files

Discussion in 'General Discussion' started by EggSuckingLeech, Aug 3, 2004.

  1. EggSuckingLeech

    EggSuckingLeech New Member

    Joined:
    Jul 27, 2004
    Messages:
    58
    Likes Received:
    0
    When trying to join servers on the Internet, I frequently get:

    Incompatible Game Files!
    .../System/UT2Vote42.u

    What does this mean and how do I solve it? It's true that I run UT2Vote42 but I didn't think it tried running it when I join other servers...
     
  2. tdw-socke

    tdw-socke New Member

    Joined:
    Nov 21, 2003
    Messages:
    990
    Likes Received:
    0
    look at your system-dir, and check, if UT2Vote42.u has the same size as that one in the official archive. If there is no UT2Vote42.u try reorganizing your cache and then it should appear. If it differs in size, please send it to us. It might be just a broken download, but it also might be a hacked version, to implent some kind of cheats... :D
     
  3. tuco[HaH]

    tuco[HaH] InstaGib Player

    Joined:
    Jul 2, 2004
    Messages:
    69
    Likes Received:
    0
    I get that stuff very often. Connect to one server, running UT2Vote42, for example. Then connect to another server, running UT2Vote43. Boom. Incompatible bla. Hit reconnect, then it works. Same with different AntiTCC versions. And it's an old bug, I noticed it since the beginning of UT2004, and my clanmates told me they experienced it in UT2003 already.

    It has nothing to do with UT2Vote itself, as far as I can tell, because I get the same problems with different AntiTCC and UTComp mutators when hopping from server to server.

    And a hit on the reconnect button always solves it.

    At least with the latest patch you get the error message. In older revisions of UT2004 you'd simply get disconnected, but hitting reconnect would magically solve it nontheless.
     
  4. EggSuckingLeech

    EggSuckingLeech New Member

    Joined:
    Jul 27, 2004
    Messages:
    58
    Likes Received:
    0
    will do. But can you give me the "official" link? I went to http://www.unrealza.co.za/proasm/ but all I see is a link to 43.

    I know I downloaded it from there initially. I assure you that if it's a hacked version, I certainly didn't do the hacking. But I really doubt it's any different unless there might have been a 42 version up there for a little while which was different (I grabbed it pretty early in the release).
     
  5. EggSuckingLeech

    EggSuckingLeech New Member

    Joined:
    Jul 27, 2004
    Messages:
    58
    Likes Received:
    0
    One thing I did notice but didn't test it well enough to be sure. I was running UTVote42 as a mutator under Instant Action (playing vs. bots). After seeing this msg alot when trying to join servers, I had a hunch and removed it from IA. Then tried to Join a server again and didn't have the problem. I figured that Instant Action and Online play were completely unrelated so I didn't sweat it until then.

    But like I said, I only joined 3 servers w/o a problem. Inconclusive as far as I'm concerned.
     
  6. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    It is quite possible that its UT2Vote's fault.

    This happened to us in UT2003 and after discussions with Joe Wilcox at Epic we discovered a way around the problem.
    In UT2004 Epic closed this loophole and now I cannot reset the problem anymore because the code is now 'Private and Protected' by Epic.

    Please try this to prove if its UT2Vote causing the problem.

    1. Start UT2004 and go into the WebBrowser
    2. Join a Server that is running UT2Vote
    3. Important... Under no circumstances bring up any Menu's what so ever.
    4. Play for a short while but Do Not let a Menu come onto your screen.
    5. Open your WebBrowser and join another Server that is NOT running UT2Vote.

    You should NOT have the 'Incompatible Game Files' problem.
    Exit to your desktop.
    Now go back to (1) above
    Now when you get to Step (3) - press Home and bring up the UT2Vote Menu.
    Once its up, open a few others and just close them, like the Mutators, Client etc.
    Now just Close the menu and goto step 4.

    After step 5, if its this problem, the moment you now join a sever NOT running UT2Vote you will get 'Incompatible Game Files'

    Can someone please check this so I can go and blast Epic.
     
  7. EggSuckingLeech

    EggSuckingLeech New Member

    Joined:
    Jul 27, 2004
    Messages:
    58
    Likes Received:
    0
    might be a bit before I can try...

    Is it important that the server joined is the same version I'm running (42)?
     
  8. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    Post deleted

    I have deleted this post as this problem runs a hell of a lot deeper than just the Weaponstats and once I get to grips with it I will make a full report.

    ProAsm
     
    Last edited: Aug 4, 2004
  9. EggSuckingLeech

    EggSuckingLeech New Member

    Joined:
    Jul 27, 2004
    Messages:
    58
    Likes Received:
    0
    great! I'll do it.

    But let me ask a question... Are you saying that if the SERVER runs both UT2Vote and UTComp then the problem still exists or are you talking about the client?

    It's good that you fixed this in 44. When is that scheduled to come out?
     
  10. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
    Yes, I am saying that if you are running UT2Vote42 or 43 and UTComp then regardless of what you do the problem will still be there.

    Any Mutator that shows Weapon Stats will cause this problem.
    Why the hell Epic always try and fix things that are not broken is anyones guess.
     

Share This Page