1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

UE2 - UT2kX Importing models with no textures from 3ds to UED

Discussion in 'Modeling & Skinning' started by frankieta, Oct 10, 2008.

  1. frankieta

    frankieta New Member

    Joined:
    Apr 25, 2008
    Messages:
    10
    Likes Received:
    0
    Hi, I'm very little practise with 3ds max and I'm developing a level for UT2004.
    I wanted to add some nice free models I found on the internet, but these are in .max or .3ds format.
    No problems, I know I must export them in ASE format, collapse, etc.
    But, some of these nice models have no graphic file for textures attached, they are only "coloured" in max itself I think (when I open the Material editor it show only coloured balls :)).
    So, when I import them into UED, only the default texture with the green bubbles appears.

    There's a way to export these colours also?
    Or I can import only models which have a texture file associated?

    Maybe some UVW mapping work, that I don't know nothing about?

    Thanks!
     
  2. frankieta

    frankieta New Member

    Joined:
    Apr 25, 2008
    Messages:
    10
    Likes Received:
    0
    Here is a screen of the viewport in 3dsmax, where I just loaded a free model of a rifle. You can see the model is coloured!
    [​IMG]

    But there's no graphic file attached, I DON'T KNOW how to have the same colours in UED also.
    This is the model after the Collapse->Exorto to ASE->Import into UED procedure:

    [​IMG]

    You can see there are 2 slots for the materials to apply, but what I can insert if I don't have anything?

    Hi!
     
  3. SolaceEternal

    SolaceEternal SPANK THAT TUNA

    Joined:
    Apr 29, 2004
    Messages:
    217
    Likes Received:
    0
    I'm not that knowledgable in this, but I can at least point you in the right direction.

    All I can tell you is it has to do with materials.

    In the second screenshot, try turning the "UseVertexColor" to True, see if that works. It might not; I haven't used UED in years.

    If you want it one solid color, that should be easy. Open MS Paint, fill the page with whatever color, save it, open it as the texture in UED.

    If you want it more complicated, you need to research UV mapping.
     
  4. IronMonkey

    IronMonkey Moi?

    Joined:
    Apr 23, 2005
    Messages:
    1,744
    Likes Received:
    0
    In the second of your pictures, expand the items marked

    Materials->0->Material.

    Ensure that you have a suitable texture selected in the UEd texture browser and a use selected option should be there when you select the final Material field in the static mesh browser.

    That will allow you to assign (in this case) two textures to the static mesh.

    If all you want is a solid colour similar to the original then you can create one very easily. I'm far from UEd at the moment so please forgive me if the details are slightly incorrect.

    Go into the texture browser and select file->new. You want to create a new material - in the bottom dropdown there is an option to create a new ConstantColor. Give the texture a unique name and place it in the MyLevel package. You can then select it to apply to the static mesh.

    Search around on the Wiki for the details:

    http://wiki.beyondunreal.com

    Have a look at some of the more complicated stock static meshes and you will see how they have multiple textures assigned.

    As for getting the original 3ds texture, if you can export the texture(s) from the 3ds model separately then you could import them into the MyLevel texture package and then make sure that the imported textures (well, one at a time) were selected before you expand Materials
     
  5. utra

    utra New Member

    Joined:
    Nov 29, 2008
    Messages:
    5
    Likes Received:
    0
    what i did to fix this problem was..

    First change the texture to .bmp using any image editing software (photoshop, paint ect) if you havent already.

    Next within max apply the new textures.

    now export the model (make shure you save the UVW settings) and import it in to unreal.

    now import the texture you used within max (unreal only suports a few file types BMP is one of them) Make shure you save them within the same package as the model

    after the texture is imported it should automaticly apply itself to the model.
     

Share This Page