1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

How to install UMOD files?

Discussion in 'Hardware, Software & Troubleshooting' started by hijks, Feb 24, 2001.

  1. hijks

    hijks New Member

    Joined:
    Feb 24, 2001
    Messages:
    3
    Likes Received:
    0
    Greetings!

    I am new to UT addons and have no idea how to install .UMOD files! Can someone please enlighten me what kind program I need or what steps I need to install new models and skins. Thank you very much :) !

    Stephen
     
  2. 8-4-7-2

    8-4-7-2 New Member

    Joined:
    Mar 6, 2000
    Messages:
    6,962
    Likes Received:
    0
    Welcome to PuF
    /me humps the n00b

    To install umods just doubleclick on them.

    Skins: there is usually a readme that tells where to put the files. utx goes to UT/Textures for example
     
  3. hijks

    hijks New Member

    Joined:
    Feb 24, 2001
    Messages:
    3
    Likes Received:
    0
    Uh-oh...

    Hello!

    Double-clicking UMOD does not seem to work on my system. Windows does not recognize the file as any readable files, so every time I double-clicked it, it just pops up a list of files for me to open. Is there any other way to help decompress the UMOD if double-clicking is not working :( ? Thanks!

    Stephen
     
  4. 8-4-7-2

    8-4-7-2 New Member

    Joined:
    Mar 6, 2000
    Messages:
    6,962
    Likes Received:
    0
    You have a b0rked file assocation

    If even that somehow fails, reinstall UT
     
  5. Robot TinMan|BuF

    Robot TinMan|BuF Godlike Blues Brutha

    Joined:
    Feb 13, 2001
    Messages:
    1,634
    Likes Received:
    0
    Hmm, try to drag the umod file onto the Unrealtournament.exe file.
    That would be the same as Shift + right click the umod and choose "Open with" and then find the Unrealtournament.exe
    If Ur on Windoze that is. ;)
    For Mac: I have no clue. :p

    Edit: I just luuv simultaneous postings.;)
    Try the above, but remember to backup the registry 1st.
    Edit2: I meant for him to try Ur solution 8-4-7-2, but I wasn't clear enuf I guess. Sorry, my bad.
     
    Last edited: Feb 24, 2001
  6. 8-4-7-2

    8-4-7-2 New Member

    Joined:
    Mar 6, 2000
    Messages:
    6,962
    Likes Received:
    0
    Tinman: that won't work because Windows fails to link the umod with the setup.exe (that's the install file btw)

    The fix above will restore that link
     
  7. Viking1

    Viking1 Highly Unstable

    Joined:
    Aug 12, 2000
    Messages:
    474
    Likes Received:
    0
    D'oh, you beat me to it.

    Thanks 8-4-7-2
     
  8. Gothik

    Gothik Day Tripper

    Joined:
    Jun 8, 2000
    Messages:
    266
    Likes Received:
    0
    If you feel uneasy about editing your registry here is an alternate method of achieving the same result:

    Associating:
    Dunno why this is such a problem for everyone. The .umod file is associated by the UT setup program during set-up in exactly the same way as any other file association... I might buzz Tim S about it... To make the association manually, do the following:

    1) Open Windows Explorer.

    2) Click the View menu, and roll the mouse down to 'Folder Options'. Click it. Click the File Types tab in the ensuing dialog box.

    3) A list of registered file types will appear. Scroll down the list looking for the UMOD file type (the list is in alphabetical order).

    4) Is it there? If so, exit the dialog box, find a UMod file, and double-left-click it. Did a setup program start? If so, follow the setup instructions -- umods are working on your system. Otherwise, go back to step one, and when you get to step three, highlight the UMOD file type and click the Remove button.

    5) if it is not there, click the New Type button. Enter the information as follows:
    Description of Type: UT Module
    Associated extension: umod
    (Just ignore Content Type)

    6)Under Actions, click the New button. In this dialog box, fill out the information as follows:
    Action: Install this UT Module
    Application used to perform this action: C:\UnrealTournament\System\Setup.exe install "%1"
    The above presumes that UT is installed at C:\UnrealTournament\. If it isn't, correct the directory address in the above.

    7) Click OK, then click the Install this UT Module display in the Action box. Click the Default button. Click OK (you might want to specify an icon -- it's up to you). Click OK again.

    8) Locate a UMOD, and double-click it. If a setup program does not show up, you've done something wrong. Repeat all the steps again until it does.
    This helped me, so try it out if you are getting nowhere with umods.
     
  9. INJEKTILO

    INJEKTILO *******

    Joined:
    Jan 31, 2001
    Messages:
    30
    Likes Received:
    0
    This helped me use UMODs when i was using the "ripped" version.
     
  10. Drillah

    Drillah New Member

    Joined:
    Feb 24, 2000
    Messages:
    6
    Likes Received:
    0
    Before I try the Registry fix, (I have the association correct), does it have anything to do with fixing a critical error regarding Virtual memory during install. I have attached an image of the error message I get when I try to install the .umod for U4ET6. No other .umod files have ever been succesfully installed either.

    Every time I attempt to install a .umod, including u4eT6, I get a critical error stating that I have run out of virtual memory. I have altered my VM settings several times to include using Windows default settings, my second partition with over 5 GB free and using my C drive with over 2GB free specifying no less that 1000 MB at any time. This critical error has got to be bogus.

    Win Me OS
    Duron 600 CPU
    256 PC 100 RAM
    SB Live X Gamer sound
    Hercules 3D Prophet DDR-DVI video
    USR 56k external modem
    Memorex 32x cd-rom
    Plextor Plexwriter 12/10/32A cdr-rw
    Netgear NIC
    ATI TV Wonder VE
    Floppy
    MS Sidewinder Precision Pro USB joystick
    MS Sidewinder Dual Stike USB game pad
    Logitech Wingman Formula Force USB wheel
    Altech Lansing ACS 45 speakers
    HP 932C Deskjet printer
     
  11. Viking1

    Viking1 Highly Unstable

    Joined:
    Aug 12, 2000
    Messages:
    474
    Likes Received:
    0
    I notice the error says that UT is on your D drive. You will need to edit the reg fix(Just change all the C drive entries to D's). However some mods seem to have a problem when UT is not installed to the default directory(C:\UnrealTournament)even when everything is fine. You may just need to do a scan disk in Windows, could be that your free disk space is being reported wrong in Windows.
     
  12. Drillah

    Drillah New Member

    Joined:
    Feb 24, 2000
    Messages:
    6
    Likes Received:
    0
    .umod and VM error...

    I tried the Registry fix above and it did not work.
    I tried a plain install over the current install, it did not work. Here's what I had to do...

    Save my MAPS, SOUNDS, and TEXTURES folders to a temp dir so I did not lose all that good stuff.
    Uninstall UT.
    Opened the registry editor and did a search for anything that said ".umod" or "tournament" and deleted everything that I found. (if you try this check what you are deleting first as other games may have some entries containing the word "tournament").
    Reinstalled UT.
    Reboot.
    Patched it to 436.
    Installed bonus pack.
    Started the game and ran a practice session.
    Stopped the game and did a reboot.

    After that, all my downloaded .umod files installed just like they aere supposed to.

    u4eT is AWSOME!!!

    Thanks for all the help.

    Drillah

    Oh yeah, then I copied my MAPS, SOUNDS and TEXTURES folders back to the UT dir.
     
    Last edited: Feb 25, 2001

Share This Page