1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Here is a fix for some UnrealED problems

Discussion in 'Mapping' started by Githianki, Dec 9, 1999.

  1. Githianki

    Githianki New Member

    Joined:
    Nov 11, 1999
    Messages:
    71
    Likes Received:
    0
    After a couple of hours comparing a working installation with a non-working installation on the same computer I have pearls of wisdom for people getting error like this:

    Warning: Failed to load 'Class None.ini:Engine.Engine.EditorEngine': Can't find 'ini:Engine.Engine.EditorEngine' in configuration file
    [taken from log file but similar pop up]

    If you installed the UnrealED fix from disc 2 it corrupts your unreal.ini file causing this error [jump below to fix]. In fact, the first disc installs everything you need to use UnrealED except a shortcut. You may still need the VB files and RichText fixes. Even so do not use the UnrealED installer on the second disc. get them from somewhere online. The disc 2 installer would seem to be meant only for fixing installations of UnrealED with Unreal, not UT. That is why it defaults to the Unreal directory. I don't even know if it works there, but since it is the same as the download from Epic's site and that works, I guess this one should too. If you are UT only then don't worry about it.

    Again, you don't need to use the UnrealED fix on disc two to use UnrealED with UT. The proper UnrealED installs when you install the game from disc one. You need to make a shortcut if you want one.

    Now if you have the error mentioned above check your unreal.ini file in the system directory. If you have a unreal.ini file which is only a dozen or so lines long (open in Notepad), this is your problem.

    To fix this situation, do a clean install of disc 1, and then make a shortcut to UnrealED.exe (Experienced users: using -nosound or -nodsound is no longer necessary because those engine items have been fixed in UT. Sound browsing works fine.).

    If you want to preserve your settings, rename your tourney folder or backup your various .ini's (not sure which but do all to be safe) and any .usa's if you have them. Then do a new install of disc 1, copy the new unreal.ini into your backup or the .ini's, etc into the new version. Either way you then can delete what you don't need.

    Unfortunately, unreal.ini is a generated file and can't just be copied off the CD. If anyone has a better way to do this please add to this thread.

    Happy editing!
     
  2. Wanderer

    Wanderer New Member

    Joined:
    Jul 7, 2000
    Messages:
    1,334
    Likes Received:
    0
    Odd. I installed UED for UT from the second CD and I haven't had any problems out of the ordinary.
     
  3. Githianki

    Githianki New Member

    Joined:
    Nov 11, 1999
    Messages:
    71
    Likes Received:
    0
    Odd, did you have Unreal already on your system?
    I repeatedly tried various combinations of install setups until figuring out the above. Everytime, the second CD screwed it up.
    Very strange indeed!
     
  4. Wanderer

    Wanderer New Member

    Joined:
    Jul 7, 2000
    Messages:
    1,334
    Likes Received:
    0
    Yep, I previously had Unreal installed along with all of it's fixes. Which included VbRun6 and the UnrealEdFix4.
     

Share This Page