1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Half-Life Problem

Discussion in 'Off Topic' started by Twisted Metal, Jan 26, 2002.

  1. Twisted Metal

    Twisted Metal Anfractuous Aluminum

    Joined:
    Jul 28, 2001
    Messages:
    7,119
    Likes Received:
    3
    My Half-Life refresh rate is defaulted at 60 hz, which you know causes some visible flicker which is not that annoying when looking straight at the screen however when seen through peripheral vision it becomes really noticable.

    Windows is running at an 85 hz refresh rate and I found that the reason Half-Life runs at 60 hz is because it runs in 16 bit color. I know Half-Life could be run in 32 bit color with the -32bpp command in the target box, but that did not fix anything. So, after looking for a solution for the problem on the internet, I found an NVidia refresh rate fix utility which just sets the refresh rate for ALL possible resolutions and ALL possible color depths. So I run it and set everything to 85.

    So then I run Half-Life and guess what? It worked. It was running at 85 hz. But guess what else? The framerate got b0rked. It was running at what I estimate to be around 30-40 fps. Now before this refresh rate fix, when Half-Life was running at 60 hz, the frame rate was perfectly smooth, always running at the maximum fps. But now since I raised the refresh rate to 85, the framerate drops. Why is this? How could setting the refresh rate higher make the framerate drop? If anything it should rise. It makes no sense.

    VSync is on, because when it is off it causes screen tearing. I did try turning it off, but it had no effect. I tried going back to the original Hercules drivers that came with my card. Same problem. So I reinstalled the newest NVidia ones.

    So now I am back to running Half-Life at 60 hz which has a perfect frame rate, but some flicker. My Quake III engine games(Quake III, Medal of Honor, Wolfenstein) run great at 85 hz, but that was set from within the game. Unfortunately, Half-Life has no built in command to change refresh rate. I really don't get it. All the refresh rate fix does is set the refresh rate for all resolutions and color depths. So I set it to 85 and gee wiz my framerate in Half-Life drops. Wonderful. Any ideas?
     
  2. Blorgg

    Blorgg New Member

    Joined:
    Feb 7, 2000
    Messages:
    1,582
    Likes Received:
    0
    Maybe this is what you're looking for, it works for me :)
     
  3. Twisted Metal

    Twisted Metal Anfractuous Aluminum

    Joined:
    Jul 28, 2001
    Messages:
    7,119
    Likes Received:
    3
    No, that's what I used and yeah it worked, but it slowed down my framerate in Half-Life which is my problem.
     
  4. Blorgg

    Blorgg New Member

    Joined:
    Feb 7, 2000
    Messages:
    1,582
    Likes Received:
    0
    Sorry, didn't read that carefully :/
    You're not running in Direct3D are you? If so try: start-->run-->dxdiag-->More Help-->Override and fill in your refreshrate there.
     
  5. Twisted Metal

    Twisted Metal Anfractuous Aluminum

    Joined:
    Jul 28, 2001
    Messages:
    7,119
    Likes Received:
    3
    Nope, OpenGL.
     

Share This Page