1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Conver Unreal maps to UT

Discussion in 'Mapping' started by Digitalia, Dec 16, 1999.

  1. Digitalia

    Digitalia New Member

    Joined:
    Dec 16, 1999
    Messages:
    28
    Likes Received:
    0
    It's possible?. How can I do it?
     
  2. Wanderer

    Wanderer New Member

    Joined:
    Jul 7, 2000
    Messages:
    1,334
    Likes Received:
    0
    Simply copy the map from the Unreal/Maps folder to the UnrealTournament/Maps folder.

    It is then highly suggested that you go into the map and replace all the Unreal weapons with the UT weapons.

    Rebuild and Paths Define and your set.
     
  3. alien8

    alien8 Run, you magnificent bastard.

    Joined:
    Jul 18, 1999
    Messages:
    1,466
    Likes Received:
    0
    In some deathmatch maps for Unreal, some creators didn't specify in the LevelInfo that it's a deathmatch map. You might run into troubles running an Unreal map in UT if this is the case.

    If it happens, it's easily fixed. Open the map in UnrealEd, go to Browse/Classes and expand Info-GameInfo-TournamentGameInfo and select DeathMatchPlus. Then go to the top menu, select Options, LevelInfo, and choose DefaultGameType. Making sure that DeathMatchPlus is still hilited, press Use.

    Rebuild, Save, and you should be ready to go.

    [​IMG]
    alien8
    PlanetUnreal | ModCentral Unreal
     
  4. Wanderer

    Wanderer New Member

    Joined:
    Jul 7, 2000
    Messages:
    1,334
    Likes Received:
    0
    Alien8, I could be wrong... but doesn't that change the file and it's internal structure to some extent (like it's ID code and filesize).

    As long as the file as the proper prefix it should work. The DefaultGameType doesn't need to be set.
     
  5. alien8

    alien8 Run, you magnificent bastard.

    Joined:
    Jul 18, 1999
    Messages:
    1,466
    Likes Received:
    0
    Wanderer:

    I had an old map that I had made with 224 Unreal, and I went thru it and replaced all the weapons to UT versions, did the path define thing again, rebuilt and saved it. It was named with the proper DM- prefix, but whenever I tried to play it, all I got was UT dumping me back to desktop.

    I had a helluva time trying to figure out what was the matter, and I was actually just kinda fooling around when I noticed that the DefaultGameType was empty. I did the above, and everything worked fine.

    Strange, I know. Coulda just been one of those Windows-coincidence things though too, who knows /~unreal/ubb/html/wink.gif

    [​IMG]
    alien8
    PlanetUnreal | ModCentral Unreal
     
  6. Digitalia

    Digitalia New Member

    Joined:
    Dec 16, 1999
    Messages:
    28
    Likes Received:
    0
    And How can I put a screenshot from the map to preview it before selecting in the map list?
     
  7. alien8

    alien8 Run, you magnificent bastard.

    Joined:
    Jul 18, 1999
    Messages:
    1,466
    Likes Received:
    0
    In the June 16, 1999 news from http://unreal.epicgames.com is this:

    Take a screenshot of your map.
    Use an art program to convert the shot to a 256x256 .BMP or .PCX.
    Start UnrealED.
    Select the Texture browse tab.
    Click "Import" and select the screenshot you took.
    Enter the Package name "MyLevel" make sure you spell it just like that.
    Enter the Texture name as "Screenshot" make sure you spell it just like
    that.
    Import the screenshot with mipmaps turned off.
    Open the Level Properties for your map.
    Under Display, set the texture to the one you just imported.
    Save your map.

    Thanks to GreenMarine for that bad boy.

    [​IMG]
    alien8
    PlanetUnreal | ModCentral Unreal
     
  8. Digitalia

    Digitalia New Member

    Joined:
    Dec 16, 1999
    Messages:
    28
    Likes Received:
    0
    Thank you very much for your kindful answers. Only a question more; I have tried to convert two maps from Unreal: DMCamelotR3 and DMBreakfast, but, when I try to open it on the UT editor, nothing occurs. I have no problem with another maps like DMCobblestone. Do you know what's wrong?.
    Thanks again.
     
  9. ether

    ether New Member

    Joined:
    Feb 1, 2000
    Messages:
    39
    Likes Received:
    0
    I thought i used to be able to load Unreal I levels into UnrealEd, and DM maps still work, but now, if i try to load Bluff.unr or other single-player maps, it loads for a long time and then gives me a blank map.

    Any suggestions?



    [​IMG]
    --ether
    http://www.remixradio.com/ut/
     
  10. Jenkins

    Jenkins America's Greatest Kitten Mitten

    Joined:
    Apr 24, 2000
    Messages:
    1,301
    Likes Received:
    0
    Well, if there are some textures used in Bluff.unr that aren't associated w/ UT, then you have to move those textures from Unreal to UT... then load it and it should work.

    [​IMG]
    Jenkins
     
  11. FatAsss

    FatAsss New Member

    Joined:
    Jan 26, 2000
    Messages:
    162
    Likes Received:
    0
    You need the unreal 1 music files, to run single play levels
     
  12. ether

    ether New Member

    Joined:
    Feb 1, 2000
    Messages:
    39
    Likes Received:
    0
    The .umx files did it.. Kinda cheezy the editor just refuses to load. Whatever. At least its working now.

    thanks
     

Share This Page