1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

can't get m16a4 mutator to work

Discussion in 'Troubleshooting' started by ovw, Jun 27, 2004.

  1. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    Hi All,

    I just dl'd a couple of mutators: m16a4, xm8, and newnades. I can see the mutators in the mutator list and have actually selected them, but I cannot find any loadouts or even a listing for these weapons in the loadout screen. I placed the files in the unreal/system folder per instructions, but nothing. I only post this because I have now spent most of two hours trying to get them to work. I even added the 'serverpackage' lines.

    Any info would be greatly appreciated.

    OVW
     
  2. Bushwack

    Bushwack Avenged Sevenfold...

    Joined:
    Jul 21, 2003
    Messages:
    564
    Likes Received:
    0
    they should be in there, what files did you actually put in the UT/SYSTEM folders? There should be 3 files for each mutator, .int, .u, .ini

    XM8, and M16A4 will be in ASSAULT RIFLES in your loadout creation menu, the new nades should show under EXPLOSIVE DEVICES/PROJECTORS as a type of 40mm to add to your loadout.
    Hope that helps.
     
  3. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    Yup, placed all 3 files into ut/system folder. The nades showed up but not the rifles.

    Thanks,

    OVW
     
  4. keihaswarrior

    keihaswarrior New Member

    Joined:
    Jan 7, 2003
    Messages:
    1,376
    Likes Received:
    0
    Just a note: You don't need the .ini file. The .ini files for mutators are only for enabling/disabling different features of the mutie.

    To use the mutator you need the .u file
    To see the mutator in your mutator list and loadout screen you need the .int file.

    Make sure they are in the UT/System and NOT the UT/Infiltration/System folder.
     
  5. Cleeus[JgKdo]

    Cleeus[JgKdo] because respawns suck

    Joined:
    Jun 8, 2002
    Messages:
    798
    Likes Received:
    0
    incase noone noticed, the m16a4 has an ugly package dependancie to yurchs new40mm package. you need to install this too.
     
  6. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    Yeah saw that...a bit tricky, but I have all of these things. Does it matter that I am on a mac, running osx? I saw that they refered to serverpackages is adding that mandatory? What I am going to do now is test those new nades to make certain that they work. As of this morning still no m16a4. Once the mutator is activated this will appear in the loadout screen correct? Right there with the other assault rifles?

    Thanks to all,
     
  7. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    Okay, what does this mean. I just tried using the new nades. Are the victims of the incindiery nades supposed to burn? They didn't. How can you tell if the bouncing nade bounces? I mean they worked in that I killed a BUNCH o' people but I couldn't tell if they worked right. And no, I still don't have either the m16a4 or the xm8.

    ovw
     
  8. Cleeus[JgKdo]

    Cleeus[JgKdo] because respawns suck

    Joined:
    Jun 8, 2002
    Messages:
    798
    Likes Received:
    0
    you only have to have the file "new40mm.u" in your /ut/System/ folder - nothing else needed.
     
  9. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    ok...I have in my ut/system folder these files:

    infm16a4.ini
    infm16a4.int
    infm16a4.u

    with them are these:

    dukexm8.ini
    dukexm8.int
    dukexm.u

    and finally

    new40mm.int
    new40mm.u

    is this all that I need?

    Thanks again for all your help,
     
  10. Cleeus[JgKdo]

    Cleeus[JgKdo] because respawns suck

    Joined:
    Jun 8, 2002
    Messages:
    798
    Likes Received:
    0
    afaik, yes it is.
     
  11. mat69

    mat69 just fooling around

    Joined:
    Dec 9, 2001
    Messages:
    849
    Likes Received:
    0
    Ok, then you should try editing your INF_Loadouts.ini by hand, maybe it will work.
    This will give you a M16A4 with some other stuff (replace the XX with the next "blank" loadout-number):
    ItemString[XX]=M16A4//M16A4-1,#M16A4sup-1,#M16A4203-1,*M16A4-5,*M203A4-2,+M67-1,KHELM-1,AVL3A-1,

    Maybe someone is going to post other loadouts, if not I am doing it this evening.
     
  12. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    hmmm...how many copies of INF_loadouts.ini should I have and where should they be? I have one in UT/system and another in main UT folder.

    OVW
     
  13. Cleeus[JgKdo]

    Cleeus[JgKdo] because respawns suck

    Joined:
    Jun 8, 2002
    Messages:
    798
    Likes Received:
    0
    hmm, only one in UT/System/

    If you have one in UT/ then its either a backup you did yourself or you maybe don't run INF correctly
     
  14. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    What does this mean, I got it from my infiltrationx.log. I was going to post all of it but there is quite a bit. One for each part of both the M16a4 and the xm8:

    Warning: Failed to load 'Class INFM16A4.INFM16A4': Can't find Function in file 'Function INF_Core.INFc_Weapon.CheckIcon'

    Thanks again,

    OVW
     
  15. Cleeus[JgKdo]

    Cleeus[JgKdo] because respawns suck

    Joined:
    Jun 8, 2002
    Messages:
    798
    Likes Received:
    0
    uhm, which version of INFiltration do you have?

    weapon addons only work with INF2.9

    If you already have INF2.9 then maybe the INF_Core package is damaged
     
  16. mat69

    mat69 just fooling around

    Joined:
    Dec 9, 2001
    Messages:
    849
    Likes Received:
    0
    Last edited: Jun 29, 2004
  17. =D.C.L.I=Snipez

    =D.C.L.I=Snipez New Member

    Joined:
    Mar 7, 2004
    Messages:
    42
    Likes Received:
    0
    I know a mac user who always needs to update the files available at combatmaps. If you have a mac it is essential to get it instead of reinstalling INF 100 times.
     
  18. MP_Duke

    MP_Duke Banned

    Joined:
    May 23, 2002
    Messages:
    711
    Likes Received:
    0
    If you're on a unix-based system, make sure you rename the files to look like this:
    INFM16A4.ini
    INFM16A4.int
    INFM16A4.u

    unix is case-sensitive.
     
  19. Crowze

    Crowze Bird Brain

    Joined:
    Feb 6, 2002
    Messages:
    3,556
    Likes Received:
    1
    It does actually do a case-insensitive search for packages it can't find, but the essential one you set the extension to lowercase is the int.
     
  20. ovw

    ovw New Member

    Joined:
    Oct 18, 2000
    Messages:
    148
    Likes Received:
    0
    Wow! This is great, I'm getting better tech support here (for a free game) than I did when I paid $50 for baldur's gate! As I've said numerous times you guys (inf team and the inf'ers) rock!

    Just dl'd files (from post above) will try them out and let you know the outcome.

    Thanks all!

    OVW
     

Share This Page