1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Another S3TC Related Question

Discussion in 'Unreal' started by Freddie, May 28, 2009.

  1. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    Hi,

    In my previous post, I talked about problems I had in installing the S3TC textures on my system running Vista. Those issues have been resolved, but now I have another problem for which I need assistance.

    I've now installed those textures in my other computer using WinXP (Home Edition), running an Intel P4 3.06 GHz processor, and using 1 GB of system RAM. The video card is an ATI Radeon 8500 with 128 MB of memory, a D3D card with Catalyst drivers. I've installed Patch 227f.

    This system runs the high level S3TC textures well in Unreal, but I have two problems, as follows:

    1. Using the D3D8 renderer, everything works well, except one thing: You all know at launch the Nali Castle spins and you see a message saying "Press Esc to continue." Well, the Nali Castle doesn't spin (it's locked) and pressing Esc doesn't do anything. However, pressing the Windows key Brings up the Desktop and places the Unreal icon on the Task Bar. Then, clinking the Unreal icon on the Task Bar brings it up with the Nali Castle spinning. Pressing Esc then allows the game to proceed normally.

    Can this behavior be fixed?

    2. The 2nd problem concerns using OpenGL, as follows: With the Preferences set properly (in Advanced) and exiting the Advanced page, the screen darkens to about the same level as that which you get when you select level 1 while pressing F11 (brightness).

    Closing down Unreal and relaunching, brings up the normal brightness and the game can proceed normally. However, when you close Unreal and return to the Desktop, the Desktop screen is all washed out. You know how the Desktop screen washes out when you launch Unreal? Well, it stays that way when I close Unreal using OpenGL (not when using D3D8).

    I can't correct this washed out look. When I reboot the computer, it goes into sleep mode rather than restarting. Hitting the "reset" button reboots the computer and brings up the Desktop with normal brightness.

    Anyone have any idea what going on with this brightness thing?

    Thanks,

    Freddie
     
    Last edited: May 28, 2009
  2. SkaarjMaster

    SkaarjMaster enemy of time

    Joined:
    Sep 1, 2000
    Messages:
    4,725
    Likes Received:
    1
    This is a bug with OpenGL that Chris Dohnal talks about on his web site and seems to also happen with Unreal as well as UT.
     
  3. Dark Pulse

    Dark Pulse Dolla, Dolla. Holla, Holla.

    Joined:
    Sep 12, 2004
    Messages:
    6,186
    Likes Received:
    0
    There's a couple ways fix that.

    1. If you have UT2003 or UT2004, launching and closing UnrealED is a reliable way to reset the gamma.
    2. There's some "Gamma Reset" programs on the web. If you can't find one, I can upload one.
     
  4. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    SkaarjMaster & Dark Pulse,

    Thanks for the information. Today, the separate HDD (not system drive) on which I had my games installed went bad (click of death). I have a replacement coming from newegg soon. I'll get back when I finish reinstalling my games. Until then, keep a stiff upper lip.

    Freddie

    For SkaarjMaster: can you provide a link to the Chris Dohnal comments about this issue?
     
    Last edited: May 28, 2009
  5. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    All,

    Today, in my Windows XP system, I managed to install all my games on a new hard drive. The brightness problem is still an issue in both Unreal and Unreal Tournament when using OpenGL. So, I have to use D3D8 (see my first post, above, for details). However, with D3D8 I have that launch issue indicated in my original post, above. Other than that issue, I have no problems with D3D8.

    Regarding the brightness issue with OpenGL, I'm using OpenGL with both these games in my other computer running Vista. The Vista system has no brightness problems, but it's using an ATI Radeon X1650 (Catalyst drivers). My WinXP system is using an ATI Radeon 8500 (older, but still quite good), so maybe that's the difference helping cause the brightness issue with OpenGL only on the WinXP computer.

    I have no clue as to what is causing this issue, apart from SkaarjMaster indicating that a bug in OpenGL is causing this. However, note that the bug doesn't appear in my Vista system. Go figure.

    I have no problem with using D3D8 (on WinXP), other than those renderers causing the launch issue I indicated earlier.

    Any more helpful tips?

    Freddie
     
    Last edited: May 29, 2009
  6. SkaarjMaster

    SkaarjMaster enemy of time

    Joined:
    Sep 1, 2000
    Messages:
    4,725
    Likes Received:
    1
    http://www.cwdohnal.com/utglr/

    I would try reading about it at the comments for 8-29-2005. It must be problem only for XP then. I don't think it's worth running Unreal and UT in D3D8 though. Both games look better in OpenGL and were really coded more towards OpenGL if what I've read here in this forum lately is correct. UT2003 and UT2004 are meant more for D3D though I believe; although, I know it's not as simple as that.
     
  7. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    Thanks SkaarjMaster, I'll look at the settings explanations you referenced. I was attracted to the comments about "gamma" settings. I'll try changing one or more of those settings to see whether that has anything to do with my brightness issues with OpenGL.

    I'm already following a guide for setting Advanced Options that I copied from another post on this and on the Unreal Tournament forums. Those guides suggest leaving the "gamma" settings at zero, which I did. We'll see. One can spend many hours (or even days) messing with these problems. I hate it when that happens.

    Freddie
     
    Last edited: May 30, 2009
  8. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    All,

    I used SkaarjMaster's reference guide to change the Gamma setting in Advanced Options. I used this suggestion from the guide:

    Gamma Offset - [Floating point]
    Offset for gamma correction. Can be used to adjust gamma correction even more if you hit the end of the Brightness slider in Video options. The default value of 0.0 causes no change. Use negative values for darker or positive values for brighter. If adjusting this setting for the first time, I'd recommend starting with small values such as -0.3 or 0.3.

    I can report that changing that setting (I tried several different iterations) only made matters worse.

    I'm back to using D3D8. That works pretty good, except for the screen freeze I get upon initial launch of the game. I can get past that freeze by pressing the Windows key. After that, I'm good to go.

    I really can't tell the difference in image quality between using OpenGL and D3D8. I looks the same to me, but I don't know what to look for.

    Maybe I could eliminate the problems if I upgrade the video card to something better than the ATI 8500. Who knows. I'll live with it for now.

    Freddie
     
    Last edited: May 30, 2009
  9. SkaarjMaster

    SkaarjMaster enemy of time

    Joined:
    Sep 1, 2000
    Messages:
    4,725
    Likes Received:
    1
    I already told you it's not a problem, but a bug with OpenGL. It happens on both ATI and Nvidia cards as it happens on both my system with UT and Unreal installed. I've noticed that sometimes it will happen and sometimes not when I exit the game. Usually it is when I minimize and go into windowed-mode. I'm not really bothered by the bug, because when I'm gaming I will not minimize and devote full attention to the game. If something comes up, I either pause it or completely exit out. It's just not worth it to me to use D3D and miss out on all the cool OpenGL/S3TC/High-end texture stuff.

    I think you might be able to eliminate the problems if you used on older driver with that card, but not completely sure on that; I believe that site explains a little of that.
     
  10. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    SkarjMaster,

    As so often happens in forums, we're having a problem with communications. The fact that you are not bothered by this "gamma" issue, because you deal with it, has no effect on my experience.

    I cannot use OpenGL at all on my WinXP system (using the Radeon 8500), because there is no work around. The in game brightness is so dark I cannot see to play the games (Unreal and Unreal Tournament). I've tried changing all the various settings, one way or the other, and the "dark" screen doesn't change at all.

    When I say that I don't see any difference in performance (image quality) between D3D8 and OpenGL, I'm referring to what I see when playing these games on my other system running Vista. On that computer, I'm running OpenGL. On the computer running WinXP, I can't use OpenGL at all because of the brightness issue. So, it is a problem, regardless of whether it's caused by a bug or something else.

    On my computer using WinXP, D3D8 works pretty good, except for the "freeze" upon launching either game. I work around this by pressing the Windows key. Then D3D8 in-game performance works well after pressing that key.

    I'm not familiar with older drivers for the Radeon 8500 or where to get them. ATI stopped updating drivers for this card some time ago, maybe years, I'm not aware of the date. I'm using the most current driver ATI provides, regardless of age. It's an old card by today's standard, but it should handle these games with no problem.

    I believe you when you say the "gamma" issue is caused by a bug. Regardless, I've been trying to find a work around, but I now see that there is no work around. I have to use D3D8 on my computer that uses WinXP. My Vista system uses OpenGL.

    Freddie
     
    Last edited: May 31, 2009
  11. Freddie

    Freddie Member

    Joined:
    Mar 21, 2008
    Messages:
    185
    Likes Received:
    1
    All,

    While still trying to fix my brightness issue in my WinXP system when using OpenGL, I replaced my AGP 128 MB Radeon 8500 (DX-8 card) with an AGP Radeon 256 MB 9600 XT (DX-9 card). I also installed the latest ATI drivers (Catalyst 9.3).

    That upgrade fixed the brightness issue I had while using OpenGL, but now I experienced some new issues. The new card and drivers produced a game crash and some choppy playback. I didn't spend much time trying to resolve this new problem. I'm tired of messing with this.

    So, I just switched to using DX9 rendering, and that switch seems to work well. Unreal and UT look great with the S3TC textures, and I'm putting this issue to rest.

    BTW, I found the new (unopened in original box) Radeon 9600XT card on ebay for $20 plus shipping, so the upgrade is well worth the effort and price. That's a good upgrade for and older computer, like my machine running WinXP.

    Freddie
     
    Last edited: Jun 12, 2009

Share This Page