1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Another DemoRec problem

Discussion in 'General Discussion' started by PartyAnimal, Jun 14, 2009.

  1. PartyAnimal

    PartyAnimal UT2004 Fanatic

    Joined:
    Feb 9, 2009
    Messages:
    3
    Likes Received:
    0
    I am running DemoRec42 on a dedicated seperate PC. It records all the standard game types fine, but it will not record any of the 3SPN gametypes like TAM, AM, Freon, and such. It will record shots being fired but you can't see any players, and you can't switch between players. Nor can you right click and go into free move mode.

    I have also installed all the correct packages onto my other machine, but I am still at a loss as to why the 3SPN demos will not play.

    Has anyone else experienced this problem? :rolleyes:


    Dang it all, sorry, wrong section!
     
    Last edited: Jun 14, 2009
  2. ProAsm

    ProAsm Active Member

    Joined:
    Mar 20, 2002
    Messages:
    2,106
    Likes Received:
    0
  3. PartyAnimal

    PartyAnimal UT2004 Fanatic

    Joined:
    Feb 9, 2009
    Messages:
    3
    Likes Received:
    0
    Thanks for the help. I went through all the links and did some searching. To no avail, I still have the same problem.

    I took the server down to UT2Vote59 and DemoRecord42, running dedicated 3369 version of ut2004 and I think it is one of these causing the problem.

    I am going to try an older version of demorec first as I really like the 59 version of ut2vote. Anyways, if I find a solution, I will post a reply.

    Thanks for the help,

    Party Animal
     
  4. Wormbo

    Wormbo Administrator Staff Member

    Joined:
    Jun 4, 2001
    Messages:
    5,913
    Likes Received:
    36
    This is not related to any demorecording mod. Add the 3SPN package to the ServerPackages list, UT2004 seems to make quite a distinction between "hard" INI entries and dynamically added entries.

    Demos recorded so far are broken as the relevant information was not stored in the demo files, but once you add the ServerPackages entry, newly recorded demos should work fine.
     
    Last edited: Jul 6, 2009
  5. PartyAnimal

    PartyAnimal UT2004 Fanatic

    Joined:
    Feb 9, 2009
    Messages:
    3
    Likes Received:
    0
    Thanks

    Yep that was the problem. Thanks for all your help, You are the Man.

    Tony
     

Share This Page