1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

Almost finished installing the perfect Inf install

Discussion in 'Troubleshooting' started by jimothy_183, Jul 14, 2008.

  1. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Hello everyone,

    I've been following the Crowze guide to installing the perfect Inf here http://forums.beyondunreal.com/showthread.php?t=170880 and I've just finished installing the Infiltration files at step 6. I'm using the normal Unreal tournament and I downloaded the Infiltration 2.9 Community Edition full (1219MB).

    However when I tested to see if my game works (I had to use the no quick menu because the normal one doesn't work) and I seem to be able to play the game normally except I don't get any sounds in the game. No music no gun firing sounds and I can't hear what the characters are saying (such as "weapons dry").

    Also I have other questions:

    1. I have Unreal Tournament normal edition (its got a blue cover instead of the red) and My second CD says "extras", is this the CD with the Hi Res Textures which is talked about in step 3 of the perfect installation guide?

    2. If I have the Inf CE full, do I need the official bonus pack mentioned in step 7?

    3. In step 9 should I download the packs? Because seeing how I have the CE full I would assume it comes with everything.

    Thank you in advance for answering my questions.

    Regards,

    jimothy_183
     
  2. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    I've done some further testing and I've noticed that my textures don't seem to look as good as some of the pictures on the internet. This probably has to do with the fact that I haven't finished all the steps in the perfect installation guide but I might as well show you guys what I mean.

    Here is the pic of an EOTech sight from http://dslyecxi.com/images/bestoftactical/infiltration/inf_combat_optics.jpg
    [​IMG]

    And here is a pic of mine:
    [​IMG]



    Is this to do with the fact I haven't finished the installation process or is it to do with something else?
     
  3. Crowze

    Crowze Bird Brain

    Joined:
    Feb 6, 2002
    Messages:
    3,556
    Likes Received:
    1
    A number of people have had problems with the OpenAL sound system - try using either the FMOD or original sound system as described in the troubleshooting sticky thread.

    Yep that's the one.

    No - the guide was written before the CE came out, the bonus pack is included already. I guess I should update the guide :).

    Again, most of the stuff is included, with the exception of some of the older maps and a few new mutators.

    Something else by the looks of it. Check that it's actually using the OpenGL renderer and not software, and that the texture detail is set to 'High'.
     
  4. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Thanks for the help Crowze but I'm still a little confused about what I should do with the sound. I mean are you talking about step 8 in the perfect installation thread?

    Secondly with the new mutators that aren't included in the CE full version, is there a list of mutators that I will need somewhere? I know there is a place with a list of all mutators but I don't know which ones I need and which ones I don't.

    And lastly with the graphics I've got my textures on high but I'm not using either software or OpenGL, I'm using Direct3D. Should I change that?
     
  5. Carpetsmoker

    Carpetsmoker Nexus-6

    Joined:
    Jan 20, 2008
    Messages:
    227
    Likes Received:
    0
    You can just download most mutators from the servers...
     
  6. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    I'm sorry but I can't seem to get my head around step 8. Perhaps you could give me a more detailed set of instructions on completing this step? Sorry for being such a noob but I seem to suck at these things.
     
  7. Crowze

    Crowze Bird Brain

    Joined:
    Feb 6, 2002
    Messages:
    3,556
    Likes Received:
    1
    Sorry, thought the fix was in the common problems thread. To change to the audio device, the easiest way is to type 'preferences' in the console and find the audio device setting in the drivers section. You can also change it manually in Infiltration.ini, but as I can't remember the exact strings to use you'd have to look it up - search for 'fmod' in this forum.

    Definitely change it to OpenGL.

    Step 8 isn't required as it's already included in the CE.
     
  8. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Cool, thanks for all that Crowze. :)

    My Inf is mostly working now except for the slight problem where now when I zoom in on the ironsights the model of the weapon goes weird as in part of the weapon turns transparent. Not a big problem but would be nice to fix.;)
     
  9. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Now that I've gotten the basics right (Besides that thing with the zoomed sights) I've run into some more problems after trying to get online.

    1. I have many mutators on my mutators list. Most are not being used at the moment. I'm having trouble figuring out which ones I need active and which ones I don't because there a lot of mutators that I don't need. An example would be that I have the rolling M67 mutator in my list and is not active yet the M67 in the game still rolls after being thrown and on the other hand there's the fact that I need the Aimedview mutator to zoom in on my sights.

    2. I seem to get the version mismatch error when I try to join servers, I seem to be able to download most of the stuff the server is hosting but there are some things I can't seem to download. I get these errors:
    Package 'UTCompass' version mismatch
    Downloading 'Vortex2' not allowed
    Package 'INFwm_C7' version mismatch

    Again I would really appreciate it if someone could help me fix these problems. :)
     
  10. Snakeye

    Snakeye Mk82HD

    Joined:
    Jan 28, 2000
    Messages:
    1,966
    Likes Received:
    0
    Concerning the mutators you need, well that depends on your personal preference - if you go online the mutators used will be determined by the server anyway. Also note that some mutators are incompatible to others - e.g. I think Rolling M67 or DukeNades or so is incompatible to the weapon pack. For offline use or if you host a server chose the mutators you like - experiment a bit with the different mutators to see what they do and if you like it.

    Concerning version mismatches, that stuff happens when mutators get updated (C7 changed to 1.3 after the CE came out IIRC). Two possible sollutions: Get the newest version - or delete the *.u File that causes the version mismatch and let it download from the server. It ends up in the cache and if rumors I heard are correct you can even have two different versions of the same file in the cache - which is useful for the UTCompass since it seems to be usd in different versions on some servers. Don't forget to change the time after which files are removed from your cache though - otherwise you end up downloading them again and again - sadly I don't remember the Ini variable that sets the time and I can't look it up (I'm at work :().

    As for Vortex2 not allowed - IIRC this is an official Unreal map and as such I doubt it would be legeal to let it be downloaded. Guess you'll have to get and install Unreal and Return to NaPali to play on thi specific server (COOP1 I assume..).
     
    Last edited: Jul 17, 2008
  11. Crowze

    Crowze Bird Brain

    Joined:
    Feb 6, 2002
    Messages:
    3,556
    Likes Received:
    1
    Could you take a screenshot of the zoomed sights and post it here?
    The CE has a whole load of mutators it uses by default, using the MultiMut mutator to load them all - see UT\System\MultiMut.ini to see which ones, and don't put them in the main server list. In hindsight I should have removed the .int files so they didn't show up individually.
    What snakeye said. Be aware that the CE puts most of the community mutators in UT\Infiltration\Community\System, so you'll have to look in there (or just do a search).
     
  12. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Thanks heaps Snakeye and Crowze now I can join half the servers.:)

    However I'm still experiencing some problems with COOP #2 as there is a mismatch with 'INF_Core' yet even when I rename the *.u file INF can't run. Then there's another server where there is another mismatch with the UTcompass file except I've already renamed the original UTcompass file. This is probably because of the fact that (as Snakeye has already pointed out) there are many different versions of the file running on different servers.

    Also a new problem has emerged where the sometimes when I run the game the colours go all weird. What I mean is that sometimes the game will run "brighter", I'm not sure you guys will get what I mean but I'll get some screenies when it happens again.

    Also I'll get some screenies of the sight zoom in a sec.
     
  13. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Ok here are some screenies.

    As you can see when I zoom in the weapon model kinda goes all weird.

    Also if you compare these screenies with the one I took of the MP5 you will see that the brightness between the two is different and I wanted to know how you can fix that problem.
     

    Attached Files:

  14. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    last screenie.
     

    Attached Files:

  15. Snakeye

    Snakeye Mk82HD

    Joined:
    Jan 28, 2000
    Messages:
    1,966
    Likes Received:
    0
    Woah, okay perhaps you shouldn't delete any file that causes a mismatch - INF_Core is among the more important ones, though I suppose downloading it doesn't really hurt :)

    Anyway COOP1 and COOP2 are currently different to ALL other servers because they run Psychomorphs PsyTex Modification (it's too big to be called Mutator IMO). This modification replaces ALL weapon textures plus a few others - and that needed significant changes in some of the core files of Inf. To be able to connect to any of the two COOPs you'll need to download and install the PsyTex Mod and run it instead of standard Inf. Exact information on this Mod as well as COOP servers in general should be looked up here: Inf COOP Forums

    As for the zooming troubles - this is most probably caused by rendering problems. The weapon models (well part of them) are not drawn when they come too close to the players view. I can understand to a certain extend why this happens in the Hk416 (as it is no official Inf weapon) but it seems a tad odd the 1911 does that too. Does anything like this also happen with standard Inf weapons? Anyway, before you get too attached to the aim zoom I might add that no server I know actually runs it - so it might be better to get used playing Inf without it - after all zooming without optical device is not realistic (though my opinion on this specific point was different when I started to play..)

    As for brightness - no real idea. What system are you on (i.e. Processor, GFX Card, RAM, Operating System aso.)?
     
  16. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Thanks I'll try using that COOP link you gave me.:)

    As for the zoom, it seems that all the weapons do this which certainly is weird. But as you say it doesn't matter too much as none of the servers run it but it would be nice if I could fix it.;)

    As for my system specs, here they are:

    Processor: Intel(R) Pentium(R) 4 CPU 2.66GHz
    Memory: 1024MB RAM
    Hard Drive: 80 GB Total
    Video Card: RADEON X800 Series
    Monitor: Plug and Play Monitor
    Sound Card: Logitech USB Headset
    Speakers/Headphones: Headphones
    Keyboard: Microsoft PS/2 Port Mouse (IntelliPoint)
    Mouse: Microsoft PS/2 Port Mouse (IntelliPoint)
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_qfe.070719-1309)
     
  17. Snakeye

    Snakeye Mk82HD

    Joined:
    Jan 28, 2000
    Messages:
    1,966
    Likes Received:
    0
    A thought occurs. Since you didn't use OpenGL before, did you get the custom OpenGL driver from the page Crowze linked to in his guide (http://cwdohnal.home.mindspring.com/utglr/)?

    Not sure they if they solve the clipping problem, but they definetly improved overall look for me. If 3.4 doesn't work fine for you, you can try older versions (at the bottom of the page) plus it has a link where some (all?) OpenGL ini/preferences settings explained.
     
  18. jimothy_183

    jimothy_183 New Member

    Joined:
    Jul 14, 2008
    Messages:
    12
    Likes Received:
    0
    Sorry if this seems out of place but my account at the COOP forums hasen't been activated by an admin yet.;)

    Anyways I'm having problems installing the PsyTex mod where when I use the .bat file to install the mod by typing in the directory stated in the installation guide here http://infiltration.forum.cerberon.net/viewtopic.php?t=32 I can't seem to see the folder after it finishes installing. This probably has to do with some error in the installation. You will see this in the screen shot below.
     

    Attached Files:

  19. Snakeye

    Snakeye Mk82HD

    Joined:
    Jan 28, 2000
    Messages:
    1,966
    Likes Received:
    0
    Had the same problem on Vista - there's an explanation of how to set it up manually in the thread in the COOP forums; it's basically a bit of copy and paste. Funny enough I had no probs on XP - did you have admin rights? And if yes you might try to set the install path into "s -> "program files/unrealtournament" IIRC command windows take exception to spaces used in paths - but that's more of a wild guess..
     
  20. Carpetsmoker

    Carpetsmoker Nexus-6

    Joined:
    Jan 20, 2008
    Messages:
    227
    Likes Received:
    0
    fork() does not work on Vista, if you want it fixed then contact Microsoft and send them copy of IEEE Std 1003.1 and the three zillion recorded promises of Steve Balmer to provide better interoperability.

    Manual installation intructions:

    o Copy The directory PsyTex to your UT installation, I will assume it's C:\UnrealTournament\

    o Copy all the .u files from the UT and INF system directory (First INF, then UT) to C:\UnrealTournament\PsyTex\System, Don't overwrite any existing .u files.
    If those files aren't present UT crashes (Yeah, I know) ... I guess you could also use symbolic links on Vista, but you'll have to find out how...

    o Copy all .utx files from C:\UnrealTournament\Infiltration\Textures\Camos\ to C:\UnrealTournament\PsyTex\Infiltration\Textures\Camos\
    Again, don't overwrite files.

    That's it.

    psytex.sh won't work either, so you'll have to do that manually to:

    o Copy Infiltration.ini to Infiltration_psytex.ini

    o Edit Infiltration_psytex.ini.

    Find the line:
    Paths=../Infiltration/System
    And replace it with:
    Paths=../PsyTex/System

    Find the line:
    Paths=../Infiltration/Textures/Camos
    Reaplace it with:
    Paths=../PsyTex/Textures/Camos

    Note: Order matters with Path=, so keep it intact.

    Now create a new shortcut, where -INI=Infiltration_psytex.ini

    And you're fertig!
     
    Last edited: Jul 18, 2008

Share This Page