1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Two Factor Authentication is now available on BeyondUnreal Forums. To configure it, visit your Profile and look for the "Two Step Verification" option on the left side. We can send codes via email (may be slower) or you can set up any TOTP Authenticator app on your phone (Authy, Google Authenticator, etc) to deliver codes. It is highly recommended that you configure this to keep your account safe.

AimView corrupts textures

Discussion in 'Troubleshooting' started by vitamin, Jul 11, 2013.

  1. vitamin

    vitamin Member

    Joined:
    Jul 8, 2013
    Messages:
    36
    Likes Received:
    0
    After adding 'AimView' to my mutators list I cannot zoom in because textures go missing. Please see sceenshots below:

    [​IMG]
    [​IMG]

    My vga is Radeon x1650 Pro (512MB) and here's my INF config:

    Code:
    [D3D9Drv.D3D9RenderDevice]
    ZRangeHack=True
    NumAASamples=2
    UseAA=True
    RequestHighResolutionZ=True
    UseSoftwareVertexProcessing=False
    UsePureDevice=True
    UseTripleBuffering=True
    MaskedTextureHack=True
    FrameRateLimit=0
    SwapInterval=0
    UseVertexProgram=False
    TexDXT1ToDXT3=False
    DynamicTexIdRecycleLevel=100
    CacheStaticMaps=True
    UseTexPool=True
    UseTexIdPool=True
    UseSSE=True
    BufferTileQuads=True
    BufferClippedActorTris=True
    SinglePassDetail=False
    SinglePassFog=False
    ColorizeDetailTextures=False
    DetailClipping=False
    UseDetailAlpha=True
    DetailMax=2
    RefreshRate=60
    MaxTMUnits=0
    NoFiltering=False
    MaxAnisotropy=2
    Use16BitTextures=False
    UseS3TC=True
    UseAlphaPalette=True
    UseTrilinear=True
    UsePrecache=False
    UsePalette=True
    UseMultiTexture=True
    MaxLogTextureSize=8
    MinLogTextureSize=0
    MaxLogVOverU=8
    MaxLogUOverV=8
    OneXBlending=True
    GammaCorrectScreenshots=True
    GammaOffsetBlue=0.000000
    GammaOffsetGreen=0.000000
    GammaOffsetRed=0.000000
    GammaOffset=0.000000
    LODBias=0.100000
    DetailTextures=True
    DescFlags=0
    Description=
    HighDetailActors=True
    Coronas=True
    ShinySurfaces=True
    VolumetricLighting=True
    
    Does anyone know what might cause this strange graphics issue?
     
  2. Ocsi88

    Ocsi88 Member

    Joined:
    Jul 20, 2009
    Messages:
    41
    Likes Received:
    0
    Maybe disabling the ZRangeHack helps, but it can cause other similar graphical bugs.
    Usually i have to enable it to prevent this kind of problem... and make problem with the previews in loadout and character screens.
     
    Last edited by a moderator: Jul 13, 2013
  3. vitamin

    vitamin Member

    Joined:
    Jul 8, 2013
    Messages:
    36
    Likes Received:
    0
    You were right, it was ZRangeHack indeed. Setting it to 'false' did the trick for me. And more over, I got M93R preview working now too:) Also other guns have much better previews - without some glitches I had before.

    Thank you very much for help.
     
  4. I-C-A-R-U-S

    I-C-A-R-U-S New Member

    Joined:
    Jul 11, 2013
    Messages:
    22
    Likes Received:
    0
    What kind of renderer do you use? And what is your Operating System?
     
  5. The Great Sephiroth

    The Great Sephiroth New Member

    Joined:
    May 18, 2004
    Messages:
    32
    Likes Received:
    0
    The ZRangeHack normally helps, but with aimview it makes parts of many guns go invisible when zooming in. Always try toggling it if you get this bug. This bug has affected the stock D3D and Glide renderers, the newest GL renderer, and the D3D8/D3D9 renderers. I have not tested it with software.
     
  6. vitamin

    vitamin Member

    Joined:
    Jul 8, 2013
    Messages:
    36
    Likes Received:
    0
    @ICARUS - I'm using D3D9 and Windows XP.

    @Saphiroth - It looks like that in my case disabling it makes things only better. I tried about 10 different maps and guns and don't see any problems with textures now. And I have M93R preview working too:)
     

Share This Page