News UnrealEd Files Mods FragBU Liandri Archives
BeyondUnreal Forums

Go Back   BeyondUnreal Forums > BeyondUnreal > Games > Unreal Tournament Series > Original Unreal Tournament

Reply
 
Thread Tools Display Modes
Old 27th Dec 2008, 02:02 AM   #1
Kantham
Fool.
 
Kantham's Avatar
 
Join Date: Sep. 17th, 2004
Posts: 18,041
UT (GOTY) and framerates Speed up.

It's ridiculous. I'm sure this has been posted before so don't mind me for bringing this here again... The problem is, that if I run the game on OpenGL, the game will go insanely fast and everything is unplayable. If I run the game in Direct3D, the game seems alright at first glance, then when I look at a corner the game constantly speed up.

I tried to run the game in Software rendering, and it worked. Except it looks like ass and well... I'm not a fan of CPU rending right?
__________________
Kantham is offline   Reply With Quote
Old 27th Dec 2008, 04:05 AM   #2
Firefly
United Kingdom is not a country.
 
Firefly's Avatar
 
Join Date: Feb. 20th, 2000
Location: Bucks, England - Nowhere near Europe
Posts: 4,846
Assuming you mean UT99
First download these OpenGL Drivers.
Then create a shortcut to the UT exe and select 98/me compatibility mode.

if it still runs erratically then add -CPUSPEED=xxxx to the end of the target field.
xxxx is the speed of your cpu. If you have a dualcore then the speed of just one of them.
Firefly is offline   Reply With Quote
Old 27th Dec 2008, 04:33 AM   #3
Crowze
Bird Brain
 
Join Date: Feb. 6th, 2002
Location: Cambridgeshire, UK
Posts: 3,554
Isn't it time we got a sticky thread describing this problem and the solutions? I'll have a go right here...

Problem: Unreal, UT and old Unreal-engine games run 'erratically' - the game speeds up and slows down at random, seemingly independent of the framerate.

Cause: This is caused by the way the Unreal engine calculates time, which is a little archaic has a number of issues with modern hardware - primarily because it is based on the CPUs clock speed, which on modern CPUs is automatically varied to save power, but it also has issues when the framerate is particularly high.

Quick Fix: Sorry, you're out of luck - this can be caused by a range of issues, so go through the solution step-by-step and see which ones actually fix the problem.

Solutions: Try the following in order - generally the first few tend to fix the problem for most people, and the latter are more extreme measures for problematic systems (dual-core laptops running Vista are particularly awkward).
  • If you have an AMD multi-core processor, install the AMD Dual-Core Optimizer (5th down). This is needed because of a bug with some AMD processors which means that the timers on the CPU cores aren't synchronised with each other.
  • UT has a built-in flag you can use to tell it the CPUs clock speed if it doesn't detect the speed correctly (it shows the detected speed in UT.log). Create a shortcut to UnrealTournament.exe and add ' -cpuspeed=X' to the end - without the quotes, and replacing X with you CPUs clock speed in Mhz.
  • As stated above, UT has issues with very high framerates (200+), you need to put a limit on it. The best way to do this is to install one of Chris Dohnal's updated renderers (OpenGL, D3D8 or D3D9) - this is worth doing anyway. Try OpenGL first, and if you have issues use D3D9 or 8.
    • Copy the .dll (and .int if present) to UT\System
    • Run the game in safe mode (create a shortcut to UnrealTournament.exe and add ' -safe' to the end)
    • When it asks to select a render device, click on 'show all' at the bottom and select the appropriate device
    • After the game starts up, open the console (normally the ~ key if I remember correctly), go to Render Devices > OpenGL (or D3Dx as appropriate), find the FrameRateLimit entry and set the value to 200.
    • While you're there, find the SwapInterval entry and set it to 0 - see the section on VSync for an explanation.
    Alternatively you can edit your UnrealTournament.ini directly to make these changes but you're on your own doing this, unless I update this guide that is.
  • The next step is to disable the CPU's power saving features before running UT. There are a number of ways to go about this depending on which operating system you use, so I'll list the easiest first.
    • On Windows XP, go to Control Panel > Power Options, and in the Power Schemes tab select 'Always On'. This can be done automatically in a batch file, as explained by Blitzschlag on the Infiltration forums.
    • In Windows Vista, go to Control Panel > Power Options and select the 'High Performance' profile.
    • In a modern Linux distro e.g. Ubuntu, the easiest thing to do is to use the EMIFreq applet - simply select either 'Performance' or a fixed speed.
    Failing this there are three ways to go about this, none perfect but all fairly fool-proof.
    • The first, and in my opinion the easiest, is to run a CPU-hungry process in the background. Prime95 is a good one to use as it defaults to running in the background, so won't interfere with UT at all.
      • Download Prime95 from the link above and extract it to any location
      • Run the application, and if nothing happens go to Options > Torture Test
      • Select 'Small FFTs' as it uses the least amount of memory
      • To start off, tell it to run only one thread - no need to waste any more power than is needed
      • Click OK and leave it to it
    • The second is to use a 3rd-party utility to manually set the CPU speed. These tend to vary in effectiveness though - I use RMClock on Windows XP but don't know if it supports Vista yet. Feel free to suggest any others.
    • The third is a little more involved, but if you aren't worried about power-saving you'll only have to do it once. Disabling power saving in the BIOS is a fairly fail-safe method, but the exact option to look for can vary depending on the CPU and BIOS type. Either way, you'll usually find the settings in something like Advanced Options or CPU Features. For AMD processors, look for Cool & Quiet and disable it. For Intel CPUs look for something like EIST Function, Thermal Control and C1E Function.
  • VSync (or Vertical Synchronisation) is a bit of a contentious issue - some people claim that enabling it solves the problem, while in my experience it can hinder things - try it both ways (0=off, 1=on). In a nutshell, it forces the video card to synchronise the swapping of buffers (i.e. outputting the picture) with each refresh of the monitor, in order to prevent 'tearing' effects where the monitor displays the upper part of one frame and the lower part of the next. On most modern flat panel monitors this is 60Hz, giving at most 60 updates per second, and in my experience a 60fps limit doesn't put enough load on a modern CPU to make it run at full clock speed all the time, meaning power saving will cut in and mess up the game speed.

Something I've missed, want anything clarified, have any suggestions, still can't get it working? Post here or PM me.
__________________

Infiltration | Sentry Studios

Last edited by Crowze; 27th Dec 2008 at 05:45 AM.
Crowze is offline   Reply With Quote
Old 27th Dec 2008, 08:51 AM   #4
NeoNite
La douce souffrance...
 
NeoNite's Avatar
 
Join Date: Dec. 10th, 2000
Posts: 18,753
Good idea, Crowze. I'm making this a sticky. (Made a slight adjustment to the thread title ;-)..)
__________________

I find myself intrigued by your subvocal oscillations,
A singular development of cat communications
That obviates your basic hedonistic predilection
For a rhythmic stroking of your fur to demonstrate affection.
-Ode to Spot, by Data
NeoNite is offline   Reply With Quote
Old 27th Dec 2008, 03:01 PM   #5
Kantham
Fool.
 
Kantham's Avatar
 
Join Date: Sep. 17th, 2004
Posts: 18,041
Hey Crowze thanks for the detailed post. But I still always have the same issue with the " -safe" / " -cpuspeed=x" in the shortcut. It just doesn't start in safe mode for example. I tried "unrealtournament.exe -safe" and the game doesn't start up in safe mode, I also tried to add it in the shortcut's target but it refused to save it as that, and also tried with and without space before the '-'. Also, the console command you speak of is unrecognized. So 'possibility' 2 and 3 didn't work. I'm sure it's doable.
__________________
Kantham is offline   Reply With Quote
Old 27th Dec 2008, 06:47 PM   #6
Zur
surrealistic mad cow
 
Zur's Avatar
 
Join Date: Jul. 8th, 2002
Posts: 11,690
If the shorcut doesn't work, try writing the command in a txt file and then renaming it to a .bat.
__________________

Zur is offline   Reply With Quote
Old 28th Dec 2008, 09:25 AM   #7
Defeat
GET EM WITH THE BACKSMACK WOOOOO
 
Defeat's Avatar
 
Join Date: Apr. 2nd, 2005
Location: Illinois
Posts: 2,933
The only way that works 100% of the time is the D3D9 renderer + FrameRateLimit.
__________________
"Timing power ups has been around since Halo 1"
-Tom Taylor aka T-squared aka a professional Halo player

Q3A kill message: HAY YOU JUST KILLED SOMEONE, HAVE FUN BEING KILLED NOW SINCE THIS MESSAGE IS HUGE

DRW-Nemesis|away> just wait for it 2 more months, and even x6 wouldn't able to beat the best TAM teams
Defeat is offline   Reply With Quote
Old 28th Dec 2008, 10:10 AM   #8
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,449
Quote:
Originally Posted by Defeat View Post
The only way that works 100% of the time is the D3D9 renderer + FrameRateLimit.
That's mostly true. One interesting thing I noticed with framerate limit is that when value is 200 (FrameRateLimit=200) then UT still goes slightly over 200 frames per second (about 220) and choppyness may happen, but it stays about 195 fps (which is perfect) when my FrameRateLimit is set to 160 in UnrealTournament.ini. Note that I was talking about Direct3D9 renderer.
Also as suggested by Crowze, disabling Speedstep/EIST/C1E/Cool'n'Quitet (depending on CPU) options in BIOS will cure most problems.
Another thing I recommand you to do is to configure your UT as described here (should be more up-to-date guide). I personally had almost zero issues with these settings on wide range of hardware (from P3's to Quad Extremes).

Good luck.
__________________

For those willing to build a mountain of bodies
and climb to the top.
In environments that stun.
Against A.I. that kills.
For those willing to stake their lives
in the pursuit of victory...
we salute you.
Raynor.Z is offline   Reply With Quote
Old 5th Mar 2009, 12:52 AM   #9
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,449
You can get updated Unreal's OpenGL renderer from OldUnreal's patch.
Why would you want to use vsync anyway, game works better with this option turned off.
Raynor.Z is offline   Reply With Quote
Old 5th Mar 2009, 02:20 AM   #10
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,449
Guess I'm lucky, because I never experienced tearing with my LCD with vsync turned off.
Raynor.Z is offline   Reply With Quote
Old 8th Mar 2009, 07:00 PM   #11
Reclaimer
UT oldtimer
 
Join Date: Mar. 29th, 2005
Location: USA
Posts: 12
I just pretty much gave up with my newer vista laptop. No matter what fix I try, UT still doesnt run the way it is supposed to.
__________________
Reclaimer is offline   Reply With Quote
Old 5th Apr 2009, 01:01 AM   #12
Wulf38
>:F
 
Join Date: Feb. 6th, 2008
Location: Canada
Posts: 16
On my Athlon X2 it only runs perfectly if I both use OpenGL with FrameRateLimit=60, and set the game's CPU affinity to only one CPU.
Wulf38 is offline   Reply With Quote
Old 5th Apr 2009, 03:44 AM   #13
medor
Registered User
 
Join Date: Mar. 15th, 2009
Posts: 355
You can still mount. Around 200 the game starts to be too fast and choppy on servers.
medor is offline   Reply With Quote
Old 26th Apr 2009, 10:33 PM   #14
SkaarjMaster
enemy of time
 
SkaarjMaster's Avatar
 
Join Date: Sep. 1st, 2000
Location: Tampa, FL
Posts: 4,700
Question

Anyone confirm a good FrameRateLimit setting for UT running OpenGL? I was going to try 180 and run with it.

Also, the utglr web site has an access limit and I can't get to it right now. Is the latest UT OpenGL renderer 3.4? Will this work with Unreal or should I use the oldUnreal one with the OMP file instead? Is the one in the OMP file 3.4 (it's an exe and it gave today's date to the file so I can't compare to the one on my other computer)?
__________________

Insite Reviews: right here in the web archive

Last edited by SkaarjMaster; 26th Apr 2009 at 11:45 PM.
SkaarjMaster is offline   Reply With Quote
Old 27th Apr 2009, 10:18 AM   #15
GreatEmerald
Khnumhotep
 
GreatEmerald's Avatar
 
Join Date: Jan. 20th, 2008
Location: Lithuania
Posts: 4,042
200 is fine for game speed itself, but textures animate wrongly and you don't see water colour under water. 100 works fine. So I guess you can trial and error from 200 to 100 and see what's optimal for you.

OMP is outdated, Dohnal's site has newer renderer. But OMP also has audio, so install OMP first, and then Dohnal's renderer.
GreatEmerald is offline   Reply With Quote
Old 27th Apr 2009, 10:40 AM   #16
SkaarjMaster
enemy of time
 
SkaarjMaster's Avatar
 
Join Date: Sep. 1st, 2000
Location: Tampa, FL
Posts: 4,700
Version 3.4 (OpenGLDrv.dll) has a date of March 10, 2007. Is there a newer one than this one?

Funny thing about the audio, I think UT sounds better in 5.1 surround sound without OpenAL. I know UT2003, UT2004 and UT3 all have OpenAL and UT does not (in my installations anyway on my older computer) and the surround sound just sounds so much better in UT. Of course, this is getting a little off topic but it's just something I noticed.
__________________

Insite Reviews: right here in the web archive
SkaarjMaster is offline   Reply With Quote
Old 6th May 2009, 10:43 AM   #17
SkaarjMaster
enemy of time
 
SkaarjMaster's Avatar
 
Join Date: Sep. 1st, 2000
Location: Tampa, FL
Posts: 4,700
Smile

I chickened out......I set the FrameRateLimit to 160 instead of 180 and everything seems to work so far.
__________________

Insite Reviews: right here in the web archive
SkaarjMaster is offline   Reply With Quote
Old 15th May 2009, 06:51 PM   #18
SDX
Registered User
 
SDX's Avatar
 
Join Date: Mar. 2nd, 2009
Posts: 6
the ultimate FIX

hey, there is actually complete fix for this problem:
coding.hanfling.de/launch
the forum thread with additional details:
http://www.dxediting.com/forums/showpost...

The fixed .exe file works with all versions and is not dependent on processor frequency, therefore killing the issue.
processor fixes are available also for Deus Ex, Rune, Unreal 1 and Nerf.

Last edited by SDX; 15th May 2009 at 06:57 PM.
SDX is offline   Reply With Quote
Old 16th May 2009, 11:46 PM   #19
xvlin
Registered User
 
Join Date: Feb. 11th, 2009
Posts: 59
Thanks for that link, it works. I have a question though, my fps is stuck at 63 I can average atleast 150, I turned vsync off and tried everything still stuck at it.
xvlin is offline   Reply With Quote
Old 17th May 2009, 04:29 AM   #20
medor
Registered User
 
Join Date: Mar. 15th, 2009
Posts: 355
Quote:
Originally Posted by xvlin View Post
Thanks for that link, it works. I have a question though, my fps is stuck at 63 I can average atleast 150, I turned vsync off and tried everything still stuck at it.
you are on opengl or d3d ...?

Show us your setup rederer
May be opengl;you must show [OpenGLDrv.OpenGLRenderDevice]
__________________



Files for UT99 utfiles All new releases and updates are listed here All news
Most popular is UnrealTournament-V3 With over 8800 visits to date.It is an optimized UT99 to download.
medor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Copyright ©1998 - 2012, BeyondUnreal, Inc.
Privacy Policy | Terms of Use
Bandwidth provided by AtomicGamer