News UnrealEd Files Mods FragBU Liandri Archives
BeyondUnreal Forums

Go Back   BeyondUnreal Forums > BeyondUnreal > Games > Unreal Tournament Series > Original Unreal Tournament

Reply
 
Thread Tools Display Modes
Old 9th Mar 2008, 02:33 PM   #1
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
UT Runs Too Fast

Before you shout at me yes I did use the search option, unfortunately the search option is about as much use as a chocolate teapot.

The problem is intermittent; If I close it and quickly click on the icon again before the music stops it runs at normal speed, but then the sound is bad.

I vaguely remember how to fix this but I thought I had better ask before I mess with things.

AMD Sempron Processor 3000+, MMX, 3DNow, ~1.8GHz
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 9th Mar 2008, 02:57 PM   #2
brdempsey69
Original UT Owns !!
 
brdempsey69's Avatar
 
Join Date: Jun. 19th, 2003
Posts: 361
Somebody here will be more than happy to help you out if you could give us some more details about your setup. Such as what OS you're using. Do you have a desktop or laptop ( it looks like a laptop with that processor you listed )? What type of graphics chip does your system have?
brdempsey69 is offline   Reply With Quote
Old 9th Mar 2008, 05:12 PM   #3
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
Windows XP Home
Desktop
ATI Radeon Xpress 200 (Integrated with Motherboard)

My computer is "old" apparently, about 4 or 5 years old... Doesn't sound very old to me... I blame consoles...
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 9th Mar 2008, 05:20 PM   #4
T2A`
I'm dead.
 
Join Date: Jan. 10th, 2004
Location: Richmond, VA
Posts: 8,769
http://cwdohnal.home.mindspring.com/utglr/

Use that and limit the framerate to 200. Anything beyond 200 causes UT to run extra fast.
T2A` is offline   Reply With Quote
Old 9th Mar 2008, 07:07 PM   #5
brdempsey69
Original UT Owns !!
 
brdempsey69's Avatar
 
Join Date: Jun. 19th, 2003
Posts: 361
And if the OpenGL driver doesn't work, scroll down that page that T2A provided the link for and try out the Direct3D9 driver.

It works great as well.
brdempsey69 is offline   Reply With Quote
Old 9th Mar 2008, 07:14 PM   #6
NeoNite
La douce souffrance...
 
NeoNite's Avatar
 
Join Date: Dec. 10th, 2000
Posts: 18,694
Isn't the D3D8/9 driver supposed to be better for ATI graphics card. Sure works better for mine (x1950)
__________________
NeoNite is offline   Reply With Quote
Old 9th Mar 2008, 07:40 PM   #7
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
Tried the Open GL driver and the D3D8 driver to no avail
How do you limit the framerate, is that in the INI file?
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 10th Mar 2008, 12:54 AM   #8
brdempsey69
Original UT Owns !!
 
brdempsey69's Avatar
 
Join Date: Jun. 19th, 2003
Posts: 361
Did you try the Direct3D9 driver yet? It is somewhat different from the Direct3D8 driver.
brdempsey69 is offline   Reply With Quote
Old 10th Mar 2008, 01:02 AM   #9
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
Oops. I knew I had done something wrong!
...
It almost works, but then the game accellerates to double speed... looks great though
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 10th Mar 2008, 04:21 AM   #10
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,441
Quote:
Originally Posted by Fokker View Post
Tried the Open GL driver and the D3D8 driver to no avail
How do you limit the framerate, is that in the INI file?
Look your UnrealTournament.ini in System folder, there should be FrameRateLimit=200 (I have mine set to 150)
__________________

For those willing to build a mountain of bodies
and climb to the top.
In environments that stun.
Against A.I. that kills.
For those willing to stake their lives
in the pursuit of victory...
we salute you.
Raynor.Z is offline   Reply With Quote
Old 10th Mar 2008, 04:25 AM   #11
haslo
Moar Pie!
 
haslo's Avatar
 
Join Date: Jan. 21st, 2008
Location: Bern CH
Posts: 363
Quote:
Originally Posted by Fokker View Post
chocolate teapot
Mmmmh, chocolate teapot!
haslo is offline   Reply With Quote
Old 10th Mar 2008, 07:15 AM   #12
Chew-This
Registered User
 
Chew-This's Avatar
 
Join Date: Jan. 23rd, 2008
Posts: 42
Are you playing UT on a laptop?
From my understanding and don't quote me on this, but the speed of your laptops
dual core processor runs a little to fast for UT.
Try this:
Go to your startup screen then right click your mouse and then click Properties. Now click Screen Saver.
Go to Monitor Power and click Power. Now change your Power scheme to always on.
Click Apply and you're there.....I think...I hope
Chew-This is offline   Reply With Quote
Old 10th Mar 2008, 03:23 PM   #13
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
Quote:
Originally Posted by Raynor.Z View Post
Look your UnrealTournament.ini in System folder, there should be FrameRateLimit=200 (I have mine set to 150)
I dont see .ini files. I see config and int files, but in the ones called UnrealTournament I can't find a line that says "FrameRateLimit"... do I add it?
________________

No it's not a Laptop...
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 10th Mar 2008, 03:41 PM   #14
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,441
There's gotta be files with INI extensions in your UT\System folder. Try to open it directly from Notepad and if you don't have this section then add it manually.
__________________

For those willing to build a mountain of bodies
and climb to the top.
In environments that stun.
Against A.I. that kills.
For those willing to stake their lives
in the pursuit of victory...
we salute you.
Raynor.Z is offline   Reply With Quote
Old 10th Mar 2008, 04:11 PM   #15
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
I can assure you that there is nothing in my UT system folder with an INI extension. I have: DLLs, Configs, INTs, Us, Batches and Internet Shortcuts.
Oh, and three text documents.
....
Ah! My computer doesn't show the INI thingy when I click the Details view, it just says Configuraton File... Sorry, my bad.

Where exactly in the *ahem* .ini do I add the line?
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Old 10th Mar 2008, 04:24 PM   #16
$hagratH
Registered User
 
Join Date: Jan. 24th, 2008
Posts: 121
Quote:
Originally Posted by Fokker View Post
Oops. I knew I had done something wrong!
...
It almost works, but then the game accellerates to double speed... looks great though

do u try to play UT99 GOTY edition??
or UT99??
if u trying GOTY,,,it might be the problem,,its known for sum bugs
try to play the original UT version
cheerz and good luck m8

Last edited by $hagratH; 10th Mar 2008 at 11:42 PM.
$hagratH is offline   Reply With Quote
Old 10th Mar 2008, 05:10 PM   #17
Raynor.Z
Ad Nocendum Potentes Sumus
 
Raynor.Z's Avatar
 
Join Date: Feb. 1st, 2006
Posts: 1,441
Quote:
Originally Posted by Fokker View Post
I can assure you that there is nothing in my UT system folder with an INI extension. I have: DLLs, Configs, INTs, Us, Batches and Internet Shortcuts.
Oh, and three text documents.
....
Ah! My computer doesn't show the INI thingy when I click the Details view, it just says Configuraton File... Sorry, my bad.

Where exactly in the *ahem* .ini do I add the line?
Depends what rendere you're using, if Direct3D9 then it should go under
[D3D9Drv.D3D9RenderDevice]

if OpenGL then it should go under
[OpenGLDrv.OpenGLRenderDevice]

For example

[D3D9Drv.D3D9RenderDevice]
FrameRateLimit=200
...other values...
__________________

For those willing to build a mountain of bodies
and climb to the top.
In environments that stun.
Against A.I. that kills.
For those willing to stake their lives
in the pursuit of victory...
we salute you.
Raynor.Z is offline   Reply With Quote
Old 10th Mar 2008, 05:47 PM   #18
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
I am using the D3D9 renderer, but in the file there is no [D3D9Drv.D3D9RenderDevice] thingy, only a D3D.... I put the Frame-woo-woo in there anyway and it didn't work (Duh!).

I'm going to try the OpenGL, but be prepared

Edit:

Epic Fail. It seems my PC is allergic to OpenGL.

Edit2:

What if I copied the whole [D3DDrv.D3DRenderDevice] section and just put 9's in there? Or is that stupid?
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."

Last edited by Adelheid; 10th Mar 2008 at 05:57 PM.
Adelheid is offline   Reply With Quote
Old 10th Mar 2008, 07:30 PM   #19
brdempsey69
Original UT Owns !!
 
brdempsey69's Avatar
 
Join Date: Jun. 19th, 2003
Posts: 361
Try looking towards the very bottom of the UnrealTournament.ini configuration file and see if you have the [D3D9Drv.D3D9RenderDevice] header and the settings listed below it. That was where mine ended up after I installed the Direct3D9 driver.

I you still don't see it anywhere you can copy and paste this into it and then adjust settings to your liking and then click File>Save to save the changes.

[D3D9Drv.D3D9RenderDevice]
ZRangeHack=False
NoAATiles=True
NumAASamples=16
UseAA=True
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=False
UseTripleBuffering=True
MaskedTextureHack=True
SmoothMaskedTextures=False
SceneNodeHack=True
FrameRateLimit=85
SwapInterval=-1
UseFragmentProgram=True
UseVertexProgram=False
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=2
RefreshRate=85
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=16
Use565Textures=False
Use16BitTextures=False
UseS3TC=True
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=False
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.000000
LODBias=-0.750000
DetailTextures=True
DescFlags=0
Description=
HighDetailActors=True
Coronas=True
ShinySurfaces=True
VolumetricLighting=True

Last edited by brdempsey69; 10th Mar 2008 at 07:32 PM.
brdempsey69 is offline   Reply With Quote
Old 10th Mar 2008, 07:47 PM   #20
Adelheid
Bernstein
 
Adelheid's Avatar
 
Join Date: Jan. 23rd, 2008
Location: Nowhere.
Posts: 1,027
Didn't work, which is really dumb as I can see your frame rate limit is at 85... Grrr..
__________________
"So, it's defeat for you, is it? Someday I must meet a similar fate..."
Adelheid is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Copyright ©1998 - 2012, BeyondUnreal, Inc.
Privacy Policy | Terms of Use
Bandwidth provided by AtomicGamer