News UnrealEd Files Mods FragBU Liandri Archives
BeyondUnreal Forums

Go Back   BeyondUnreal Forums > Unreal Development > Coding

Reply
 
Thread Tools Display Modes
Old 28th May 2004, 09:24 PM   #1
Dark[NSF]
Northwest Secessionalist Forces
 
Dark[NSF]'s Avatar
 
Join Date: Mar. 12th, 2003
Location: Melbourne, Florida
Posts: 632
[UT2004] Can't find my models!?

Quote:
Importing Defaults for PISTOL_Sp9_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.sp9''
Importing Defaults for SMG_ACS_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.acs''
Importing Defaults for SMG_K12_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.acs''
Importing Defaults for SMG_Mp8_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.acs''
Importing Defaults for SNIPER_Hunting_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.hunting-rifle''
Importing Defaults for SNIPER_Robar_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.hunting-rifle''
Importing Defaults for SNIPER_Semi_
ObjectProperty Engine.Actor.Mesh: unresolved reference to 'SkeletalMesh'dark.hunting-rifle''

The model file is in the correct location, this has only happened since I moved to UT2004 from UT2003..

I also opened it in the editor to make sure of some things, resaved it and it still didn't work..
__________________
http://www.ReignofMilitias.com

webevolved.com || ICQ: 96970935
Dark[NSF] is offline   Reply With Quote
Old 28th May 2004, 10:12 PM   #2
meowcat
nothing new under the sun
 
meowcat's Avatar
 
Join Date: Jun. 7th, 2001
Posts: 750
Could you post what the default property entry looks like? I am also using skeletal meshes and here is what my default property looks like:

Mesh=mesh'TD2WeapMesh.t_AK74mesh'

are the ' marks out of place around 'skeletalMesh' instead of skeletalMesh'modelpackage.modelname'?
__________________
"What do you mean it doesn't exist clientside?"
Meowcat's Mods for UT2K4:
Yet Another Real-life Mod: Class-based play, generic realistic weapons, unoriginal gameplay, w/ cheap COD4 knockoff, parkour player moves
TD Vehicles v125: HMMWV, MI4Hound, Black Hawk & AH-6 Helicopters, Motorcycle, IFAV Jeep, Abrams Tank
Jetpacks for UT2k4!

Last edited by meowcat; 28th May 2004 at 10:13 PM.
meowcat is offline   Reply With Quote
Old 28th May 2004, 10:30 PM   #3
Dark[NSF]
Northwest Secessionalist Forces
 
Dark[NSF]'s Avatar
 
Join Date: Mar. 12th, 2003
Location: Melbourne, Florida
Posts: 632
Quote:
Originally Posted by meowcat
Could you post what the default property entry looks like? I am also using skeletal meshes and here is what my default property looks like:

Mesh=mesh'TD2WeapMesh.t_AK74mesh'

are the ' marks out of place around 'skeletalMesh' instead of skeletalMesh'modelpackage.modelname'?

Code:
     Mesh=SkeletalMesh'dark.acs'
__________________
http://www.ReignofMilitias.com

webevolved.com || ICQ: 96970935
Dark[NSF] is offline   Reply With Quote
Old 28th May 2004, 10:43 PM   #4
meowcat
nothing new under the sun
 
meowcat's Avatar
 
Join Date: Jun. 7th, 2001
Posts: 750
Well the only thing i can think of is that either the name of the models or package changed (or were renamed when you opened it and saved it?) or perhaps you have the model file in a separate mod folder. I was able to create the same log errors you got by simply moving my animation file out of the animations folder.
__________________
"What do you mean it doesn't exist clientside?"
Meowcat's Mods for UT2K4:
Yet Another Real-life Mod: Class-based play, generic realistic weapons, unoriginal gameplay, w/ cheap COD4 knockoff, parkour player moves
TD Vehicles v125: HMMWV, MI4Hound, Black Hawk & AH-6 Helicopters, Motorcycle, IFAV Jeep, Abrams Tank
Jetpacks for UT2k4!
meowcat is offline   Reply With Quote
Old 28th May 2004, 11:06 PM   #5
Dark[NSF]
Northwest Secessionalist Forces
 
Dark[NSF]'s Avatar
 
Join Date: Mar. 12th, 2003
Location: Melbourne, Florida
Posts: 632
yep, well its in there and the names are the same. it works perfect with 2003 but not 2004.
__________________
http://www.ReignofMilitias.com

webevolved.com || ICQ: 96970935
Dark[NSF] is offline   Reply With Quote
Old 29th May 2004, 08:40 PM   #6
[SAS]Solid Snake
Registered User
 
[SAS]Solid Snake's Avatar
 
Join Date: Jun. 7th, 2002
Location: New Zealand
Posts: 2,633
Did you use the exec load package? As in #exec load OBJ=filename. It's one of the common things to miss.
__________________
I make the impossible possible ... ... ... to some extent.

Digital Confectioners
[SAS]Solid Snake is offline   Reply With Quote
Old 29th May 2004, 08:48 PM   #7
Dark[NSF]
Northwest Secessionalist Forces
 
Dark[NSF]'s Avatar
 
Join Date: Mar. 12th, 2003
Location: Melbourne, Florida
Posts: 632
Same error, looks like I'm going to haev to rebuild the ukx file? ^^
__________________
http://www.ReignofMilitias.com

webevolved.com || ICQ: 96970935
Dark[NSF] is offline   Reply With Quote
Old 6th Jun 2004, 04:07 PM   #8
meowcat
nothing new under the sun
 
meowcat's Avatar
 
Join Date: Jun. 7th, 2001
Posts: 750
possible cause

Quote:
Originally Posted by Dark[NSF]
Same error, looks like I'm going to haev to rebuild the ukx file? ^^
Just figured it out I think. It has to do with package dependecies. When I removed a texture package altogether (I had renamed all of the textures in it to another texture package to consolidate the total number of packages). When I deleted the original texture package then tried to recompile, I got the same error messages you got. The textures that I had renamed still referred to the color "palettes" of the original package. It could not compile because of this. You might want to check the ucc.log file to get the specifics of why it failed.
__________________
"What do you mean it doesn't exist clientside?"
Meowcat's Mods for UT2K4:
Yet Another Real-life Mod: Class-based play, generic realistic weapons, unoriginal gameplay, w/ cheap COD4 knockoff, parkour player moves
TD Vehicles v125: HMMWV, MI4Hound, Black Hawk & AH-6 Helicopters, Motorcycle, IFAV Jeep, Abrams Tank
Jetpacks for UT2k4!
meowcat is offline   Reply With Quote
Old 6th Jun 2004, 04:10 PM   #9
Dark[NSF]
Northwest Secessionalist Forces
 
Dark[NSF]'s Avatar
 
Join Date: Mar. 12th, 2003
Location: Melbourne, Florida
Posts: 632
awww, your right ^^
__________________
http://www.ReignofMilitias.com

webevolved.com || ICQ: 96970935
Dark[NSF] is offline   Reply With Quote
Old 21st Jul 2004, 01:52 PM   #10
_paradox_
Registered User
 
Join Date: Jul. 14th, 2004
Posts: 4
How does one fix this error? I have the same problem. Can I not get rid of the old texture package without breaking everything?
_paradox_ is offline   Reply With Quote
Old 30th Jul 2004, 12:35 PM   #11
meowcat
nothing new under the sun
 
meowcat's Avatar
 
Join Date: Jun. 7th, 2001
Posts: 750
Quote:
Originally Posted by _paradox_
How does one fix this error? I have the same problem. Can I not get rid of the old texture package without breaking everything?
Reimport the textures into a new texture package (so that the palettes are generated in the new package) and reassign them to models. This is only neccessary for P8 textures.
__________________
"What do you mean it doesn't exist clientside?"
Meowcat's Mods for UT2K4:
Yet Another Real-life Mod: Class-based play, generic realistic weapons, unoriginal gameplay, w/ cheap COD4 knockoff, parkour player moves
TD Vehicles v125: HMMWV, MI4Hound, Black Hawk & AH-6 Helicopters, Motorcycle, IFAV Jeep, Abrams Tank
Jetpacks for UT2k4!
meowcat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Copyright ©1998 - 2012, BeyondUnreal, Inc.
Privacy Policy | Terms of Use
Bandwidth provided by AtomicGamer