News UnrealEd Files Mods FragBU Liandri Archives
BeyondUnreal Forums

Go Back   BeyondUnreal Forums > Unreal Development > Mapping

Reply
 
Thread Tools Display Modes
Old 11th Apr 2004, 12:28 PM   #1
Bonecrusher
Make choices, don't look back...
 
Bonecrusher's Avatar
 
Join Date: Oct. 14th, 2001
Location: Spring City, PA
Posts: 3,873
Movers & Vehicles

I'm trying to make an elevator for vehicles...how come Movers aren't triggered by vehicles? I think I've tried everything. Am I missing something?
__________________

: My 350Z : My Sigs : BuA :
Bonecrusher is offline   Reply With Quote
Old 11th Apr 2004, 01:47 PM   #2
shadow_dragon
is ironing his panties!
 
shadow_dragon's Avatar
 
Join Date: Apr. 26th, 2000
Location: "The cold neon research lab of your betrayal"
Posts: 4,512
Give em a switch to shoot! Not that i've seen a switch since UT'99! But still!
__________________
"There are only two words that can make me laugh uncontrollably and innapropriately in an otherwise innocent sentence: Debugger and Fallacy!"

Quote:
Originally Posted by Haarg View Post
what the **** is wrong with you
shadow_dragon is offline   Reply With Quote
Old 11th Apr 2004, 08:11 PM   #3
{ME}
ma$e is back!!??
 
Join Date: Mar. 6th, 2004
Posts: 470
im a noob at mapping..i dont map much in 2k4.. but i did a lot in UT. could you just make it a triggered mover (not a bumpopen mover).. then in the triggers properties, isnt there something like "triggered classes"? and switch that to w/e teh vehicle class is. onsvehicles or something i think. im not exactly sure though, so dont take my word for it
__________________
{ME} is offline   Reply With Quote
Old 12th Apr 2004, 01:50 AM   #4
Jacob Korn
Crimson Strife Mapper
 
Jacob Korn's Avatar
 
Join Date: Apr. 16th, 2001
Location: New Zealand
Posts: 156
that sounds about right, but thats going from my ut days aswell. i havnt had much experiance with movers in 2k3/4 yet
__________________
Best sig in the world
Jacob Korn is offline   Reply With Quote
Old 12th Apr 2004, 06:13 PM   #5
Paladin
Where do I mount the silencer?
 
Paladin's Avatar
 
Join Date: Jan. 4th, 2000
Location: QBVille
Posts: 60
I'm having the same problem. I wish I had an answer, but I'm still looking for one too. Plus, I've had a problem with the movers not colliding properly with the vehicles. From what I can tell, if the mover speed is faster than the vehicle's maximum speed, the mover will pass through the vehicle, leaving it behind. And when the lift returns, despite having it set to crush on encroach and a high enough damage to destroy any vehicle, the mover simply pushes the vehicle out of the way...usually making it hang on surrounding architectural static meshes.
__________________
Whoso pulleth this linolium knife from this milkman shall be the rightwise born king of England!

Max, Sam & Max The Freelance Police
Paladin is offline   Reply With Quote
Old 12th Apr 2004, 07:53 PM   #6
chip
Registered User
 
Join Date: Nov. 14th, 2002
Posts: 524
-- place a Trigger in the middle of your Lift Mover
-- Trigger Event = Mover Tag
-- TriggerType = TT_ClassProximity
-- Trigger ClassProximityType = Onslaught.ONSVehicle (or whatever vehicle type you need for your map)
-- set Mover DelayTime to 0.5 to 1.0 sec (gives the vehicle time to get fully on the lift)

this should get you started, at least. i tested it with an Onslaught tank and it works, subject to the caveats below.

NOTES: vehicles and Movers interact oddly. unless the vehicle is occupied and has some velocity (even really small), the vehicle will not interact with the Mover, perhaps due to some aspect of the Karma coding. so vehicle lifts will be unreliable at best unless some workaround is developed.

a similar problem affects XMP vehicles. i wrote a small scripted actor for XMP maps that wakes up the karma of unoccupied vehicles when a mover is activated -- something similar might work for UT2K4 vehicles as well. if you're inclined to scripting, look in the classes for the KWake() function, see if & how it's used. if it's in there, you might be able to use it as i did in the XMP fix. be sure to test it thoroughly for netplay!

also note that unlike XMP, in UT2K4 you apparently can't base a VehicleFactory on a Mover, so vehicle spawn points will have to be placed elsewhere than a Mover/lift.
chip is offline   Reply With Quote
Old 13th Apr 2004, 08:02 AM   #7
Paladin
Where do I mount the silencer?
 
Paladin's Avatar
 
Join Date: Jan. 4th, 2000
Location: QBVille
Posts: 60
Chip, I can't tell if you answered my mover collision question or not, and I'm at work ATM and can't test it...

"unless the vehicle is occupied and has some velocity (even really small), the vehicle will not interact with the Mover, perhaps due to some aspect of the Karma coding"

If I drive a vehicle onto a mover and if I keep the vehicle in motion even slightly, it will interact correctly with the mover? Is that lack of vehicle motion the reason my vehicles seem to get left behind by fast-moving movers? I have a moving horizontal platform (lift) to move people and vehicles from one platform to another. People work fine, vehicles get dropped off the back as the mover glides up to full speed.
__________________
Whoso pulleth this linolium knife from this milkman shall be the rightwise born king of England!

Max, Sam & Max The Freelance Police
Paladin is offline   Reply With Quote
Old 13th Apr 2004, 11:05 AM   #8
chip
Registered User
 
Join Date: Nov. 14th, 2002
Posts: 524
Paladin: by "interact" i mean the vehicle responds to the mover, rather than just having the mover pass right through it. with a vertical lift, i had to have a small velocity to the vehicle or it wouldn't get lifted vertically (basically i was responding to the original post of this thread). i could also activate the mover while shooting the vehicle and the vehicle would respond to the mover -- shooting a vehicle wakes up its karma code.

i haven't tested horizontal movement, but would assume the same conditions apply, with the added problem that there seems to be some inertia and friction coded into the vehicles that may be a prob -- in my tests the inertial effects looked rather inaccurate, typical for many game vehicles.

Last edited by chip; 13th Apr 2004 at 04:36 PM.
chip is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Copyright ©1998 - 2012, BeyondUnreal, Inc.
Privacy Policy | Terms of Use
Bandwidth provided by AtomicGamer