News UnrealEd Files Mods FragBU Liandri Archives
BeyondUnreal Forums

Go Back   BeyondUnreal Forums > Mods > UT2Vote > General Discussion

Reply
 
Thread Tools Display Modes
Old 29th Jun 2005, 12:21 PM   #1
theteck
Registered User
 
Join Date: Jan. 10th, 2005
Posts: 18
getpathname error

hi,

i have this bug only when ut2vote switch map ?

can you help me ?

Exit: Socket shut down
Log: Collecting garbage
Log: Purging garbage
Log: (Karma): Level Karma Terminated.
Critical: UObject::GetPathName
Critical: UObject::GetPathName
Critical: UObject::GetPathName
Critical: UObject::GetFullName
Critical: DispatchDestroy
Critical: UObject::GetPathName
Critical: UObject::GetPathName
Critical: UObject::GetPathName
Critical: UObject::GetFullName
Critical: DispatchDestroys
Critical: UObject::PurgeGarbage
Critical: UObject::CollectGarbage
Critical: Cleanup
Critical: UGameEngine::LoadMap
Critical: LocalMapURL
Critical: UGameEngine:rowse
Critical: ServerTravel
Critical: UGameEngine::Tick
Critical: Level DowntownChaos-V3
Critical: UpdateWorld
Critical: UServerCommandlet::Main
Exit: Executing UObject::StaticShutdownAfterError
Exit: Exiting.


thanks
theteck is offline   Reply With Quote
Old 30th Jun 2005, 01:53 AM   #2
tdw-socke
Registered User
 
tdw-socke's Avatar
 
Join Date: Nov. 21st, 2003
Posts: 990
does it switch correctly to that specific map without ut2vote?

from my experience a StaticShutdownAfterError happens mostly, if something is missing, a mutator, a texture, a static mesh or something else... this should also happen without ut2vote.
tdw-socke is offline   Reply With Quote
Old 30th Jun 2005, 11:11 AM   #3
theteck
Registered User
 
Join Date: Jan. 10th, 2005
Posts: 18
no

no this map is working correctly

but 2 or 3 time a day i have this error but this map working all the day and this appens to all my map but only 1 or 2 time a day and is intermitent

mayby is to long to change map ?? ut2vote take this setting WaitForLevel=90

can go up to 120 ?? this appens when server is full up to 20 people when server is near empty this not appens

is the timout ?

im a good admin from many years and this is very hard to find this bug

and the game never gpf when i play only when the utvote change the map....

thanks



Quote:
Originally Posted by tdw-socke
does it switch correctly to that specific map without ut2vote?

from my experience a StaticShutdownAfterError happens mostly, if something is missing, a mutator, a texture, a static mesh or something else... this should also happen without ut2vote.
theteck is offline   Reply With Quote
Old 30th Jun 2005, 02:58 PM   #4
theteck
Registered User
 
Join Date: Jan. 10th, 2005
Posts: 18
ok i try but

is not working


(
theteck is offline   Reply With Quote
Old 1st Jul 2005, 01:19 AM   #5
tdw-socke
Registered User
 
tdw-socke's Avatar
 
Join Date: Nov. 21st, 2003
Posts: 990
what kind of server do you use? cpu and ram.
rising the WaitForLevel did not work?

if this only happens with 20 players and not with few players, i'd think of a stronger server, and yes, the WaitForLevel-setting.

Posting sour ut2vote.ini and your serverlog (best as links) could help here...
tdw-socke is offline   Reply With Quote
Old 2nd Jul 2005, 01:34 AM   #6
theteck
Registered User
 
Join Date: Jan. 10th, 2005
Posts: 18
no

waitforlevel not working

3700+ 1024 meg of ram

and is on ezzi.net oc-48

i thinks is good




Quote:
Originally Posted by tdw-socke
what kind of server do you use? cpu and ram.
rising the WaitForLevel did not work?

if this only happens with 20 players and not with few players, i'd think of a stronger server, and yes, the WaitForLevel-setting.

Posting sour ut2vote.ini and your serverlog (best as links) could help here...
theteck is offline   Reply With Quote
Old 2nd Jul 2005, 02:44 AM   #7
ProAsm
Registered User
 
ProAsm's Avatar
 
Join Date: Mar. 20th, 2002
Posts: 2,106
Is your server an ADM ?
If so, there is one thing you can try and if this does not work you MUST remove it as it can cause other players that are not having the problem to crash.
In the UT2Vote51.ini file under [UT2Vote51.UT2VoteIniOnly] add the following:
bNoDisconnect=True

Like I say if it does not work, remove it.
This option should only be used in extreme cases where players get kicked during a level changeover as it will remove many of the functions that UT2Vote normally does.

This option is not documented because its only used in extreme cases and this may be one.
ProAsm is offline   Reply With Quote
Old 3rd Jul 2005, 10:40 PM   #8
theteck
Registered User
 
Join Date: Jan. 10th, 2005
Posts: 18
ok i try this

my server is this

http://www.serverspy.net/site/search....154:7777&g=13

and i try this tomorow morning and check what this make

thanks you to help me



Quote:
Originally Posted by ProAsm
Is your server an ADM ?
If so, there is one thing you can try and if this does not work you MUST remove it as it can cause other players that are not having the problem to crash.
In the UT2Vote51.ini file under [UT2Vote51.UT2VoteIniOnly] add the following:
bNoDisconnect=True

Like I say if it does not work, remove it.
This option should only be used in extreme cases where players get kicked during a level changeover as it will remove many of the functions that UT2Vote normally does.

This option is not documented because its only used in extreme cases and this may be one.
theteck is offline   Reply With Quote
Old 4th Jul 2005, 02:07 AM   #9
tdw-socke
Registered User
 
tdw-socke's Avatar
 
Join Date: Nov. 21st, 2003
Posts: 990
again, links to your ut2004.ini, your ut2vote51.ini and maybe your startup-line, could be helpfull...
tdw-socke is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Copyright ©1998 - 2012, BeyondUnreal, Inc.
Privacy Policy | Terms of Use
Bandwidth provided by AtomicGamer