PDA

View Full Version : 2 terrabyte HDD


StoneViper
9th Jan 2002, 10:36 PM
my system thinks it has installed a two terrabyte Hard Drive. It has millions of errors on it. i can't change the partition, merge them, add one, or delete one. I keep getting errors that don't tell what the problem is. the error is just a number like "error 912" or something.

Because of this i can't use my second HDD (except my one good partition on it, which it thinks it's twice the size it should be).

It is a 45 gb harddrive.

I've used programs such as fdisk, and Partition Magic Pro 7 (in both windows and dos from it's boot disks) I can't do anything with it.

Can you help me fix this?

StoneViper
9th Jan 2002, 10:38 PM
what really confuses me is that two terrabytes is the largest partition size FAT32 can be used for (just like 2 gigabytes is the largest partition FAT can be used for)

JTRipper
9th Jan 2002, 11:18 PM
From your description, I'm thinking that the problem is probably going to be in BIOS. Assuming it's an EIDE drive, either it was set incorrectly, autodetected incorrectly, or it's logical geometry no longer "works" right anymore. If this is it, there's a fix, but be aware that it's more than likely going to mean trashing any data on the drive.

Get into your BIOS setup, and make a note of whatever numbers are listed there, as well as the mode. Make sure that the drive is set to mode = LBA. If it's normal, large, or ECHS, set it to LBA and try autodetecting again. Make sure that whatever geometry it comes up with is correct, and set it manually if it isn't. The drive's geometry should be printed on the label - cylinders, heads, and sectors per track.

If it wasn't set to LBA, it shouldn't be readable after that. If it was set to LBA but the geometry was off, it's likely to be readable, but with errors (and your partition info will still be wrong). From here you should be able to delete the old partition(s), reboot, and repartition the drive. If none of this fits the problem, some more info on the drive's history could be helpful.

StoneViper
9th Jan 2002, 11:55 PM
this is my newer drive. the problem happened after i deleted some partitions using fdisk (apparantly they weren't deleted, but one was added). fdisk actually never liked this drive. i couldn't delete the extended partition because of something, and i couldn't delete the something it couldn't find the extended partition. i don't know the details all i know is it gave me the run-a-round. Maxtor's MaxBlast didn't even think there was second HDD installed.

All data has been removed from that disk, but it thinks there are things on it still, and i know there isn't.

This is a 45GB HDD. It is on my Primary Slave IDE. my 30GB HDD is my Primary Master. They are both jumpered right. It has always has two partitions created with fdisk. Im not sure what file system it used to have, but it is now NTFS.

I was dual-booting with winXP and winME. I have since reformatted that whole HDD before i had problems with it, so that is how i know i have nothing on it. win2K is now on my Primary Master (the 30gb HDD) and it still thinks i am dual-booting. There is a menu of three choices of what OS i want to boot, but i only have one installed.

JTRipper
10th Jan 2002, 02:27 AM
Heh, sounds like you've had a mess of a time. But FDisk (and I assume Partition Magic & MaxBlast also) works with whatever the BIOS tells it is installed. If either the BIOS or the drive aren't reporting it's geometry correctly, it'll never work correctly - that's why it's important to make sure you're square there. Since the problem only started after you tried to change the partition, it doesn't seem likely that the problem is there, but just to make me feel better check it anyway. I've only used MaxBlast on two systems, but it never failed to find (and identify) a drive, which is why I'm still concerned about this.

As long as that all looks correct, then the problem can only be in the partition table. If you have a WinME (or preferably Win98) boot floppy around, I'd recommend booting from that and running FDisk again. Try deleting a non-DOS partition, rather than a DOS primary or extended, and see if you have better luck. I suspect that Win2k would have to change the partition type from DOS to NT before reformatting for NTFS, though I don't know NT/2k well enough to say for sure. It doesn't explain why it's reporting the size incorrectly, but it would explain why it wouldn't delete. The delpart utility might also be worth a shot. It was part of the NT resource kit, but might have been included with 2k. If not, it's here

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/reskit/nt31/i386/reskit.exe

If that still doesn't do it, give

fdisk d: /mbr

a shot. It's a reach (and I'm not sure /mbr actually works on an extended partition), but worth a try if there's no data to lose anyway. Win2k might cop an attitude about that when you reboot, but it should convert the drive again, and hopefully correctly. With any luck, it won't assume that it's supposed to be a bootable partition.

As for fixing the dual-boot thing, I can't help much, but I'm glad you mentioned it, it does present another (remote) possibility. I did read up on Win2k's approach to dual boot, but I'm afraid the bulk of it went in one eye and out the other. Win2k, if I recall, doesn't use a traditional master boot record, and the partition table of the primary partition (your C: drive) isn't "normal". Or rather, the way it's handled is a departure from DOS/Win98. At any rate, it's from your c: drive that it's getting the idea that you still have a dual-boot system, and the fix for it is different than earlier versions. I know there is a procedure to revert to a single boot, but you'll need to find it elsewhere. Win2k's help maybe? Heh, talk about reaching... At any rate, I doubt it's causing problems with your D: drive, but booting from the WinME or 98 disk will insure that it can't. I know that there was a lot of work put into recovering from problems in Win2k, and if it's trying to "fix" your "broken" other boot partition (without realizing that it isn't supposed to have an OS anymore), it's possible that it could give you headaches. That's just guesswork though, and I'll stress again that I don't know 2k that well, but if nothing to this point has fixed it, it's worth looking into. If you get it straightened out booting from a floppy and it gets screwed up again later, the guess is probably accurate and Win2k is "fixing" things for you. You'd need to get the dual boot straightened out first, then fix the d: drive again, then let Win2k convert it.

If none of this seems to help, it's time to yank the c: drive and set the d: drive up as solo/master. Try installing Win2k on it, and see what happens. If absolutely none of this helps at all, and this doesn't work either, I hope your warranty hasn't expired. I'd have to chalk it up to hardware failure (as unlikely as it seems).

StoneViper
10th Jan 2002, 08:12 AM
Thanks for all the help, ill give MaxBlast a try again. MaxBlast always worked when fdisk failed but for this one time. I just wish there was one program that can totally wipe clean a HDD as wish it was fresh out of the box.

Ill also check out the delpart utility. I've had problems with wrong geo sizes on a HDD before, but they have since been fixed (i don't remember how).

JTRipper
12th Jan 2002, 11:06 PM
Your post just reminded me that some IDE drive manufacturers used to distribute low level format utilities for their drives. EIDE drives are supposed to ignore any attempt at a low level format, but in the worst case, it might be possible that Maxtor has something like that for your drive (I'm assuming it's a Maxtor).

StoneViper
13th Jan 2002, 08:48 PM
it is a maxtor drive, both of them. I tried using MaxBlast again and this time it recognised both HDDs. I partitioned and formatted (it asked me for a win9x disk, so i used one) and made it into one FAT32 partition.

....but now PartitionMagic won't work! Windows see's it as a newly unformatted drive. (*confused*). So i will format it tonight in FAT32 and load winME if i can. I uninstalled Partition Magic via add/remove programs from the control panel and reinstalled it. It still won't work. I am going to reformat my win2K partition also, but later. ill let you know what happens tomorrow about this reformatting.

JTRipper
13th Jan 2002, 10:55 PM
To quote a horse, "No sir, I don't like it". That is one seriously troublesome unit.

StoneViper
14th Jan 2002, 09:24 AM
i attempted a format using windows, here's what happened:

error - 'the format could not complete'

then...

error - 'drive d:\ could not be formatted'

these are the two windows that opened after the formatting was about to finish.

Do you know of another program other than Partition Magic that i can use (on an NTFS win2K partition), since that program no longer works on my system.

JTRipper
14th Jan 2002, 10:07 AM
Aside from Win2k's Disk Administrator, I don't know anything else that will create NTFS partitions, but if they're valid Fdisk should have no trouble deleting them (as non-DOS partitions) and delpart should do it even if they're not. Norton's Disk Doctor may or may not help, but I'm leaning toward "not". A screwy partition table wouldn't make MaxBlast fail to see the drive one day, and find it another. I'm sorry to say that if the geometry's correct in BIOS, that sort of intermittant problem sounds more like failing hardware.

StoneViper
14th Jan 2002, 10:42 AM
right now i don't care whether or not it's FAT32 or NTFS. I tried to do FAT32 on this one. I still don't think the problem is hardware related because i got this error when running the reskit you linked me to. this is the last lines of the log file during 'double clicking' the file

StoneViper
14th Jan 2002, 10:44 AM
if im right, Command.com is the program that actually does the formatting. btw the only errors in the log file are the ones you can see in the pic.

Chrysaor
14th Jan 2002, 01:44 PM
This is wonderful, REAL troubleshooting going on in the toubleshooting forum. Don't let me ruin it, i just thought it was nice to finally see.

StoneViper
14th Jan 2002, 10:12 PM
umm chrysaor the spamming thread is here (http://forums.beyondunreal.com/showthread.php?s=&threadid=90539).

when i opened fdisk and saw there were five options i almost screamed! When i looked at the specs for that one partition i almost fainted. When i saw that the partition was made up of 43gb, i woke up on the floor with someone over me asking me how many fingers they were holding up.

anyway i will try to load winME again on the FAT32 partition and just hope that everything goes well. This time i will wrap myself up in a blanket so that if i faint again because i can't believe what im seeing i will land softly. Ill post my findings here when i install winME tomorrow.

JTRipper
14th Jan 2002, 10:19 PM
lol@Chrysaor. It's reminding me that there's a reason why I stay out of here. ;)

I just DL'd the reskit, and it extracted fine here. If you want those files you might want to grab it again, I know the file is good. At any rate, if only those files failed to extract you don't need them, delpart is a standalone utility.

Fyi, command.com just provides the command line interface, the command interpereter for batch files, and things like that. The actual formatting is done by the format utility. And to straighten out a possible misunderstanding, the partition type isn't the same as the FAT. A DOS partition is needed for FAT16 or FAT32 to work, while an NT partition is needed for NTFS, but any file system is part of the high level format (not partitioning). I think you knew that and just misworded, but thought I'd mention it.

StoneViper
14th Jan 2002, 10:30 PM
as far as high level and low level stuff yeah im clueless. give the hardware and i usually know what to do with it, but as for as the terms and stuff i don't know that where is delpart, can you link me it¿ I thought that .com files were loading files, so i wasn't sure what command.com actually was. i read somewhere it had something to do with the actual formatting, but at then i couldn't understand why MaxBlast had command.com on it yet it needed win9x disk to format it.

Fdisk thinks it's formatted as FAT32, but windows sees it as an unformatted drive. Im hoping installing winME solves this because i can format it just before the installation.

And that whole Partition Magic thing i still don't understand. Everytime i solve a problem with my computer, i get a new one to fix. each one was harder than the previous problem was to fix. i wonder what will happen to my computer after i fix this¿ bad bios¿ (like my older motherboard, thank God for dual bios) ill tell you what problem will arise after i install winME tonight.

And thanks so much for all the help!! (no not you Chrysaor, lol)

JTRipper
15th Jan 2002, 02:30 AM
The delpart utility (delpart.exe) is in that reskit file. If you don't see it with the others, download reskit again.

The MaxBlast disk has system files on it (io.sys, msdos.sys, and command.com) because it needs to be bootable, but my guess is that it doesn't do the formatting itself (uses the format utility from the Win cd).

As for the terms, briefly -

Low level format is something users & technicians don't have to worry about anymore. It's when the boot sector is created, the sectors are created, and the drive's interleave is set. When IDE drives came out though, thier actual physical geometry wouldn't work with BIOS, so they had a logical geometry and a translation table added to make them work. This meant that low-level formats couldn't work anymore, and from then on were only meant to be done at the factory. As I said, some manufacturers did distribute low level format tools for specific models (that were aware of the drive's translation tables), but generic LLF tools didn't work anymore. Or destroyed drives if they did. EIDE drives are supposed to ignore any attempt at low level formatting so that the clueless don't destroy them. 99% of people don't really need to know this anymore, but if a tool like that were available for your EIDE drive, it would either set it back to "factory" condition, or tell you that it can't be (in which case you'd know for sure that the drive is screwed). This is why I said to check Maxtor - maybe manufacturers still offer tools like that, I don't know.

Partitioning is setting up a low-level formatted drive for formatting and recording it in the partition table. It sets up any logical divisions of the drive in the partition table for multi-OS or logical drive setups, and sets the active partition. I'm not 100% sure, but I think that the format utility detremines the size of the drive to format from here rather than BIOS. The partition info and the BIOS are the only two places where the size of the disk is defined (barring counting all the sectors in the FAT), so if any program is reporting a bad disk size, it's coming from one of the two. If only a partition's size appears bad, it's in the partition table.

High level format is what the format utility does. It writes a header and trailer to every sector defined by the LL format with a 512 byte data area in between, and sets up a file system for use by the OS. Any problems you have here are a symptom, not a cause.

Varpu
15th Jan 2002, 08:26 PM
Yes- the size of the drive seen from os, including the format utility, is read from the partition table - using BIOS.

The format utility has traditionally been a separate program to wipe out existing data from disk partitions. Today they won't wipe anything, they just read the entire surface (check it out) and recreate the file system. The actual physical disk access is in the BIOS (INT13) and the format utility just uses the simple read/write sector from there.

I have never made a boot partition bigger than 2G. And I would expect to see trouble if making it bigger than that. Most machines I have at home have only 1G boot patition that has the OS and then the rest of the drive is partitioned different sizes depending on their partition type. NTFS being the most robust of them.

And a 43G drive just scares me - how in earth do You back it up ?

What I would do with this monster... I would first try to make it be seen correctly from BIOS (just like JTRipper explained). If this fails, there is not much to do for it.

After that, I would start by creating a relatively small partition on it (2G max) and assign that one to a good operating system that is KNOWN to tolerate big ass drives like Yours. Win98 and Win95 are out of that crowd. They may CLAIM to understand the big drive but IMO they are just hax0red versions of older OS versions that were not able to cope with big drives. Win2000 might be usable as it is based on WinNT which has always been ahead of it's time in this issue.

You could also set up a dual boot. The installation order is important here. If You install the Win95/Win98 first and then WinNT/Win2000 the whole thing is made automatically for You. Doing it vice versa can be done but it requires some manual setups on start up files.

After the OS is installed You can partition the hard drive. For partitioning use only an OS that can manage big drives like this. Win95/Win98 will ruin Your work. (Been there, done that). If You have access to Win2k or better yet, WinNT, use it for partitioning and formatting the rest of the hard drive. If You decided to go along the dual-boot way, make sure the Win95/Win98 NEVER sees a drive that is greater than 2G. This can be done by formatting the partitions that should not be seen by Win98/95 to NTFS.

I would not use NTFS partitions on Win95/98. That is just begging to be beaten. Seems like there are utilities around that make this possible but the fact is that the Win95 can't "speak" to an NTFS drive. One corrupted DLL and the data on that partition will be gone forever !

StoneViper
15th Jan 2002, 10:10 PM
win9x can't be installed on NTFS. and yes i do plan on creating more than one partition on this drive. i want to shift my music to this one using a different partition on this HDD. my other one (30gb) is the one with win2K on it.

i believe you partition it before you install the OS. And i've seen nearly every computer that has win9x is installed on 20gb HDDs all the time. FAT32 supports drives up to 2tb. It's FAT16 that can't handle more than 2gb.

Besides i tried to install winME earlier today and it wouldn't let me. It said something about if i continue with the installation, it won't work right, so i didn't install it. LBA was set to enabled.

Tomorrow i will try and call Maxtor and get this straightened out.

StoneViper
19th Jan 2002, 11:59 PM
w00t

Take a look at this! I fixed my HDD. Thanks to everyone who helped in these forums, mainly JTRipper (so that leaves what, one more person¿)! All i did was use the win2K bootdisk32's to partition it and format it. I had to delete the old partition cause it said that it either wasn't formatted, or it had errors. And it worked!!