PDA

View Full Version : My Map won't open in Ued


StoneViper
8th Jan 2002, 02:29 PM
all i get is a blank map when i open it.

if i already have a map opened, loading my troubled map stays on the map i already had on.

it says: Loading CTF-ForbiddenFieldsLE.unr

it won't load the texture files, music file, or anything. the size of the map is the same, i just can't open it up anymore.

what do i do, SAVE ME

Rukee
8th Jan 2002, 05:05 PM
Is it a valid map file??? That is can you play them map from a folder rather then from the game???

StoneViper
9th Jan 2002, 01:54 AM
all i know is that i've been working on this map trying to get it right, then listening to Hourences, then working on this map some more, and then the last time i tried to open it, nothing happened. This error came up when double clicking on the file.

JTRipper
10th Jan 2002, 12:25 AM
Try opening some of the autosave files, or the autoplay.unr if you've launched the map from UEd (er, you DO have autosave on, don't you?). If none of them open, check the log file for additional errors. I have no idea what none.mylevel is, where it came from, or why it can't find it now, but that's how a map acts when a package is missing. Hopefully the log will shed a little more light.

StoneViper
10th Jan 2002, 12:44 AM
where can i get this log file and autosave is on, but i don't where they save to, but ill check autoplay definitally. ill bet Varpu can hack into the file.

JTRipper
10th Jan 2002, 01:22 AM
There will be 10 files in your maps filder, auto0.unr-auto9.unr. The log file is just ASCII text, readable in notepad or wordpad, and it's editor.log in UT\system.

StoneViper
10th Jan 2002, 09:13 AM
thanks, ill get those. I really hope this works.

StoneViper
10th Jan 2002, 09:23 AM
**** it looks like autosave wasn't on. i saw no autox.unr and noticed it was set to false in ued. i know i had turned it on earlier, maybe that was before i repatched to 436. **** im pissed now. ill post that log here:

---the log file---

Log: Log file open, 01/10/02 09:20:43
Init: Name subsystem initialized
Init: Detected: Microsoft Windows NT 5.0 (Build: 2195)
Init: Version: 436
Init: Compiled: Oct 24 2000 23:40:18
Init: Command line:
Init: Base directory: C:\UnrealTournament\System\
Init: Character set: Unicode
Log: Bound to Editor.dll
Log: Bound to Core.dll
Log: Bound to Engine.dll
Log: Bound to Window.dll
Init: Object subsystem initialized
Init: Computer: CHRIS
Init: User: ChrisAWeidert
Init: Memory total: Phys=261424K Pagef=631516K Virt=2097024K
Init: Working set: 32000 / 159000
Init: CPU Speed=598.478743 MHz
Init: CPU Page size=4096, Processors=1
Init: CPU Detected: PentiumPro-class processor (GenuineIntel)
Init: CPU Features: CMov FPU RDTSC PAE MMX KNI
Init: Unreal engine initialized
Log: Bound to Galaxy.dll
Init: Galaxy is using WinMM
Init: Galaxy initialized
Init: Transaction tracking system initialized
Log: Bound to Fire.dll
Log: Bound to IpDrv.dll
Log: Bound to UWeb.dll
Log: Bound to WinDrv.dll
Init: Mouse info: 6 10 1
Init: Client initialized
Log: Bound to Render.dll
Init: Lighting subsystem initialized
Init: Rendering initialized
Init: Editor engine initialized
Log: Startup time: 5.043039 seconds
Init: Input system initialized for U2Viewport0
Log: Opened viewport
Log: Bound to SoftDrv.dll
Init: Input system initialized for U2Viewport1
Log: Opened viewport
Init: Input system initialized for U2Viewport2
Log: Opened viewport
Init: Input system initialized for U2Viewport3
Log: Opened viewport
Init: Input system initialized for MeshViewer
Log: Opened viewport
Init: Input system initialized for TextureBrowser
Log: Opened viewport end of loading unrealed2
Log: New File, Existing Package (Package MyLevel, Package CTF-ForbiddenFieldsLE)
Log: Matched Viewport U2Viewport0
Log: Matched Viewport U2Viewport1
Log: Matched Viewport U2Viewport2
Log: Matched Viewport U2Viewport3
Log: Matched Viewport MeshViewer
Log: Matched Viewport TextureBrowser
DevAudio: Galaxy SetViewport: U2Viewport2
Log: BspValidateBrush linked 0 of 0 polys
Log: Collecting garbage
Log: Purging garbage
Log: 0.0ms Unloading: Package Render
Log: 0.0ms Unloading: Package MyLevel
Log: Garbage: objects: 41573->41548; refs: 499736 end of loading map
Log: Closed viewport
Log: Closed viewport
DevAudio: Galaxy SetViewport: NULL
Log: Closed viewport
Log: Closed viewport
Log: Missing name
Log: Closed viewport
Log: Missing name
Log: Closed viewport
Log: Missing name
Log: Missing name
Log: appRequestExit(0)
Critical: appError called:
Critical: Assertion failed: OwnerWindow [File:..\..\Window\Inc\Window.h] [Line: 1433]
Critical: Windows GetLastError: The operation completed successfully. (0)
Exit: Executing UObject::StaticShutdownAfterError
Exit: UGalaxyAudioSubsystem::ShutdownAfterError
Warning: glxStopOutput() failed: 6
Exit: Executing UWindowsClient::ShutdownAfterError
Critical: WCodeFrame::OnDestroy
Critical: WM_DESTROY
Critical: WWindow::WndProc
Critical: WWindow::StaticProc
Critical: WEditorFrame::OnClose
Critical: WM_CLOSE
Critical: WWindow::WndProc
Critical: WWindow::StaticProc
Critical: WWindow::WndProc
Critical: WWindow::StaticProc
Critical: WWindow::WndProc
Critical: WWindow::StaticProc
Critical: DispatchMessage
Critical: 000503A0 161
Critical: MessagePump
Critical: MainLoop
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, 01/10/02 09:21:05 end of closing unrealed2

---end of log file---

Chrysaor
12th Jan 2002, 01:19 AM
Wish I could help...i've done this before, with different versions of mylevel thingies or something, but that doesn't appear to be what you did. There's a reason I stay away from this section of the forum :)

DigitalW
12th Jan 2002, 04:21 PM
I've had this problem before, but it was when I tried to open a user made unreal1 map in ued2. Not all of them did it just a few. I never found out why, but never bothered to invesigate it either.

JTRipper
13th Jan 2002, 12:22 AM
I opened UEd, loaded a map, and closed it again to compare log files. There are a few lines in the one you posted that weren't in mine, but I can't say that the differences shed any light. Do you recall having placed any sounds, textures, music, or code in MyLevel?

StoneViper
13th Jan 2002, 02:06 AM
i added no sounds, textures, or code in MyLevel. I did have music. The only thing in there is the screenshot, which has been in there for months. this is why im so confused about this, i did nothing that would have caused this.

I doubt this would help any but here's my troubled map. maybe it's my God Forsaken computer's fault and not ued's.

actually come to think of it, the only thing somewhat odd i did, was build another side map within that map, cut and pasted what i needed, and deleted what was left of the original part of that map (kinda like starting over, but not). But still that would not matter in the least bit, since i was able to open it after i did that (i think, im almost positive).

JTRipper
14th Jan 2002, 06:06 AM
I get the same results. I thought I'd try grabbing Unreal Office and taking a peek at the package dependencies, and it seems to think that there are none. I know there is at least one other tool for taking a look in .unr files, but blast if I can remember what. At any rate, if'n you can lay your hands on one of these, you might be able to see if you wound up with a reference you don't recall (a texture from the other file, maybe). If you can get a name and replace it with something else of the same name, you should at least then be able to open it. The tool might have even let you remove references, I think I vaguely recall reading about that on the PU news page. I might have hallucinated that part.

That, or the file is frotzed. Try the editing forums for that other utility I can't remember, someone there likely knows.

StoneViper
14th Jan 2002, 10:19 AM
i make sure i only use official files to use in my map. That is why i don't install any bonus packs on the HDD i use for mapping. Any i frequently type "texture cull" in the command line to eliminate unused textures from my level. The last i tried Unreal Office, i got an error every time i tried installing it. Ill try it again. I emailed Varpu (of his hacking into .unr files) to see if he can change what ever is wrong with it. Ill try other forums also. I found a backup copy of this map from a long time ago; like when i started to revise it. it's not even not worth keeping it's so old. Thanks for all the replies. I hope i just don't to have to accept the fact that this map has been condemned for the remainder of its existance.

Varpu
15th Jan 2002, 11:19 AM
Oh man .... this is so sad.

I pressed the file through the UTCMS inspector and it found no LevelInfo in there. Or if it found it was faulty. It also reported that Your map uses no other than the official textures, sounds etc.... No LevelInfo - no map.

This isn't the first time UED would do stupidities like this. My best guess for what has gone south is that You have loaded some other map in editor and then loaded Your own map without exiting the editor first. In cases like this, there are always some crap left in editor memory from the first map. The worst of them is ofcourse the LevelInfo which is crippled if You load maps on top of each other. I always restart the UED when I start editing my maps. If I need to copy things I use intermediate files (import-export) for that.

There is a good reason why UED behaves like this (texture caching for one) but the execution is poor especially when You change maps.

I tried to salvage the map by several ways:
- giving it an texture package "Level None.utx" which had this MyLevel texture
- Doing this with Sound and Music types as well
- Made an empty map and renamed it to "Level None.unr" and then tried to start Your map
- Renamed Your map to "Level None.unr"
- Renamed Your map to "None.unr"

None of these helped... and then I pressed it through this UTCMS and it gave the reason: No LevelInfo in the file.

Then - I looked the map with UTPT (Unreal Tournament Package Tool) and that revealed that both import and export tables were corrupted (filled in with zeroes).

No data is incurable but this one would be extremely difficult to restore. Loosing contents of those tables (they tell the map loader where different things of the map are in the UNR file) is like formatting Your HD. It can be cured but it is very hard.

Once more - I REALLY wish there would be an easy way of doing it. It it could be done by a program I would gladly have spent the 5 hours in doing that (if nothing else, just to show myself I can do it).

Backups Rule !

Now, to cheer You up, I tell about one accident that happened to me when I was a newcomer in IT business ... more than 15 years ago:

It was a NOKIA PC (Yeah, NOKIA has also manufactured PC:s) left by a customer for file repairs and it had a GIGANTIC 40Mb hard drive. The OS was MsDos V1.2 (or somethig like that). As I was very curious I started to "try" the different commands available in there. Format sounded pretty dangerous so I passed by it ... recover.exe ... mmm... that was interesting. The session was like (I can still remember the green phosphor screen):
C:\> recover <ret>
MsDos Recover V1.2
Missing drive letter
C:\> recover C <ret>
MsDos Recover V1.2
Press any key to start recovering drive C <ret>
Recovering ......(dots appearing)
Finished recovering drive C. Press any key to continue <ret>

C:\DOS\COMMAND.COM not found ... press any key to continue <ret>

After finding out that there REALLY was no more COMMAND.COM around I decided to reboot the machine:

Non system disk - press any key to continue

After I rebooted the machine with a floppy (5 inch, 640Kb) I realized what recover actually does. The darn thing had moved each and every file, including directories into the root directory of C: and then renamed them FILE0001.rec, FILE0002.rec .... FILE0957.rec. One thousand or so files with no idea what they were originally named. All data was there .. yeah .. including the customer database. Spent three weeks "recovering" that thing. Had no backup - either :) .

Chrysaor
15th Jan 2002, 01:49 PM
Ouch for both of you :(

Was this the urban map you were working on, stone?

StoneViper
15th Jan 2002, 11:21 PM
Originally posted by Chrysaor
Ouch for both of you :(

Was this the urban map you were working on, stone?
no that map is ok, it was a different one that hit the ****.

Varpu thanks so much for finding this out for me. what exactly is the level info in the map. i mean where is it. i don't think i could've deleted it.

all i know is at one point of time during construction of that map. i had deleted the whole original part of the map all at once, and what remained in that level was the newer part somewhere else on the grid. Could this have done deleted it?

about backing up, i now have autosav turned on. the last backup was too long ago for me to recontinue working on it.

JTRipper
16th Jan 2002, 02:32 AM
UEd puts one in every map at 0,0,0 - at least, that's where it was supposed to be. It's set to bHiddenEd=true by default.

Just for the heck of it, I dug through the map file, and the string levelinfo does actually appear in the map - I have no clue whether what follows is a valid actor or not though.

Another question for Varpu - do you know of a decent freeware hex editor for Windows? Or DOS either for that matter. It doesn't need to be fancy, just work. I'd like to try inserting what I think is a valid levelinfo from another map into where I think the one for this map should be, and I haven't had one for years.

Varpu
16th Jan 2002, 05:51 AM
A good HEX editor can be found at least in UltraEdit, and one that I would favor if I had to operate on dos prompt would be Norton Commander or NC for short. (LOL they have an almost alike proggie in Linux that has name Midnight Commander).

What comes to "adding" a LevelInfo to an Unreal package - it IS hard and the best place to add it would be in the tail of the file.

The Unreal package has five basic parts:
1. Constant header
2. Symbol table (that's where You find the LevelInfo string)
3. Import table
4. Export table
5. Data

The package starts with a constant header that tells where the three tables reside in the file and how many entries each of them has. The tables in their turn tell:
1. What name does a thing have (The name table)
2. What things does this file offer to others (The export table)
3. What things does this file need (The import table)

The data contains Your work. The export table tells where this data is located and how it is organized. Decoding this part of the package is very hard to do and I almost lost my hope with it. (Scarce documentation being one, small obstacle).

So, let's imagine You wanted to add a LevelInfo into the file. A level info does NOT have static length as it is somewhat "packed" and is has some peculiar decoding techniques. Well, You take a copy from another package an decide
to fill in names with blanks and so on to keep it at original size. OK.

If there would be a LevelInfo already, inserting this one would be just to paste it to place - that's it.

Adding a new one - First append the new LevelInfo at the tail of the file, insert a new entry in the export table -- wait a second -- that thing is in the middle of the file, meaning You have to shift the rest of the file some bytes to the right. This will ofcourse include the job to correct all the entries in the export table to point to the new positions - and this was NOT be the entire story. The Unreal package has a funny way of storing small integers called indexes. They are packed and their size (how many bytes they take room) depends on the integer value - the values change - they MAY take more or less space.....

Just to warn You :)

I attach a the only decent document I found discussing the package structure.

JTRipper
16th Jan 2002, 03:51 PM
Heh, I'm not expecting it to work, just hoping it will. ;) I guess this probably isn't as simple as cheating old bsaved game files. Thanks for the info on the package file structure too. Whether or not it's useful, it should make an interesting read.

StoneViper
17th Jan 2002, 01:18 AM
so your saying there's still a chance my map might come back to life!!?┐

JTRipper
18th Jan 2002, 09:55 AM
Survey says... what was the question, Bob? I fooled with it a little, but either I'm screwing up (most likely) or that isn't the problem. I wouldn't recommend any breath-holding.

StoneViper
20th Jan 2002, 01:12 AM
since it is the same map as the older version, (just older, thats all) i will upload it for you to see where in the map the levelinfo was placed. Will this help any┐

JTRipper
20th Jan 2002, 01:38 PM
Not really. I thought I could tell what part of the file itself was the levelinfo, I was hoping I could figure out which parts of another map was and just put it in place of yours. No such luck. Either I botched it, or the problem is something else.

StoneViper
21st Jan 2002, 01:14 PM
actually the older version of the map isn't even the right file anyway. i reuploaded the wrong file, so don't even bother with it anyway. I guess i forgot to save auto0.unr to another name, that is why i don't have a previous version of it.

Oh well, *sigh*, come to think of it. the map was turning into a map i was going to create after this one. i found out the flaws of it, and know how to make my next map better because of it. So i guess not all is lost.

I do appreciate everything everyone has done to help me with this. I will come back twice as strong! My mapping powers have strengthened! I aim for nothing less than Map of the Week!

Peace all, and thankx