PDA

View Full Version : Custom music looping?


DarMonkey
13th Dec 2001, 05:14 PM
I created some custom music and followed zynthetic's steps in this thread (http://forums.beyondunreal.com/showthread.php?s=&threadid=88620). I used ModPlug and followed the directions. The music works fine in the map play itself also, except that it only plays once, and fails to loop. How can I fix this? Also, is there a way to change the volume of the music in UnrealEd, or in ModPlug? Thanks for the help.

zynthetic
13th Dec 2001, 07:10 PM
there's an option (in MPTrack) in the general tab; a checkbox for looping. Make sure it's checked.
If it is checked and it still doesn't loop go to the last frame on the last pattern.
At the very bottom (of any track), put a position jump.
here's a pic (http://www.unrealtournament.org/forums/attachment.php?s=&postid=46888&fullpage=1)
set the Value to 00, so it reads B00. It should loop to the very first pattern in the song.
There's also a volume slider in the general section, try moving it up. To make it louder than that click on the samples section and amplify (there's a button for it) the sample(s) in incriments of 110% until your satisfied. Be carfull not to distort the samples by amplifying them too much though.

DarMonkey
13th Dec 2001, 11:55 PM
Thanks a lot! I'm going to try that right now. I really appreciate the help, and especially the quick reply. By the way, nice site. And good luck with your tracking.

DarMonkey
14th Dec 2001, 01:42 AM
Well, I fixed the volume problem, but still can't get the looping to work. I'm using ModPlug Tracker with the file in .it format. In the General tab I have the Loop Song box checked. I also added the B00 in both channels in the last row of the last pattern. I don't know what else I can do. I'd really appreciate the help if you have any more ideas. Making this custom music has caused the delay of the release of this map for over a week already. But I think it will be worth it if I can get it working. Thanks a lot!

DarMonkey
14th Dec 2001, 02:57 PM
Also zynthetic, I'd like whatever information you'd like included in my readme file. As in a URL or whatever info you'd like to appear there. You deserve the recognition for your help. Thanks.

zynthetic
17th Dec 2001, 04:31 PM
hmm...
/me stares at the screen.
How big is the file, what format are the samples in (be specific; ie: PCM wav), what format is the module in (.it, .s3m, ect).
I've had many problems with importing music before but I've never ran into this one. That other post was something that's been on my brainsince I've started tracking, I've never witnessed it though.
If it's <1.2mb send it to me and I'll take a look at it.

DarMonkey
17th Dec 2001, 11:46 PM
Thanks a lot. The instrument is a Windows PCM wav file that is 879KB. It says that there is two samples. One is 0bytes, and the other is the rest of the 879KB.The module file is in .it format and is 880KB. I have the beginning in the tracker looking exactly like you told people to do in the other thread.

In the tracker it reads:

Channel 1 Channel 2
C-5 01 . . T05 | C-5 01 . . A00 (First line of first pattern)
.
.
.
.
... . . . . B00 | ... . . . . B00 (Last line of last pattern)

Nothing in Channels 3 and 4. There are two patterns.

It has the box checked in the General tab for Loop Song. Still hasn't looped. The .it file is a total of 880KB. Here's a link (http://www.sit.wisc.edu/~eeolson2/Druid.it) to the file. If you want to take the time to look at it, I'd greatly appreciate it. If you have the time, I wanted the volume higher if it's possible without distortion if that is something you could do. I also would like whatever information you want in my readme file for your help. Be it your website, or links on mp3.com, or some of your work. Thanks a lot! I really appreciate it. If you need anything else from me, I added you on ICQ. Hope you don't mind. Thank you.

zynthetic
18th Dec 2001, 02:09 AM
Everything seems fine in ModPlug. Amplified the sample a bit but there was too much bass. Exported it into SoundForge, decreased the bass frequency a bit, increased the midbass and treble a little and reimported it. Added another note (a third lower volume) with a volume swell around the middle of the song.
In order for it to loop in unreal the sample itself needed to be looped too ( I did not know that:)).
all done (http://www.geocities.com/digitalwaste_unreal/druid-umx.zip) save target as... and in umx.

It's been a very long time since I've used icq, I tend to stick w/ irc. I may get it running again someday.
Dont worry about adding my name, I didn't do much;) If you want just add a thanks for the tutorial.
I guess it (the tutorial) covers everything now.
enjoy

DarMonkey
18th Dec 2001, 03:12 AM
Thanks a lot! I'm going to try it out right now.

And I don't care what you say! I'm putting you in the Readme. Sure, not too many people will probably see it, but that's better than nothing. Also, I would like some links to your stuff that I can put on a page I'm working on. Since you "didn't do so much," I can at least not do too much and give you the credit you deserve. Please at least humor me, and let me know what you want people to see about you. If you don't give me anything, I'll just have to link to whatever I can find. Every little bit can help getting your material noticed. Take advantage of that.

THANKS AGAIN!

DarMonkey
18th Dec 2001, 03:47 AM
It worked great! Now all I need to do is write the readme file and package it up. Thanks a lot! I really appreciate it. First trying to help me learn how, and then actually doing some of it. I'm really happy I came to BuF, and will keep coming back. Thanks zynthetic!

zynthetic
18th Dec 2001, 03:50 PM
well, you can link to the BUMS homepage when it gets put up:D
glad your happy with it.