PDA

View Full Version : MapVote3 Admin Tab


JimMonz
10th Dec 2001, 09:20 AM
I know this has been a problem since the beginning, but I need to mention it again.

I am now admin of a remote server, and do not have access to the PC. I tried changing some settings for MapVote3, via the admin tab, and lost ALL settings. At this point MapVote3 was useless.

I even tried setting each variable using the ADMIN SET command, but that didn't work either.

Is there something I'm doing wrong? Is there a fix for this? Any help would be appreciated.

Also, not MapVote related, has anyone changed the map rotation list remotely and have it saved. I changed it, it then displayed the correct changes, I restarted the current level, and my changes were gone. I also disconnected and reconnected and the changes were lost. This, I think, is a bug with the UT Remote admin interface.

JimMonz
10th Dec 2001, 01:37 PM
Ok,

The second part of the above message, having to do with the map rotation list, is not a problem with default UT gametypes. Where I run into problems is when I update A MultiCTF Gametype map rotation list. It won't update it.

If anyone has any ideas on how I can update a mod's map rotaion list, please post. TIA.

BDB
10th Dec 2001, 10:43 PM
I don't know why yours is not saving the changes.
It worked when I tested it.
What exactly are you doing/changing remotely and
how can you tell that the change is not saved.

Note: If you change the config on the Admin tab and
click the Save button and reload maps, then you
need to close the window and reopen it to get the new
map list.

JimMonz
11th Dec 2001, 08:17 AM
Steps taken:

1. Connect to server.
2. Open up console window.
3. adminlogin <password>. I am now admin.
4. Close console window.
5. Open MapVote3 window.
6. Click on admin tab.
7. Change anything (use maplist check), press save.
8. Close MapVote3 window.
9. Open MapVote3 window.
10. Click on admin tab, all settings are lost.
11. Restart level.
12. Open up console window.
13. adminlogin <password>. I am now admin.
14. Open MapVote3 window.
15. Click on admin tab, all settings are still lost.

This will also happen if I start a non-dedicated server and follow the same steps on my own PC.

JimMonz
11th Dec 2001, 09:15 AM
Sorry BDB,

I am trying to run a MultiCTF server and was having problems.

I have my normal installation of UT that I started a MultiCTF server from. This installation has lots of stuff downloaded, installed, etc. This is the version that is not working.

I installed a clean version of UT with bonuspacks, MultiCTF and MapVote3 and nothing else. This version seems to be working properly.

It is my problem, I have to figure out what is different between the 2 versions.

I might try to reinstall MapVote3 and see if it works properly then.

Sorry to bother you.