PDA

View Full Version : TOMapVote problem with TO 2.1


pAiN4joo
30th Oct 2001, 07:22 PM
ScriptLog: Base Mutator is TO-Forge.TO_DMMutator0

This does not seem like it belongs in my Server's log file (atleast I don't recall ever seeing that). For some reason after I installed TO 2.1 on my server it stopped working. All of my other mutators are working fine...it's just MapVote that is not working.

It looks as if it is not even loading the package, it will not run even under Debug mode. I have not change a thing from my previous installation. -- I will try to figure out why it is not working while I wait for your response.

NOTE: I used to the auto installer to install the patch (which I think is where I messed up)....maybe it is my batch file. I don't know...but I think the auto installer possibly changed some settings to incorrect ones.

Any idea why it would be doing this??


Let me know.

BDB
31st Oct 2001, 06:42 PM
I replied to this via Email. But I figured that I should post here also
for everyone else.

It looks like your problem is that it is not loading the MapVote mutator at all.
The log should look something like this:

ScriptLog: Base Mutator is TO-TrainStation.TO_DMMutator0
ScriptLog: Mutators TOMapVote100.TOMapVote <== These are missing from your log
ScriptLog: Add mutator TOMapVote100.TOMapVote <==
ScriptLog: Detected GameType = s_SWAT.s_SWATGame <==
ScriptLog: Total Maps = 11 <==
ScriptLog: UdpServerQuery(crt): Port 7778 successfully bound.

So, Recheck your .bat file that is used to start the server.
My guess is that the autoinstaller over wrote that file.
I should have something like this in it:

UCC.exe server TO-Monastery.unr?game=s_SWAT.s_SWATGame?mutator=TOMapVote100.TOMapVote INI=TacticalOps.ini USERINI=TOUser.ini -log=TacticalOpsServer.log

Also, You might as well remove the WebChatLog line from your ini.
It doesn't work with TO 2.1 and can't be fixed.
(Blame all the damn cheater's and spamming lamers out there)