PDA

View Full Version : Help Importing ??MESHMAP?? (Call me Erdrik::::DarkMagic


Call me Erdrik
18th Oct 2001, 02:29 AM
Ok I am a spell coder for the DarkMagic MOD.
I have been trying to import a new wings model for my 'AngelicWings' spell. I have a 8 bit .pcx, and have already converted the .3ds file to the .3d files....

My problem is in compiling the class..
This is what I have in the class:

//=============================================================================
// AngelWings.
//=============================================================================
class AngelWings expands Effects;

#exec MESH IMPORT MESH=AngelWings ANIVFILE=c:\UnrealTournament\wingstest\Models\AngelicWings_a.3d DATAFILE=c:\UnrealTournament\wingstest\Models\AngelicWings_d.3d X=0 Y=0 Z=0
#exec MESH ORIGIN MESH=AngelWings X=0 Y=00 Z=0

#exec OBJ LOAD FILE=c:\UnrealTournament\Textures\wingstest.utx PACKAGE=winstest.Effects

#exec MESH SEQUENCE MESH=AngelWings SEQ=All STARTFRAME=0 NUMFRAMES=41
#exec MESH SEQUENCE MESH=AngelWings SEQ=flying STARTFRAME=0 NUMFRAMES=41

#exec MESHMAP NEW MESHMAP=AngelWings MESH=AngelWings
#exec MESHMAP SCALE MESHMAP=AngelWings X=0 Y=0 Z=0

#exec MESHMAP SETTEXTURE MESHMAP=AngelWings NUM=1 TEXTURE=wingstest.Effects.AngelicWings


simulated function timer()
{
Playsound(Effectsound1);
}

simulated function PostBeginPlay()
{
loopanim('flying',0.3,0.3);
settimer(1.0,True);
}
defaultproperties
{
DrawType=DT_Mesh
Style=STY_Translucent
Mesh=LodMesh'wingstest.AngelWings'
DrawScale=1.200000
ScaleGlow=2.000000
bUnlit=True
}


everytime I compile it I get this warning:
C:\UNREALTOURNAMENT\wingstest\Class\AngelWings.uc<15> : ExecWarning, Missing meshmap
C:\UNREALTOURNAMENT\wingstest\Class\AngelWings.uc<17> : ExecWarning, Missing meshmap, texture, or num <MESHMAP=AngelicWings NUM=1 TEXTURE=wingstest.Effects.AngelicWings>

And when I go into UED I get the model but the texture isn't there and any texture I apply doesn't show....

Does anyone know what Im doing wrong?

Magus
18th Oct 2001, 02:46 PM
How about trying it this way:

//=============================================
// AngelWings.
//=============================================
class AngelWings expands Effects;

#exec MESH IMPORT MESH=AngelWings ANIVFILE=c:\UnrealTournament\wingstest\Models\AngelicWings_a.3d DATAFILE=c:\UnrealTournament\wingstest\Models\AngelicWings_d.3d X=0 Y=0 Z=0
#exec MESH ORIGIN MESH=AngelWings X=0 Y=0 Z=0

#exec MESHMAP NEW MESHMAP=AngelWings MESH=AngelWings
#exec MESHMAP SCALE MESHMAP=AngelWings X=0 Y=0 Z=0

#exec OBJ LOAD FILE=c:\UnrealTournament\Textures\wingstest.utx PACKAGE=winstest.Effects

#exec MESH SEQUENCE MESH=AngelWings SEQ=All STARTFRAME=0 NUMFRAMES=41
#exec MESH SEQUENCE MESH=AngelWings SEQ=flying STARTFRAME=0 NUMFRAMES=41

#exec MESHMAP SETTEXTURE MESHMAP=AngelWings NUM=0 TEXTURE=wingstest.Effects.AngelicWings

Call me Erdrik
19th Oct 2001, 03:00 AM
that got rid of the first error but I still get this one :p

C:\UNREALTOURNAMENT\wingstest\Class\AngelWings.uc<17> : ExecWarning, Missing meshmap, texture, or num <MESHMAP=AngelicWings NUM=0 TEXTURE=wingstest.Effects.AngelicWings>

Sheesh I go to the WOD forums and Magus answers :D lol
I could have just asked in the team forums huh Magus ;) ?

Ah Well......

Bytekeeper
21st Oct 2001, 05:43 PM
Hmm, you really want to scale the meshmap to 0,0,0 ?

Did you test the texture to work for another actor ie. ?

Call me Erdrik
22nd Oct 2001, 02:57 AM
Im not exactly sure what MESHMAP is :p Ill mess with the Scale and see what happens,

I changed it to 1,1,1

but still get the same error

I think its just not finding the texture so Im going to double check it....

Kangus
22nd Oct 2001, 09:38 AM
Originally posted by Call me Erdrik
Sheesh I go to the WOD forums and Magus answers :D lol
I asked my modeler to take a look at the question..... guess he never did.... go fig.

Bytekeeper
23rd Oct 2001, 04:58 PM
Uhm originally I had a problem too but it was a typoe which made mesh and meshmap names differ.

Call me Erdrik
2nd Nov 2001, 02:34 AM
OK I got it to Compile properly :D

BUUT....

I plastered it to a DarkMagic spell, and when cast it loads the model and skin, but the Model has missing Polys?!? and it won't animate, even tho the code calls for the 'Flying' animation.....