PDA

View Full Version : Logitech MouseWheel won't work....WHY?!?!


JustForFun
3rd Dec 1999, 05:53 PM
Hello,

I am having problems getting my mousewheel to work/be recognized when I am playingthis INCREDIBLE game. I haven't had this problem before and up until now I have used version 8.4 of Logitech's MouseWare drivers. I have always used the MouseWheel to switch between weapons and all my games had wheel functionality.

However, I just updated to Logitech's latest version of Mouseware, version 8.62, at the suggestion of some people on this board, and I have now lost ALL use of my mousewheel while playing video games (Half-Life, Kingpin, Unreal Tournament, etc.)

I also downloaded and ran the registry patch, GAME_WHL.EXE and it still didn't fix the problem. I also looked in my registry and the value the registry patch is supposed to change("MouseHookDLLEnable") is set to "0" as it is supposed to be after the patch.

I have also unsinstalled the drivers completely and reinstalled them again, with and without the registry patch, and still can't get the wheel to work in my games properly. What am I doing wrong here?? This is really driving me nuts, being as I "really" rely on using the mousewheel to switch between my weapons while playing my video games. /~unreal/ubb/html/smile.gif

Please help me!!!!! I don't really know what else to do here. It "should" work just fine...but it doesn't. /~unreal/ubb/html/frown.gif Just so you know, otherwise it seems the drivers work flawlessly, and I really like the webwheel feaure.

Anybody got any ideas???

Randy

[This message has been edited by JustForFun (edited 12-03-1999).]

JustForFun
3rd Dec 1999, 06:50 PM
WOW...messages sure do get buried here FAST! heheeh... Anyway, I wanted to move this back up top. Thanks again.

JFF

lipton
3rd Dec 1999, 07:13 PM
hmm does that mean that you solved the problem? .. if not look a little further on the planet unreal and this forum i think /. on one of them is a similar post ... well it's the same post ..adn it has the answer for your problem .. BUT if you dont want to actually LOOK for it .. go to logitechs website .. tyey ahve a fix called gaemwheel or something .. anyway it's pretty aparent what it is when you see it ./..
/~unreal/ubb/html/smile.gif

JustForFun
3rd Dec 1999, 09:16 PM
LIpton,

NO...I have NOT solved this problem. What gave you that idea?? Anyway, if you reread my original post, you will see that I DID try the reg patch from Logitech called "GAME_WHL.EXE" The reason I found out about it in the first place is because before I ever posted MY message I DID go back approx 10 pages or so and read ALL the messages related to this issue. If you will look, I state that
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR>I just updated to Logitech's latest version of Mouseware, version 8.62, at the suggestion of some people on this board<HR></BLOCKQUOTE>

My point is that NONE of these "fixes" have helped me. I have fired an email off to Logitech. We will see if they can help, but I'm sceptical.

One more thing. I did some additional testing and reinstalled the "original" Logitech driver that came with the mouse...v.8.3. And guess what??....yep they WORK!!!! I can switch weapons with my wheel using that driver....but NOT using the updated versions of 8.4 and 8.62. I dunno....it's weird. Logitech has switched up sumthin and fixed what ain't broke. /~unreal/ubb/html/frown.gif

JFF

LaughinA$$a$$in
3rd Dec 1999, 10:50 PM
In the Logitech mouse properties, under the Buttons tab, make sure the "Use Office 97 Compatible Scroll" is UNchecked. I have the same mouse with the 8.62 drivers - works fine for me. If it still doesn't work, post here, and we'll compare settings. Hope this helps....

-LA

Ritz
3rd Dec 1999, 11:24 PM
It may be your wheel settings under the logitech mouse panel, try setting it to 'scroll bar (vertical' with 3 line scroll, works for me.

[This message has been edited by Ritz (edited 12-03-1999).]

dolce916
3rd Dec 1999, 11:38 PM
ditto what laughin and ritz said...I have the corless wheel mouse and it worked perfect in the demo ..nothin in the full...UT is the only game I allow myself time for besides NFS3 (have steering wheel for that) so I don't know about the prob on other games..but check this to
MAKE SURE DIRECT INPUT is selected in the prefs-input tab I am not 100% sure..but I think that is what fixed it for me..I too have the latest drivers from Log...had them the night before I installed UT ..also that webwheel feature they added crashed UT on me when I clicked the button..Good luck

http://www.planetunreal.com/images/bullet2.gif
The more I learn...the more I realize I don't know $#!%

JustForFun
4th Dec 1999, 12:11 AM
LaughinA$$a$$in
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR>"Use Office 97 Compatible Scroll" is UNchecked.<HR></BLOCKQUOTE>
Already set up that way...and BTW..I also tried it with that box checked..still no go.

Ritz
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR>wheel settings under the logitech mouse panel, try setting it to 'scroll bar (vertical' with 3 line scroll, works for me.<HR></BLOCKQUOTE>
Do you mean in the option box beside the checkbox for "Office 97 Scroll" ???? If so, I will try, although as I said...that Office 97 bx isn't checked and doesn't seem to make a difference even if it is. BUT if you are talking about the Button assigment, then NO..I don't have it set for scroll. I NEVER have and it has worked fine with the older versions. I always assign the wheel button (not the wheel itself) to act as a "middle button". I use it to Reload in Half-life, and Kingpin. The wheel "button" assignment is differnt than the wheel scroll feature.

dolce916
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR>MAKE SURE DIRECT INPUT is selected in the prefs-input tab<HR></BLOCKQUOTE>
NO WAY, man! I saw your earlier posts and i did try checking that option in the UT menu. BOY!...it really made my game go NUTS!!! What it did was make it so that every time I moved my mouse...my weapons would switch and cycle through!! So, if I were to move around a map, my weapon would be changing every friggin second....and I couldn't contol it...nor could I fire the weapon, because it was always changing. And the wheel was still disabled. I then deselected Direct Input and at least my movement was back to normal..but still the wheel was inoperable.

Anyway guys, thanks for all your suggestions, but I can see over at http://www.gamersx.com/messages/overview.asp?board_id=8727 that this is DEFINATELY a common problem and besides what some people think, the 8.62 version with the registry hack DOES NOT work for everyone for whatever reason.

The only way I can find to get my mouse back to functioning in ALL of my FPS games is to simply reinstall the "original" outta the box drivers, version 8.3. I KNOW they work, because they did for over a year. But the new 8.62 drivers and maybe the last update, 8.4, do not seem fully compatible for some reason. Thanks again.

JFF

dolce916
4th Dec 1999, 01:44 AM
Well JFF hmm..you have me stumped..to tell you the truth the whole Logitech prob stumped me..because I am not sure exactly what fixed mine...direct input on my system improved things for me...obviously there IS a prob with the Logitech's use of the wheel in the game...but what I am seeing on here so far is that the effects of the prob are varying to some extent dependent on system...???? Sorry I couldn't help you..only last suggestion I might offer is to force the wheel settings via advanced options...but like I said I am not sure whick changes worked (I tried alot) Good Luck to you JFF

http://www.planetunreal.com/images/bullet2.gif
The more I learn...the more I realize I don't know $#!%

ghostgeek
4th Dec 1999, 03:21 AM
click the button tab and set(or bind) the middle button to "middle button"
you should be good to go...i use a logitech trackman marblr with no wheel..."old school"


/~unreal/ubb/html/smile.gif

JustForFun
4th Dec 1999, 03:43 AM
ghostgeek
You related to lipton by any chance??? The following is a quote from my post just "2 posts" before yours:
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR> I always assign the wheel button (not the wheel itself) to act as a "middle button"<HR></BLOCKQUOTE>

DOH! Been there, done that. But thanks. /~unreal/ubb/html/smile.gif

JFF

[This message has been edited by JustForFun (edited 12-04-1999).]

[This message has been edited by JustForFun (edited 12-04-1999).]

marco
4th Dec 1999, 12:57 PM
This may or may not help.
I had the same problem with Q3A,
So I installed the 8.20 version of
logitech's mouseware. You can find it
here http://buzzkill.stomped.com/
There may also be more help on this as well
at this site.
Best of luck!
Marco

LaughinA$$a$$in
4th Dec 1999, 06:30 PM
Not sure if it means anything, but I can enable direct input in advanced options with no problem. Have you checked your DX7 install with DXdiag?

-LA

JustForFun
5th Dec 1999, 02:37 AM
LaughinA$$a$$in
Hmmmmmmm....maybe you are onto something here? At your suggestion I did run DxDiag and checked under the "Direct Input" Tab. What it said was this:
<BLOCKQUOTE><font size="1" face="Tahoma, Arial, Helvetica">quote:</font><HR>
No input devices detected
No Problems Found<HR></BLOCKQUOTE>

Well, I like that it says "no problems", but is it "supposed" to say that no input devices are detected?? I don't have a joystick or gamepad on my rig, but should it show the mouse??? I'm not sure what is supposed to show there? What does everyone else's say under this tab? Does it show your mouse?

Anyway, I reinstalled DirectX 7 and it still says the same thing.

Finally, another thing I have suspicions about concerns a file called "gchand.dll". Follow me here. When I went from DirectX 6.1 to DirectX 7.0, I discovered that it stranded a registry key, which looked for the file "gchand.dll". I discovered this by running Norton's Windoctor. It basically said that the registry was looking for this file and that it "no longer existed".. I searched my drive, and yep, it wasn't there. A quick search of Microsoft's Knowledge Base discovered that this file has something to do with Direct X and Direct Input!!! In fact , it is one of the files that comes in the DirectX install. I guess however, that DirectX 7.0 doesn't use it anymore, and deleted it, but left the registry key? I did manage to extract the file from my Win95 CD, and replaced it into my Windows/System folder to see if it would affect anything. Didn't change anything it seems, BUT DxDiag does now say that this file is "an old file" and to run DirectX 7.0 to update it.

However, when I run DirectX 7.0, it doesn't update it, it just removes the old file, leaves the registry key, and now, again, I don't have the file "gchand.dll" on my hard drive!!

So, would someone out there please be kind enough to check a few things for me???

If you have DirectX 7.0 installed, see if you have the file "gchand.dll" installed and, if so, post here telling me it's properties(size,creation date, etc.)

Also, could you also check to see if under your "Direct Input" tab in DirectXDiag if it says that it detects a mouse or not.

I know it sounds weird when I said that checking "Direct Input" in UT's Options page made my game wig out, but it is true. It was like the mouse roller or ball, controlled the weapon changing. So you can imagine what it was like when ever I moved the mouse.

Anyway, I think I may be onto something here, and ANY and ALL help so forth and to come is much appreciated. Thanks guys.

JFF

LaughinA$$a$$in
5th Dec 1999, 11:02 PM
I don't have the gchand.dll, although there are 5 references to it in my win98 registry.

I also do not have an entry for my mouse in DXdiag Input.

Interestingly enough, the only reason I upgraded to the 8.62 Logitech drivers was that every so often when playing any game from solitaire to UT, the mouse cursor would go nuts and start jumping around the screen and even "clicking" on icons or resizing the toolbar. When I upgraded to ver 8.62 this problem was finally cured. I have heard that others have had success fixing various Logitech/UT problems by going back to Ver 8.2.

-LA

Gargos
6th Dec 1999, 03:28 AM
As mentioned earlier, your problem definitely sounds like a DirectInput problem. I had the same with my Intellimouse Explorer (Friggin long name). If DirectInput was enabled in the game, the mousewheel and the wheel's button no longer worked. Once I unchecked it, it was fixed.