PDA

View Full Version : Sniper rifle zoom problem ?!?


Stryker
21st Jul 1999, 12:00 PM
I have the 2.1 patch and it ROCKS! But the Sniper rifle will not "un-zoom" unless I fire it first. Is this a glitch or is it supposed to be this way?

Warren
21st Jul 1999, 06:53 PM
I think I'll need a more indepth explanation on this one. Which game modes does it occur in? Is your aim style Hold or Toggle? Does it occur for you all the time?

Stryker
22nd Jul 1999, 09:26 AM
Here it goes...
When I use the sniper rifle zoom funtion it zooms all the way in like it is supposed to. It works if I just click the button once or if I hold it down. If I want to un-zoom, I have to shoot the rifle first. Clicking the button again or releasing the button does not take the zoom off. I am not sure what you mean by aim style though. I am doing this in the INF deathmatch game type.

Stryker
23rd Jul 1999, 09:11 AM
New update... It is working correctly at home now but my other PC still does not let go of the zoom. I dont know what I did differently.

SchizoidMan
23rd Jul 1999, 10:25 AM
Stryker: I noticed this too.

It's all about the AIM Style, as Warren says.

In the game, press esc, select go to main menu, and select options.

The second item from the bottom is "Aim Style".

If it's hold you'll get the behavoir you first mentioned.

If it's toggle, it'll un-zoom when you press alt-fire again, without having to fire at all.

Stryker
23rd Jul 1999, 10:57 AM
Cool! That seems to have worked. I had to start a Classic game to get to that menu though. Is it supposed to show up in Deathmatch? I also noticed that if I set keys for reload, weapon mode, etc. They dont stay set. Is that normal?

Warren
23rd Jul 1999, 12:06 PM
Glad that worked for you- thanks SchizoidMan.. In DM mode the aim style and reloading style will always be set to hold and autoreload respectively. This was set so we could allow our weapons to be summoned on any level and still work ok. We didn't spend a great amount of time trying to get it to work with your settings for all three game modes thus you see version 2.1 out 2 days after 2.0.. This is of course in our list of things to fix.

Stryker
23rd Jul 1999, 01:05 PM
It stopped working again!!! It only seems to work if I run the game server on the same machine I am playing on. If I run the game from my normal game server on the lan it does not let me release the zoom without firing.