PDA

View Full Version : Help please


Shaka
1st Mar 2000, 08:18 PM
Hello,

I'm new to making levels and I'm having bot problems. I've worked on my map for a week now, and even though it's idiotically simple, the bots don't work well. I originally designed the map so my friends and I could play some trench warfare, so please keep that in mind. If someone could fix my map for me, I'd be most appreciative. thanks.


Here's the link to my file:
http://members.home.com/c4militia/Downloads/CTF-Wack.unr

Chand
1st Mar 2000, 08:40 PM
I'd download and fix it but I'm working in another map...

Though I'm no expert,

*) Make sure all the pathnodes can be seen from one another (ex, if you're plotting the pathnodes 1-2-3, from 1 you must be able to see 2, from 2, 3 ... etc.)
*) Don't plot the pathnodes too far away (700 units max, 350 on ramps/stairs)
*) Leave some space between each pathnode and geometry/objects (if possible =>50 units)
*) Don't set the pathnodes very high relative to the walking surface (< 1.5x bot height...otherwise they won't see it)
*) And finally, the problem areas with pathnodes are some tight/narrow corners, navigation around objects and ramps/stairs...

Following these guidelines made my life so much easier when pathnoding (is that a word ?) my map... I only had to set them right and make minor corrections 2 or 3 times after that.

Hope it helps...

------------------
This is your brain...
THIS IS YOUR BRAIN ON INF... (bold /infopop/emoticons/icon_smile.gif)

Shaka
1st Mar 2000, 08:49 PM
I've tried the tips you've listed and the tips on many tutorials. One person told me that my trenches were the problem, but that would mean that the concept of trench war would have to removed.

Don't let my map interfere with your plans. I'm just hoping someone has free time to fix my map. Thanks.

[This message has been edited by Shaka (edited 03-01-2000).]