PDA

View Full Version : Strange problem with UnrealEd


PyZ
3rd Dec 1999, 04:50 AM
When I install Unreal without any patches it works great, but when I put a 225f patch into unreal game I get a critical error.
Is it a problem with patch or with my W98 configuration.
Does anybody work with UED on unreal 225f ???

Please HELP !!!!

PyZ

NutWrench
3rd Dec 1999, 05:44 AM
Hi PyZ,
I'm using the 225f patch of UnrealEd and I'm not having any problems with it. You might want to try downloading the RichText fix and the Visual Basic fix from www.dukeed.com (http://www.dukeed.com) in the files section. If UnrealEd still gives you problems, you'll need to download the UnrealEd experimental patch #4 (around 3-4 megs) which is a much more thorough patch.

--Nut

PyZ
3rd Dec 1999, 06:14 AM
Thanks,
but I installed every fixes and patches for UED and nothing /~unreal/ubb/html/frown.gif ... except Experimental Patch 4 ,but I don't have an address of this file.
I can't get to unreal.epicgames.com so I need other addresses on Internet.

PyZ

NutWrench
3rd Dec 1999, 08:59 AM
Hi PyZ,
The experimental patch is also available at www.dukeed.com (http://www.dukeed.com) in the files section.

If that doesn't work, here's one other thing you can try. Try editing your shortcut to UnrealEd and adding
-nosound (including the dash) to the end of the path. This has worked for other people. If that fixes it, then you may need to download the latest drivers for your soundcard and/or DirectX.

The error message on the pop-up window, usually gives some kind of clue as to what is causing the editor to crap out. In your Unreal/System directory there are two text log files (UNREAL.log and Editor.log) which list everything that happens while the game and editor are are loading and running. These can be a big help in determining what's causing the problem. Good luck! /~unreal/ubb/html/smile.gif

--Nut

[This message has been edited by NutWrench (edited 12-03-1999).]

PyZ
3rd Dec 1999, 03:11 PM
Hurrra!!
Thanks a lot!
I wrote a -nosound and it's working /~unreal/ubb/html/smile.gif
Maybe I should really put some newer drivers for my Vortex 1 sound card ...

Once again - thank you.

PyZ

Wanderer
3rd Dec 1999, 04:30 PM
Actually guys, make that -nodsound (note the "d" in there). This way you've still got sound and the editor will run.

NutWrench
3rd Dec 1999, 06:57 PM
Cool. Does the 'd' stand for DirectSound?

--Nut

Wanderer
3rd Dec 1999, 08:50 PM
I'm gonna say yes on that /~unreal/ubb/html/smile.gif

WiwiJumbo
4th Dec 1999, 12:16 AM
I'm willing to bet that the d is for DirectSound cause if you turn off DirectSound under Unreal the Editor will load up fine... The last time I tried to investigate the error it *seemed* to have something to do with DirectSound and Unreal loading up the OpenGL driver (Even tho I use glide...) Can't remember how I came to this tho... it's been a while...

Wiwi

http://www.planetunreal.com/images/bullet2.gif
"I trust in my abilities, but I want more then they offer"

Wanderer
4th Dec 1999, 08:42 AM
Oh the D is definitely for DirectSound, why do you think it's one of the command line switches listed at Epic's Unreal Tech site?

As for the problem with UnrealEd. Well apparently it's mostly Epic's fault and they've admitted to it. I guess it worked for the sound cards they had but not the others. And it's strictly a DirectSound issue not a combination of Opengl and DirectSound.

The solution to getting UED to work with sound was found by someone else. They disabled DirectSound for the entire system. I just went a step further by letting you keep DirectSound for everything else and just disabling it for UED.

sykobob
1st May 2000, 12:26 AM
woohoo turning off direct sound does work!!