PDA

View Full Version : Weird *** General Protection Fault! Help!


JF
14th Nov 1999, 02:57 AM
Can someone help me?? This is the error I get when I start up UnrealED:
General protection fault!
History: UEditorEngine::FinishAllSnaps <- UEditorEngine::Exec <- (MAP GRID X=16 Y=166 Z=16 BASE=ABSOLUTE SHOW2D=ON SHOW3D=OFF) <- WM_USER_EXEC <- VbWindowProc <- glxDetectOutput <- UGalaxyAudioSubsystem::Init <- UEngine::Init <-UEditorEngine::InitEditor <-UEditorEngine::Init <-InitEngine

Any ideas??????

Bishop
14th Nov 1999, 06:14 AM
I had the same problem ages ago. I believe your best bet is to do as follows:
1.Create an Unreal editor shortcut on your desktop(If you havent already).
2.Right click on the Unreal editor icon
3.Select properties
4.Under "target" write this line of code-
C:\Unreal\System\UnealEd.exe -nosound
5.Be sure that theres a space between "exe" and "-" or it wont let you edit the target.

The only downside to this fix is that it doesnt allow you to hear the audio you place within the game while editing.
Hope that does the trick.

Wanderer
14th Nov 1999, 09:31 AM
Use -nodsound instead. This is a better fix as it allows you to still be able to hear the sounds from within UnrealEd.

JF
14th Nov 1999, 01:22 PM
Woohoo! I tried the -nodsound and it worked! Thanks! What exactly does that do though? Just curious.

Wanderer
14th Nov 1999, 02:14 PM
-nosound
Disables sound altogether.

-nodsound
Disables DirectSound forcing Windows to use a software sound rasterizer. Eats some more CPU usage but is generally the most stable.

JF
14th Nov 1999, 02:32 PM
Thanks for the help! I have a good CPU so I'm not too worried about it. /~unreal/ubb/html/smile.gif

Bishop
14th Nov 1999, 06:19 PM
Cool!
I was really getting annoyed not being able to hear.Double thanx!

PTQ
3rd Apr 2000, 10:04 PM
I know this is old news, but I just began getting the same general protection fault. I could only trace it back to when I installed the new V3 drivers and LiveWare 3.0. I uninstalled the new V3 drivers and Unreal and wiped out the Unreal folder. I then reinstalled the older V3 drivers and reinstalled Unreal with the 225 patch, and I still had the same problem. I suspect the 225 patch does not work well with the LiveWare 3.0 drivers. By the way I do not get the fault when I used older Unreal patches such as 219.

OK

Jenkins
3rd Apr 2000, 11:08 PM
PTQ, sounds like a conflict between those components. Try installing one at a time and see if it works.

http://www.planetunreal.com/images/bullet2.gif
Jenkins

PTQ
5th Apr 2000, 11:26 AM
I went to my other computer to run unrealed which I have not done in a while just to see if the machine displays the same fault. It sure does. This other computer is using a V2 card and a generic 3D soundblaster compatible sound card. So apparently the fault has nothing to do with the cards. The only other common thing that has been installed on both systems are the DirectX and Win98 updates. I also added -nodsound to both systems and now it works. I am just wondering if the most recent DirectX from MS is having a conflict with patch225. Four systems have experienced this problem in this thread, so there is a definite problem with directsound.

Wanderer
5th Apr 2000, 01:28 PM
Actually it was an incompatiblity problem between UnrealEd and damn near every sound card driver out there. The problem was fixed though afterwards but they just never released a patch for Unreal and moved on through to UT.