PDA

View Full Version : Help setting LAN tab as default in Browser


dylan
9th Apr 2001, 06:55 AM
Hi all,

Is there some way to set the default tab in the infiltration browser window (for finding mutiplayer games) to the LAN tab instead of the news tab, because i have a weird internet and it won't let me connect to any internet games and just locks up if it tries to find news, however it still works on LAN, however i cannot get to the lan tab cause it is set to news and then it locks up. I know i can do lan cause i can host, just not join yet. Any suggestions on setting default to LAN?

Thanks heaps.

Dylan

EL_Kabong
10th Apr 2001, 06:54 AM
I dont think you should be locking up from the news tab unless you're running an firewall such as ZoneAlarm, in which case you'll have to put UT into a window before you go to the server browser, so you can check the box that ask if you want to allow INF.exe to access the internet, then set it back to full screen.

to answer your question about making the lan tab the default tab, I dont think its possible from within the ini's but if you are still having trouble, there is a way to connect to your server directly without starting UT, but because the app starts up normal UT instead of INF, I figured out a work around and tested it myself. but it requires file switching and renaming if you play both UT and INF, its easy and shouldnt be a problem as long as you back up the files.

1) download this app which will directly connect you to a server without the need to startup UT or use its GUI, its called "utip", you just type in your server ip then it puts you directly into the game:

http://www.fileleech.com/?skin=8&file=1553

just make sure the file is put into the UT system folder or you'll get an error when putting in the ip

2)make a backup folder and copy and paste these 4 files to the backup folder:

A)UnrealTournament.ini
B)User.ini
C)Infiltration.ini
D)InfiltrationUser.ini

3)after you backup the 4 files to the backup folder, you then need to delete UnrealTournament.ini and User.ini from the UT system folder, rename Infiltration.ini to UnrealTournament.ini, then rename InfiltrationUser.ini to user.ini

4) startup utip, put in your lan ip then have fun :)

its really just a matter of renaming the 2 files, so its pretty simple to do and should be no problems are long as you backup the ini's, when you want to go back to UT, just copy and paste the 2 UT ini's in the backup folder to the UT system folder.
dont do any of this to the server, its only for the client machine

dylan
10th Apr 2001, 08:28 AM
Thanks for the advise but i forgot to mention i am using a mac. :(

I am behind a firewall proxy thing i think and the server is set up so that i am not allowed to connect to any external games servers, (cause they don't want people playing games on our server), so i can't connect to any ut games or anyone type of game, and i think it is trying to get to the ut news but cannot connect so it just locks up.

Is there some sort of app like gameranger or gamespy that i can use for connecting mac and pc that supports inf, cause i would be able to use that with no probs.

Anyway thanks but i am still stuck.

Dylan

EL_Kabong
10th Apr 2001, 01:33 PM
hehe, you could of saved me a lot of typing and bad spelling if you said you were on a mac. I thought about gamespy afterwards, but to be honest I havent used it in about a year and a half, but I think the same could be done as long as Infilitration.exe is used in the configuration or by renaming the ini's as I did above, but I dont have a clue if gamespy works for macs or what apps are used, so i'm going pass this on to a mac guy for you, he may be busy and not answer your questions for awhile, but i'm sure he'll help when he can.

but to any others reading this post, that utip app should work great with the niffty INF server page Daddybone made, but only if you dont switch back and fourth from UT and INF

http://www.sobservers.com/serverstat/servers.html

SF_Darkness
13th Apr 2001, 11:01 PM
Go into your Infiltration.ini and change the [UBrowser.UBrowserHTTPClient] to the following...

[UBrowser.UBrowserHTTPClient]
ProxyServerAddress=127.0.0.1
ProxyServerPort=80

This will point the browser to your own computer which should have no web services so the News tab will load nothing...then just click on the LAN servers tab....if you want LAN servers to be the only Game type listed then change [UBrowser.UBrowserMainClientWindow] to the following...

[UBrowser.UBrowserMainClientWindow]
LANTabName=UBrowserLAN
ServerListNames[0]=UBrowserLAN
ServerListNames[1]=None
ServerListNames[2]=None
ServerListNames[3]=None
ServerListNames[4]=None
ServerListNames[5]=None
ServerListNames[6]=None
ServerListNames[7]=None
ServerListNames[8]=None
ServerListNames[9]=None
ServerListNames[10]=None
ServerListNames[11]=None
ServerListNames[12]=None
etc...

All you will see is News,Chat,Favorites, and LAN.


And who stole my name?...sucks to be me....lol

EL_Kabong
14th Apr 2001, 12:24 AM
You the man darkness :)
thx for not letting down an old comrade!

dylan
14th Apr 2001, 09:41 PM
Thankyou, soooo much, I am very happy now see :) :) :)

Thanks heaps, it works heaps good for the LAN tab now, I can actually get to it and join games, and i don't know whether it was that local server address thingy or me setting my proxy correct but now (since i left the rest of the tabs on) can actually browse and join internet games, which i couldn't before. Thanks again, INF ROCKS ONLINE!!!

ok anyway

bye

Dylan aka Knight_Owl