PDA

View Full Version : Can't get YnrealEd to work


G-Man
12th Mar 2000, 02:06 AM
I'm just starting to get into this level design thing thanks to a little inspiration by PC Gamer. Unfortunately I can't seem to get UnrealEd to work. I first tried to instal it, however during the installation I was notified that there was already a copy installed (I guess it got installed when I installed unreal tournament in the first place). I canceled the installation, but I might have copied over some files inadvertently, even after it said if you continue there might be problems in removing the installation if you continue, I can't remeber how persistent I was at installing the program. Well like I said I quite the installation and then tried to start UnrealEd, but I got the "This program has performed a fatal error..." message. So I rebooted my machine tried again and got the same message. I then uninstalled unreal tournament and then reinstalled it. Tried unrealed and got the same classic error message (I think in twenty years time I'll look back at windows nintey eight and remember it by that error message!). I then tried to install a second copy of unrealed into a different directory and the same problem. Any suggestions? actually maybe I could try the EXTRAS disc and see if I can install unrealed from that disc... I'll try that but any other sugeetions would be appreciated.

Thanks,
The G-Man.

Da_Mack-aroni
12th Mar 2000, 02:30 AM
Well, G-man, it goes like this...

First, you have installed it, so that is cool.
Second, on the second cd, there is an UnrealEdFix4, or something like that. It is an experimental fix for UnrealEd. Install that to your UT folder.
Third, you need the latest version of Visual Basic. I am at 6.0, but I believe 5.0 works also. I think you can get that from MicroSoft.
Fourth, there is a RichText fix. You should be able to get that from http://www.planetunreal.com/files/
You can get VBasic5.0 from there, as well.
No, I had problems before, even with all of those. Now, for some reason, I reinstalled UT and it is patched to 405b, I thought it was conflicting with the new patch, anyway, and UnrealEd works fine. I didnt even need to use the UnrealEd Fix. Go figure.
Hope this helps ya, G-man.

Later




http://www.planetunreal.com/images/bullet2.gif
Da_Mack-aroni
Fear the wrath of my noodles!!!

G-Man
12th Mar 2000, 02:52 AM
Thanks for the tips, I'll try them tomorrow. If I stay up any later I think my head would explode.

I actually just tried installing the second CD and running the UnrealEd again after it was installed and I got the same error. I didn't however look for that specific file you mentioned. I already have VB 6.0, comes with excel, infact I have a lot of experience with VB so if UnrealEd uses it at all I've got a bit of a head start!

Hopefully I'll be able to start letting my imagination fly with unrealed soon!

I'll be back if I need more help!

Ciao,

G-Man.

Wanderer
12th Mar 2000, 09:22 AM
You guys do realize that the UnrealEdFix4 and the UnrealEdInstaller are the same files don't you? Anyways...

There's a setup.exe on the 2nd CD, run that. Uncheck hi-res textures and continue. Now install UnrealEd and make sure it goes into the C:\UnrealTournament folder (or appropriate drive). Now give it a shot.

Da_Mack-aroni
12th Mar 2000, 11:43 AM
Well, Wanderer

I am sure you are getting tired of us new people asking for help getting UEd to work but thanks for continuing to help. It has been working fine for me. Now I just need to go over the tutorials that you have suggested so I can start workin on it.

See ya



http://www.planetunreal.com/images/bullet2.gif
Da_Mack-aroni
Fear the wrath of my noodles!!!

G-Man
12th Mar 2000, 11:56 AM
Alright, I tried the UnrealEdIntstaller on the second disc but I still got the "This program has performed an illegal operation, Should it continue contact the program venfor" message when I ran unrealed. Where am I supposed to put the Riched32.dll and Rochtx32.ocx files?

The G-man

G-Man
12th Mar 2000, 12:28 PM
Ok, I found out where to put the Richtxt files, WIN98/SYSTEM folder, I hope it's that one and not the SYSTM32 folder! I installed vbrun50, although I'm not sure this will do anything because
a) I have VB 6.0
b) I installed it in it's default location because I didn't know where else to put it.

I'm presently in the process of downloading Patch 2.19 BETA and I'll see if this helps at all. I presently have 2.25b installed and there appear to be mixed reactions to it conflicting with the editor. Am I on the right track?

G-Man

G-Man
12th Mar 2000, 12:32 PM
I just notice that 2.19 was for unreal and not unreal tournamnet so I'm going to try 405b and 402.

Wanderer
12th Mar 2000, 08:21 PM
G-Man: Hmm.. you weren't quite listening. The 2nd CD's there's a setup.exe file there. Run that and uncheck the hi-res textures and continue. Then install UnrealEd.

G-Man
13th Mar 2000, 09:09 AM
Hi Wanderer,
I Actually didn't explain myself properly because I did try that.

In fact just now, I got fed up with it all and unistalled everything and tried again from scratch, still the same problem.
1) I installed Unreal Tournament to D:Unreal Tournament.
2) Inserted second disc, used explorer to find the setup.exe which is in the main F:/.
3) Ran setup.exe, unclicked high res textures and installed to D:/Unreal Tournament.
4) Then found UnrealEdInstaller on the second CD and in F:/UnrealEd folder and installed that to C:/Unreal (default), because it interupts installation if I try to install it to D:/Unreal Tournament

Could that be the problem? UnrealEd is already installed when you install the first CD and it should be unistalled first before the (the supposed FIXED copy) UnrealEd from the second CD is installed. I looked in Add/Remove programs on the control pannel and couldn't see UnrealEd so I wouldn't know how to unistall it if that was the problem though.

I'm still trying guys, please bear with me. Anyone feeling like flying to Montreal to help me out?!

G-man.

Wanderer
13th Mar 2000, 08:24 PM
No problem the mistake was you're supposed to let it overwrite the file in that the main UT folder.

G-Man
13th Mar 2000, 09:43 PM
alright, here's the latest in my quest to get UnrealEd to work and wanderer your patience is much appreciated.

I tried to install UnrealEd from the second disc into the UnrealTournament folder, when it asked if I wanted to replace an existing file I said yes, it promptly came up with a few error messages which I quickly dissmissed (you know how it is...) I did notice that it was UnrealEd.exe that it stopped on. SO, I went into the sytem sub folder in UnrealTournament main folder and deleted UnrealEd.exe. I then reran unrealedinstaller and the installation was completed succesfully. WAHOO!

HOWEVER, when unrealed is run I still get the same error message as always. I'm going to look back and make sure I've got the other files are in the right spots, and I'm going to do some more searching on the unreal editing sites to see if I can see anymore info. Thanks again wanderer, sounds like you have been through this all before with other people and it's starting up again with someone new I noticed aswell. Hey, maybe I could buy you a beer sometime !

ciao,
G-Man

G-Man
14th Mar 2000, 01:00 AM
NOW I CAN'T EVEN START UNREAL TOURNAMENT, UPON CLICKING THE ICON IT SAYS IT CANNOT FIND REQUIRED WINDOW.DLL FILE!!!! I NEED MY FIX!!!! DOH!

G-Man
14th Mar 2000, 01:39 AM
Solved the .dll problem, had my exe in the wrong folder, still messing to get ed going....

Da_Mack-aroni
14th Mar 2000, 10:23 AM
I am beginning to see how Wanderer gets so confused and frustrated about us asking how to get UnrealEd to work. /~unreal/ubb/html/smile.gif
I had a hell of a time, myself.
Now, I am at 405b and didnt even have to run the UnrealEdInstaller from the second disk. Perhaps I got lucky, I dunno.
Hey, by the way, I have made a Dr. Evil voice pack and I dunno where I should upload it to. I was going to send it to Painful Detail, but Unreality is still down. Any ideas?

Take it easy.




http://www.planetunreal.com/images/bullet2.gif
Da_Mack-aroni
Fear the wrath of my noodles!!!

Goof Slapper
16th Mar 2000, 04:25 PM
So many in the know in this post I thought maybe one of you could take a moment to direct me.
I have done all I can to solve this problem on my own and I am very frustrated. I am trying to make my own skin I followed all the tutorials I could find on how to do this. I did the naming thing right. I saved them in the right format, all that prep work has been done right. When I bring the Images into unrealed and then save out the utx file it seems to work fine. I hand wrote the int file and boom! Away I go, right…
WRONG! They don’t show up. So then I tried Utx2int and it doesn’t see my utx file but sees all the stock utx’s. Next I tried running the overkill pcx’s threw unrealed same problem but Utx2int sees the utx that downloads with the overkill skin pack. So I now believe there is something wrong with My Unrealed (also ran the UnrealEdFix4). Does anybody know what I could be doing wrong? or what could be wrong with my unrealed. Any positive feedback for a frustrated soul would be much appreciated.
Thx, GS

Da_Mack-aroni
17th Mar 2000, 12:40 AM
Well, Goof-ball...if I can call ya that...

I wish I could help you, but I haven't tried makin a skin yet. I fully intend to, but just havent gotten to it yet...

Just bought my new comp so I have to start over, anyway.

Are you sure the .utx is in the right place? I mean in that textures folder? Just a thought...perhaps run a file search for your file.

Other than that...perhaps the Wanderer can help you. He seems to be the UT advice god in here.

Hope you figure it out!!

See ya



http://www.planetunreal.com/images/bullet2.gif
Da_Mack-aroni
Fear the wrath of my noodles!!!

Wanderer
17th Mar 2000, 06:42 PM
If I remember right there was a bug with the first version of that released and it took me ages to figure it out. Problem is I forget what I did.

2 choices. Either get the new version (which should be up by now) or open up an existing, working, .int file and compare the differences. Odds are it's very subtle so pay attention closely.

Hopefully somebody who's a bit more experienced in skinning can help you.