PDA

View Full Version : Lagged Mouse in Direct3D


mborle
13th Feb 2001, 12:20 AM
Greetings,
Just picked up a Creative Annihilator2 today after blowing up my 3D Prophet (lesson: they mean it when they say unplug the power cord from the PC when installing modems. The mainboard got it too). Since replacing the card with this new one, UT's mouse movement is absolutely horrid. It's like a 10th of a second behind, so it almost feels like I am dragging it through water or something. Changing from Direct3D to OpenGL makes the mouse movement better, but Direct3D with it's detailed textures looks far superior. Doing a test, I ran No One Lives Forever which is a Direct3D game, and it has no problems. So I am not ready to blame it on Direct3D itself. (Whew). Also, I did delete the USER.INI and UNREALTOURNAMENT.INI files, which I assume are the only new ones made after a reinstall. Anyone ever run into this?

XxBonesxX
13th Feb 2001, 02:17 AM
Did you completly remove the old driver from your Prophet? I have done it a time or 2 installing a new card and forgeting to clean my system of the old card driver.... Which will cause conflicts via mouse some rendering, and other things. Here is what you can try if that is not the case.. Use a usb adapter for your mouse if it supports it and see if that fixes it. You mention you blew up your other card you might have damaged something internal in your system just a thought..

mborle
13th Feb 2001, 09:51 AM
Normally, I might agree that I blew something else internal, but the fact that the problem *only* comes up with UT makes me think otherwise.
Both cards, being nvidia cards, use the detonators, so they are the same driver. I will try removing/reinstalling both the card and UT after work, for ****s and/or giggles.

XxBonesxX
13th Feb 2001, 11:13 AM
Are you using the detonator 3 driver ?

|H|Alarion
13th Feb 2001, 11:40 AM
These should be attempted in a "if the last one didn't work, try the next" fashion. (in other words, don't do them ALL if one of them works) :)

First: Try reinstalling motherboard drivers (USB, AGP, etc)
Second: Turn "mouse acceleration" off in your mouse control panel
Third: Try turning "USB Error Checking" or whatever it's called (not positive, as I am at work on an older workstation) by going to device manager and opening the properties for your USB "hubs". The option is a little checkbox at the bottom under the "advanced" tab.
Fourth: Try toggling the "use direct input" checkbox in the UT control options.

I have a Tbird and a Prophet2 gts and I get this problem all the time (after installing windows, or sometimes if I need to reinstall UT). The motherboard drivers *usually* fix it, but not always. As well, make sure you are running in 32 bit mode, and that your desktop is also in 32 bit mode.

HTH

Crager
13th Feb 2001, 11:45 AM
Originally posted by |C|Alarion|PuF
These should be attempted in a "if the last one didn't work, try the next" fashion. (in other words, don't do them ALL if one of them works) :)

First: Try reinstalling motherboard drivers (USB, AGP, etc)
Second: Turn "mouse acceleration" off in your mouse control panel
Third: Try turning "USB Error Checking" or whatever it's called (not positive, as I am at work on an older workstation) by going to device manager and opening the properties for your USB "hubs". The option is a little checkbox at the bottom under the "advanced" tab.
Fourth: Try toggling the "use direct input" checkbox in the UT control options.
HTH

I would try number 4 first than 2, 3 and 1 if the others don't work.

|H|Alarion
13th Feb 2001, 01:22 PM
You could, but most people prefer to leave mouse accel *on* and direct input *on*. So those would be things he would be "sacrificing". the mobo driver update doesn't make you sacrifice jack, and is usually the cause of the prob anyhow. :)

mborle
13th Feb 2001, 10:58 PM
Greetings,
Thanks for everyone's help on this one. The solution in the end was to run This GeForce Tweaker (http://www.markborle.comfiles/geforcetweak.zip) and go into the Direct3D panel and turn off FSAA.
Odd that this being on didn't seem to affect other programs, but maybe in the end, it did. I should check out NOLF one more time....
Thanks again guys.